Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want to set homepage using mozilla.cfg file during deployment, but want to allow users to change the homepage later according to them.

  • 2 replies
  • 3 have this problem
  • 14894 views
  • Last reply by mayankv59

more options

I have deployed firefox using local-settings.js, mozilla.cfg and override.ini files.

local-settings.js : pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

mozilla.cfg : //Firefox Default Settings

// set Firefox Default homepage pref("browser.startup.homepage","https://www.yahoo.com");

// disable default browser check pref("browser.shell.checkDefaultBrowser", false); pref("browser.startup.homepage_override.mstone", "ignore");

// disable application updates pref("app.update.enabled", false)

// disables the 'know your rights' button from displaying on first run pref("browser.rights.3.shown", true);

// disables the request to send performance data from displaying pref("toolkit.telemetry.prompted", 2); pref("toolkit.telemetry.rejected", true);

the homepage is getting set properly, but the user is not able to change the homepage later on. plz tell what changes i need to make so that users should be able to change the homepage according to their choice any time.

Chosen solution

hello mayankv59, try to set the following in your mozilla.cfg file:

// set Firefox Default homepage 
defaultPref("browser.startup.homepage", "data:text/plain,browser.startup.homepage=https://www.yahoo.com");

http://mike.kaply.com/2012/08/29/setting-the-default-firefox-homepage-with-autoconfig/

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

hello mayankv59, try to set the following in your mozilla.cfg file:

// set Firefox Default homepage 
defaultPref("browser.startup.homepage", "data:text/plain,browser.startup.homepage=https://www.yahoo.com");

http://mike.kaply.com/2012/08/29/setting-the-default-firefox-homepage-with-autoconfig/

more options

hi mike, thanks for the reply, the solution works..:)