X
Tap here to go to the mobile version of the site.

Support Forum

Why Firefox cannot load pictures?

Posted

Firefox does not load pictures when opened as jpgs in new tab, for example when I click on a thumb to enlarge in new tab, no matter of the image size, I get the message: "Image {{image adress}} cannot be shown, because it contains errors", which is translation from the error in my language I use firefox with.

I used reset to default settings, it did not work, I have displaying images enabled in settings, I cleared my cookies and cache, nothing helped.

And this is not the first time, I expirienced this on multiple computers with various operating systems.

Firefox does not load pictures when opened as jpgs in new tab, for example when I click on a thumb to enlarge in new tab, no matter of the image size, I get the message: "Image {{image adress}} cannot be shown, because it contains errors", which is translation from the error in my language I use firefox with. I used reset to default settings, it did not work, I have displaying images enabled in settings, I cleared my cookies and cache, nothing helped. And this is not the first time, I expirienced this on multiple computers with various operating systems.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 15.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • 5.1.20913.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/WINNT/pl/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • McAfee Security Scan Plus 1.0 ({e4f94d1e-2f53-401e-8885-681602c0ddd8}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 8600 GTS
  • adapterDescription2:
  • adapterDeviceID: 0x0400
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 10-16-2010
  • driverDate2:
  • driverVersion: 6.14.12.6099
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 8600 GTS Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.1.1
  • media.gmp-gmpopenh264.lastUpdate: 1417975209
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1417975207
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 53666
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Please update to Firefox 34 to see if this persists.

Please also check the default codec of the webpage. (View > Character Encoding)

Please update to Firefox 34 to see if this persists. Please also check the default codec of the webpage. (View > Character Encoding)

Question owner

guigs2 said

Please update to Firefox 34 to see if this persists. Please also check the default codec of the webpage. (View > Character Encoding)

I have the latest version. And the problem is now even more frustrating. I can see the image loading, but when it loads to bottom end it becomes greay error screen.

Clearing cookies and cache does not help, I have ckecked every possible option in preferances.

I don't care, I switch to Opera.

''guigs2 [[#answer-662200|said]]'' <blockquote> Please update to Firefox 34 to see if this persists. Please also check the default codec of the webpage. (View > Character Encoding) </blockquote> I have the latest version. And the problem is now even more frustrating. I can see the image loading, but when it loads to bottom end it becomes greay error screen. Clearing cookies and cache does not help, I have ckecked every possible option in preferances. I don't care, I switch to Opera.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

"Image {{image address}} cannot be shown, because it contains errors" is a placeholder that Firefox displays when loading the real image from the server.

If images aren't loaded then they are blocked somehow.

Did you check that your security software isn't blocking the images if the settings in Firefox are correct?

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if any content is blocked and has a file size 0 (zero).


If images are missing then check that you do not block images from some domains. Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

See also:

"Image {{image address}} cannot be shown, because it contains errors" is a placeholder that Firefox displays when loading the real image from the server. If images aren't loaded then they are blocked somehow. Did you check that your security software isn't blocking the images if the settings in Firefox are correct? You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if any content is blocked and has a file size 0 (zero). *https://developer.mozilla.org/Tools/Web_Console ---- If images are missing then check that you do not block images from some domains. Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions" Check "Tools > Page Info > Media" for blocked images *Select the first image link and use the cursor Down key to scroll through the list. *If an image in the list is grayed and "<i>Block Images from...</i>" has a checkmark then remove this checkmark to unblock images from this domain. See also: *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *http://kb.mozillazine.org/Images_or_animations_do_not_load *http://kb.mozillazine.org/Websites_look_wrong