X
Tap here to go to the mobile version of the site.

Support Forum

How can I permanantly prevent a website from offline data storage

Posted

Hello, I noticed that a website which I've never visited (until I noticed it today) is listed in my 'Advanced' 'Network' preferences and even though I can temporarily remove it via the 'Clear Now' button, it later returns.

I've googled the issue and read bewildering lines of code, but I'm not so savvy to know where making those types of changes might lead!

I've got Firefox 33.1 on Mac 10.6.8 and hope someone in the Mozilla community may have a fix.

Thanks

Hello, I noticed that a website which I've never visited (until I noticed it today) is listed in my 'Advanced' 'Network' preferences and even though I can temporarily remove it via the 'Clear Now' button, it later returns. I've googled the issue and read bewildering lines of code, but I'm not so savvy to know where making those types of changes might lead! I've got Firefox 33.1 on Mac 10.6.8 and hope someone in the Mozilla community may have a fix. Thanks

Chosen solution

Hello,

If you enter about:permissions in your address bar and press enter, it should show you a list of sites. You can select the site you do not want storing information, and then set "Maintain Offline Storage" to "Block"

In your advanced options, you can also have "Tell me when a website asks to store data for offline use" selected so all sites ask you, and you can block them.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

CoryMH 229 solutions 1076 answers

Chosen Solution

Hello,

If you enter about:permissions in your address bar and press enter, it should show you a list of sites. You can select the site you do not want storing information, and then set "Maintain Offline Storage" to "Block"

In your advanced options, you can also have "Tell me when a website asks to store data for offline use" selected so all sites ask you, and you can block them.

Hello, If you enter '''about:permissions''' in your address bar and press enter, it should show you a list of sites. You can select the site you do not want storing information, and then set "Maintain Offline Storage" to "Block" In your advanced options, you can also have "Tell me when a website asks to store data for offline use" selected so all sites ask you, and you can block them.

Question owner

Thank you CoryMH for your solution. Very much appreciated.

Thank you CoryMH for your solution. Very much appreciated.

Question owner

Unfortunately the rogue website returned even after blocking the 'maintain offline storage' in about:permissions and the advanced options check box is 'on' in the advanced/network preferences.

Unfortunately the rogue website returned even after blocking the 'maintain offline storage' in about:permissions and the advanced options check box is 'on' in the advanced/network preferences.
CoryMH 229 solutions 1076 answers

Can you check your about:permissions page again to see if the setting was reset? If so, please see the How to fix preferences that won't save article.

It could also be a problem with your permissions.sqlite file, try renaming it to permissions.sqlite.old:

  • Go to your profile folder (Profiles - Where Firefox stores your bookmarks, passwords and other user data):
    • Enter about:support in your address bar and hit enter
    • Click the "Show Folder" button
  • Close Firefox (Menu New Fx Menu > Exit The image "Close-29" does not exist.)
  • Rename the permissions.sqlite to something else, such aspermissions.sqlite.old
  • Restart Firefox - does the problem still occur?
Can you check your '''about:permissions''' page again to see if the setting was reset? If so, please see the [[How to fix preferences that won't save]] article. It could also be a problem with your ''permissions.sqlite'' file, try renaming it to ''permissions.sqlite.old'': * Go to your profile folder ([[Profiles - Where Firefox stores your bookmarks, passwords and other user data]]): ** Enter '''about:support''' in your address bar and hit enter ** Click the "Show Folder" button * Close Firefox (Menu [[Image: New Fx Menu]] > Exit [[Image: Close-29]]) * Rename the ''permissions.sqlite'' to something else, such as''permissions.sqlite.old'' * Restart Firefox - does the problem still occur?

Question owner

Sorry, I'm not too good at this but where do I find this file- permissions.sqlite

and where is the profiles folder please?

Sorry, I'm not too good at this but where do I find this file- permissions.sqlite and where is the profiles folder please?
CoryMH 229 solutions 1076 answers

To get to the profiles folder:

  • Enter about:support in your address bar and hit enter
  • Click the "Show Folder" button
To get to the profiles folder: * Enter about:support in your address bar and hit enter * Click the "Show Folder" button
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Were do you see this website listed?

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

You can't block website from showing in the disk cache unless you access these pages in Private Browsing mode.


The offline cache AKA as the application cache is only used in very special cases and shouldn't be confused with the disk and memory cache. It is the last section that is present on the about:cache page (open via the location/address bar).

Were do you see this website listed? Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB You can't block website from showing in the disk cache unless you access these pages in Private Browsing mode. ---- The offline cache AKA as the application cache is only used in very special cases and shouldn't be confused with the disk and memory cache. It is the last section that is present on the about:cache page (open via the location/address bar).

Question owner

OK. I've renanmed the 'permissions.sqlite as permissions.sqlite.old. Was asked if changing its file extension to 'old' from 'sqlite' & said yes.

'about:permissions'/'manage offline storage' still blocked & advanced/network still clear so rogue website not back so far.

OK. I've renanmed the 'permissions.sqlite as permissions.sqlite.old. Was asked if changing its file extension to 'old' from 'sqlite' & said yes. 'about:permissions'/'manage offline storage' still blocked & advanced/network still clear so rogue website not back so far.

Question owner

The rogue website appears in this (empty atm) window.

The rogue website appears in this (empty atm) window.
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Can you post another screenshot once you see it appearing again?

Does it appear in the lower text area?


You can toggle the browser.cache.offline.enable pref to false to disable the offline cache or possibly set the offline-apps.quota.warn pref to a lower value.

Can you post another screenshot once you see it appearing again? Does it appear in the lower text area? ---- You can toggle the browser.cache.offline.enable pref to false to disable the offline cache or possibly set the offline-apps.quota.warn pref to a lower value.

Question owner

I found multiple entries for it in-

Disc 'list cache entries' although nothing has appeared in the window I previously uploaded (Advanced/Network

I found multiple entries for it in- Disc 'list cache entries' although nothing has appeared in the window I previously uploaded (Advanced/Network
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

That is the regular disk cache and not the offline cache mentioned above. You do not have control over what is stored there and it normally would pose a problem. As I wrote above, you can visit websites in Private Browsing mode to prevent Firefox from storing data on in the Firefox profile folder.

That is the regular disk cache and not the offline cache mentioned above. You do not have control over what is stored there and it normally would pose a problem. As I wrote above, you can visit websites in Private Browsing mode to prevent Firefox from storing data on in the Firefox profile folder.

Question owner

OK thanks. I'll start using the private browsing function.

Weird thing is I've never been to that website, so I'm puzzled how it's managed to get on to my computer in the first place. That & I always browse with Cookies disabled.

OK thanks. I'll start using the private browsing function. Weird thing is I've never been to that website, so I'm puzzled how it's managed to get on to my computer in the first place. That & I always browse with Cookies disabled.
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

You can check the browsing history to see if what websites you have visited during the time he entries were created.

You can check for recently installed suspicious or unknown extensions.


Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

You can check the browsing history to see if what websites you have visited during the time he entries were created. You can check for recently installed suspicious or unknown extensions. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware

Question owner

Is there an OSX version for those malware programs?

Thanks also for your help.

Is there an OSX version for those malware programs? Thanks also for your help.

Question owner

Oh no! What have I done? Did a restore to default browser settings then found I no longer had control over cookies. Websites now dumped in all cookies where previously I had control over 3rd party ones. Tried swapping the 'profiles' from an earlier version, now downloading the latest F/F won't even open as it know the profiles aren't there.

Oh no! What have I done? Did a restore to default browser settings then found I no longer had control over cookies. Websites now dumped in all cookies where previously I had control over 3rd party ones. Tried swapping the 'profiles' from an earlier version, now downloading the latest F/F won't even open as it know the profiles aren't there.

Question owner

Managed to swap back to my original profile in User/Library/Application support/Firefox/Profiles. Now is it possible to have my control over 3rd party cookies again? ATM wherever I browse my Privacy window is loaded.

Managed to swap back to my original profile in User/Library/Application support/Firefox/Profiles. Now is it possible to have my control over 3rd party cookies again? ATM wherever I browse my Privacy window is loaded.
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Helpful Reply

You can allow third-party cookies only from visited domains.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"

You can set the network.cookie.thirdparty.sessionOnly pref to true on the about:config page to make third-party cookies behave as session cookies that expire when Firefox is closed.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can allow third-party cookies only from visited domains. *Tools > Options > Privacy > Firefox will: "Use custom settings for history" You can set the <b>network.cookie.thirdparty.sessionOnly</b> pref to true on the <b>about:config</b> page to make third-party cookies behave as session cookies that expire when Firefox is closed. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

Thank you cor-el for your assistance. I am again 'situation normal' & no sign of the rogue website which was the core of my problem.

Awesome community!

Thank you cor-el for your assistance. I am again 'situation normal' & no sign of the rogue website which was the core of my problem. Awesome community!