Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get "This Connection is Untrusted" on every website?

  • 13 replies
  • 71 have this problem
  • 17634 views
  • Last reply by tgirl026

more options

I've uninstall firefox and changed the time and I can't get the bowser to work. Every single webpage gets the This Connection is Untrusted message. Every website gets the error message (Error code: sec_error_unknown_issuer). I don't have any problems with IE only firefox won't work. I just bought the computer 2 days ago so im sure its not a virus. I have Kaspersky internet security

All Replies (13)

more options

Hello,

Please see the article "This Connection is Untrusted" error message appears - What to do.

It sounds like the file cert8.db in your profile folder may have become corrupted. Delete this file while Firefox is closed.

If you need help finding this file, open your profile folder:

  • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.
  • Under the Application Basics section, click on Show Folder. A window with your profile files will open.

Exit Firefox, and click delete the file named cert8.db. Restart Firefox - does the problem still occur?

more options

No, I can get on some websites now but google.com and others still get the same message. But I can get to facebook now.

more options

Sometimes this problem can be experienced when your system clock is out of sync. Do you have your clock automatically syncing to time.windows.com?

more options

No, I had to set the clock manually. I never heard of time.windows.com

more options

does it make a difference when you check in the firefox menu ≡ > options > advanced > network > connection - settings... that firefox is set up to directly connect to the internet ('no proxy')?

more options

I am assuming you are using Windows. If you click on your clock on the taskbar (usually located at the bottom right corner of the screen), an option to "Change date and time settings..." should pop up. One of the tabs there will be "Internet Time", and over there you can change your settings to periodically sync your clock with an online server.

more options

I have windows 8.1. Changing the settings to No Proxy didn't work and syncing my clock to time.windows.com didn't work either. The only thing that helped was deleting the cert8.db file; howevr some websites like, google, yahoo, and gmail keep getting "This Connection is Untrusted" message. I looked under Certificate status and found that the error was issued by Kaspersky Anti-Virus Personal Root Certificate. I tried unchecking the "Scan encrypted connections" but that also didn't work

more options

After unchecking "Scan encrypted connections", did you restart your computer?

If that doesn't work, it might be better to post on those forums as there might be a setting in Kaspersky that you need to change. (The 7th Important topic they refer to is this post, which tells you what they need for them to help you: http://forum.kaspersky.com/index.php?showtopic=915)

Modified by CoryMH

more options

It's definitely Kaspersky, some pages still get the error message and I just find out that flash doesn't work in firefox. Chrome and ie work fine but I have to pause Kaspersky to get firefox to work. I had to submit a ticket because I couldn't find anything on their forms and the agent on their chat page couldn't help. Thanks everyone for all your help

more options

If you use KASPERSKY, this is the solution they emailed to me when I encountered this problem. It worked wonderfully.

Here are the steps on what you need to do:


To Show hidden files, folders and drives:

Go to the Start Menu Open up My Documents folder On your keyboard, press and hold 'Alt' key then press 'T' to open the Tools Menu. On the list, please click on 'Folder Options' Go to 'View' tab. Under Advanced Settings, please select or choose 'Show hidden files, folders and drives'. Click on 'Apply' then 'Ok'. Then close the My Documents window.


Deleting and Importing Certificate:

Open up Firefox, click the 'Open Menu' icon or the three horizontal lines. Go to Options Go to the Advanced tab in the top right Click on 'Certificates' tab Click on 'View Certificates' button Under Authorities you will find one or more "KasperskyAnti-VirusPersonalRootCertificate" Select the certificate then delete the file(s).

Select the Import button. Browse to C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\ select the (fake)Kaspersky Anti-Virus Personal Root Certificate, and press open. When importing the certificate, there are three options, select the option for "Trust this CA to identify websites" then press OK on all the windows to save the settings.


Please close the Firefox window and reopen the program then try to access sites again. If the steps stated above solved the issue, follow the steps on how to 'Show hidden files, folders and drives' and please select/choose ' Do not Show hidden files, folders and drives' to restore the default setting.

more options

It didn't work. I could not find KasperskyAnti-VirusPersonalRootCertificate in firefox. I have windows 8.1 so I don't have a start button. I made hidden folders viewable from the control panel, but I couldn't find the certificate

more options

Do the steps posted at this forum work?

1 Go to SETTINGS 2 Click on the BROWN BOX icon 3 Go to NETWORK 4 Click on INSTALL CERTIFICATE (Kaspersky security certificate) follow install instructions. You can also import the Kaspersky root certificate in the Certificate Manager.

more options

Sorry that didn't work either. I think that thread was for an older version of Kaspersky, There are no brown boxes anymore. I went to SETTINGS>>> ADDITIONAL>> NETWORK,. I checked the Scab encrypted connections box. and then clicked the "Advanced setting" hyperlink. Last I did step 4 "Click on INSTALL CERTIFICATE (Kaspersky security certificate) follow install instructions." Nothing happened.