Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

GNU/Linux: Address bar prepends http:// when performing single-word searches.

  • 4 replies
  • 1 has this problem
  • Last reply by Zarrrdoz

more options

When using the address bar to perform a single-word search, Firefox prepends http:// to the search word, breaking the search. This behavior does not occur when two or more search words are entered.

This behavior occurs when using the latest release version of Firefox on 64-bit GNU/Linux. It does not occur when using the latest version on 64-bit Windows.

All Replies (4)

more options

I don't know if this will help;

more options

Thank you for your suggestion, but I am afraid that I did not find a solution therein.

more options

It is usually best to use a (one letter) keyword search (bookmark or manage search engines) or use the search bar for one word searches to prevent Firefox from doing a fix up and look up.

more options

The search engine field is less efficient. When opening a new tab, the cursor is in the address field, instantly ready for searching.

The workarounds suggested are not necessary on Windows--it just works. There must be something different in the GNU/Linux version, which causes it to treat single-word searches...differently.