Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The OCSP server suggests trying again later

  • 2 replies
  • 1 has this problem
  • 29 views
  • Last reply by cor-el

more options

I am getting this error message when trying to access my site from Firefox, however no other browser (IE, Chrome, Safari) is experiencing this issue.

https://www.core-e.biz

I have a valid ssl cert installed on my server, and haven't had any problems until people tried to use Firefox to browse my site. The exact error message I get is:

Secure Connection Failed

An error occurred during a connection to www.core-e.biz

The OCSP server suggest trying again later.

(Error code: sec_error_ocsp_try_server_later)

All Replies (2)

more options

hello, if offered by the server firefox will use a technology called ocsp stapling (which isn't supported or switched on in other browsers by default yet) to check if a certificate is revolved and might throw the error page you're seeing when the response is faulty: https://blog.mozilla.org/security/2013/07/29/ocsp-stapling-in-firefox/

this is a time-sensitive operation, so maybe check that the clock of your webserver is set correctly, or otherwise contact the support of your cert's provider to inquire what is goign wrong or else disable ocsp stapling on your server.

more options

Works for me in Firefox 32.

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.