X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Login popup for Instagram won't load. Works fine in IE.

Posted

Instagram is one of a few sites that choke on loading a login screen in Firefox 32.0.2. The login popup spins endlessly, but works fine in other browsers. CNET is another site which has terrible troubles with Firefox. BrightHouse Networks sites also stall on Firefox. Tried everything: deleting History, deleting relevant cookies, checking Hosts list, etc etc.

Instagram is one of a few sites that choke on loading a login screen in Firefox 32.0.2. The login popup spins endlessly, but works fine in other browsers. CNET is another site which has terrible troubles with Firefox. BrightHouse Networks sites also stall on Firefox. Tried everything: deleting History, deleting relevant cookies, checking Hosts list, etc etc.

Modified by Mr. News

Chosen solution

Solved it! I have the Do Not Track Me add-on, and it was blocking two trackers on the Instagram sign-in page. Allowing Google Analytics didn't help, but Facebook Connect is apparently required to allow Instagram login. I'm blocking all cookies, but no trackers, in IE, so that's why it was able to log in there.

-)
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Zoom Launcher
  • Next Generation Java Plug-in 11.20.2 for Mozilla browsers
  • Google Update
  • Citrix Online App Detector Plugin
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Intel web components updater - Installs and updates the Intel web components
  • Plugin for Wacom tablets.
  • NPWLPG
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

David Tenser 30 solutions 310 answers

This is most likely an issue with obsolete cache. I've experienced this myself sometimes, specifically on Instagram.

The instructions can be found here: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Let me know if this solves the problem. Thanks!

- David

This is most likely an issue with obsolete cache. I've experienced this myself sometimes, specifically on Instagram. The instructions can be found here: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache Let me know if this solves the problem. Thanks! - David

Helpful Reply

Nope. Cleared both web cache and offline cache, and Instagram log-in box still has the endlessly spinning circle... Works fine on IE, which I rarely use, but now more and more...

Nope. Cleared both web cache and offline cache, and Instagram log-in box still has the endlessly spinning circle... Works fine on IE, which I rarely use, but now more and more...

Chosen Solution

Solved it! I have the Do Not Track Me add-on, and it was blocking two trackers on the Instagram sign-in page. Allowing Google Analytics didn't help, but Facebook Connect is apparently required to allow Instagram login. I'm blocking all cookies, but no trackers, in IE, so that's why it was able to log in there.

-)
Solved it! I have the Do Not Track Me add-on, and it was blocking two trackers on the Instagram sign-in page. Allowing Google Analytics didn't help, but Facebook Connect is apparently required to allow Instagram login. I'm blocking all cookies, but no trackers, in IE, so that's why it was able to log in there. :-)
the cunning linguist 0 solutions 1 answers

Open the social media site you are having problems with Click Log In While on this frozen page: View menu > Page Style > No Style Now login with your credentials View menu > Page Style > Basic Page Style Voila!

List of tried-but-did-not-work items for reference:

  • Creating a new Firefox profile
  • Starting Firefox in Safe Mode
  • about:config settings: "network.http.sendRefererHeader" was 2 already
  • Clearing both web cache and offline cache
Open the social media site you are having problems with Click Log In While on this frozen page: View menu > Page Style > No Style Now login with your credentials View menu > Page Style > Basic Page Style Voila! List of '''tried-but-did-not-work '''items for reference: * Creating a new Firefox profile * Starting Firefox in Safe Mode * about:config settings: "network.http.sendRefererHeader" was 2 already * Clearing both web cache and offline cache