X
Tap here to go to the mobile version of the site.

Support Forum

How can I speed up the scrolling of my middle mouse button?

Posted

When I try to scroll down using the middle mouse button, it goes so slowly that I can't stand it, so I use the scroll bar to the right. This is annoying to me. When I reset the mouse button on my windows to more lines, it makes it scroll too fast for my docs, but does not affect the scrolling in FireFox. I've looked for tools and options for this, and can't find anything to do about it.

When I try to scroll down using the middle mouse button, it goes so slowly that I can't stand it, so I use the scroll bar to the right. This is annoying to me. When I reset the mouse button on my windows to more lines, it makes it scroll too fast for my docs, but does not affect the scrolling in FireFox. I've looked for tools and options for this, and can't find anything to do about it.

Chosen solution

You could try changing one (or both) of these hidden settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste wheel and pause while the list is filtered

(3A) Double-click the mousewheel.default.delta_multiplier_y preference and type in a higher value to make each movement of the wheel cover more ground. For example, you could try 300 or 500. You can keep this tab open and experiment with scrolling in a different tab until you find a value that gives you the speed you're looking for.

(3B) Double-click the mousewheel.system_scroll_override_on_root_content.vertical.factor preference and type in a higher value. For example, try changing 200 to 500. You can keep this tab open and experiment with scrolling in a different tab until you find a value that gives you the speed you're looking for.

I'm not sure I understand the reason there are two such similar preferences. Do either of them do what you want?

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Version 5.4.2.18903
  • 5.1.30514.0
  • FireFox PDF Architect Previewer
  • Pokki Download Helper
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • NPWLPG

Application

  • Firefox 32.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0/WINNT/en-US/

Extensions

  • Autofill Forms 1.0.1 (autofillForms@blueimp.net)
  • ChatZilla 0.9.90.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Classic Theme Restorer 1.2.3 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Down for Everyone or Just me 0.2 (jid1-BQlYZao7HHmGLw@jetpack)
  • gTranslate 0.9 ({aff87fa2-a58e-4edd-b852-0a20203c1e17})
  • Hide My Ass Proxy Extension 1.2.7 (extension@hidemyass.com)
  • NoScript 2.6.8.40 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • PDF Architect Converter For Firefox 1.0 (FFPDFArchitectConverter@pdfarchitect.com)
  • Simple Timer 2.0.2 (simpletimer@grbradt.org)
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Status-4-Evar 2014.07.06.05 (status4evar@caligonstudios.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Wiktionary and Google Translate 7.1 (googledictionary@toptip.ca)
  • FitBolt Firefox Addon 3.7 (jid1-Alhd9pNI2YZTAg@jetpack) (Inactive)
  • Helper 1.0.0 (dnshelp@dnshelp.com) (Inactive)
  • MAFIAAFire: ThePirateBay Dancing! 0.3.3.2.10102012 (thepiratebay@mafiaafire.com) (Inactive)
  • PriceSparrow 1.4.9 (extension@pricesparrow.com) (Inactive)
  • StretchClock - Desk Yoga Break Reminder. Feel better, be more productive. 2.0.3 (info@stretchclock.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7640G
  • adapterDescription2:
  • adapterDeviceID: 0x9903
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 12-6-2013
  • driverDate2:
  • driverVersion: 13.251.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7640G Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140825202822
  • browser.startup.homepage: http://grokwisdom.org/gendlinexercise.php
  • browser.startup.homepage_override.buildID: 20140825202822
  • browser.startup.homepage_override.mstone: 32.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 32.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1410241842
  • places.history.expiration.transient_current_max_pages: 93173
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1409550667

Misc

  • User JS: No
  • Accessibility: No
CoryMH 229 solutions 1076 answers

You can change the number of lines Firefox scrolls in the about:config page, the variable will be called "mousewheel.min_line_scroll_amount", try changing it from 5 to 60, or whatever suits you.


In order to change your Firefox Configuration please do the following steps :

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
You can change the number of lines Firefox scrolls in the about:config page, the variable will be called "mousewheel.min_line_scroll_amount", try changing it from 5 to 60, or whatever suits you. ---------------------------------------------------------------------- In order to change your Firefox Configuration please do the following steps : # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''' to continue to the about:config page.
jscher2000
  • Top 10 Contributor
7930 solutions 64774 answers

Chosen Solution

You could try changing one (or both) of these hidden settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste wheel and pause while the list is filtered

(3A) Double-click the mousewheel.default.delta_multiplier_y preference and type in a higher value to make each movement of the wheel cover more ground. For example, you could try 300 or 500. You can keep this tab open and experiment with scrolling in a different tab until you find a value that gives you the speed you're looking for.

(3B) Double-click the mousewheel.system_scroll_override_on_root_content.vertical.factor preference and type in a higher value. For example, try changing 200 to 500. You can keep this tab open and experiment with scrolling in a different tab until you find a value that gives you the speed you're looking for.

I'm not sure I understand the reason there are two such similar preferences. Do either of them do what you want?

You could try changing one (or both) of these hidden settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''wheel''' and pause while the list is filtered (3A) Double-click the '''mousewheel.default.delta_multiplier_y''' preference and type in a higher value to make each movement of the wheel cover more ground. For example, you could try 300 or 500. You can keep this tab open and experiment with scrolling in a different tab until you find a value that gives you the speed you're looking for. (3B) Double-click the '''mousewheel.system_scroll_override_on_root_content.vertical.factor''' preference and type in a higher value. For example, try changing 200 to 500. You can keep this tab open and experiment with scrolling in a different tab until you find a value that gives you the speed you're looking for. I'm not sure I understand the reason there are two such similar preferences. Do either of them do what you want?

Helpful Reply

These two responses worked great! I think I need to go back and rejigger it, because now it's too fast, but I know what to do, now. Thanks to both of you.

These two responses worked great! I think I need to go back and rejigger it, because now it's too fast, but I know what to do, now. Thanks to both of you.
cor-el
  • Top 10 Contributor
  • Moderator
16722 solutions 151190 answers

You can also try to modify the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page to see if that makes a difference with smooth scrolling enabled.

You can also try to modify the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page to see if that makes a difference with smooth scrolling enabled.