Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When using IMAP: cannot find the option to set "leave downloaded message on server for xx days"

  • 3 replies
  • 9 have this problem
  • 45056 views
  • Last reply by Matt

more options

Own 4 machines (2x win7 with serversetting POP, 2x win8.1 with serversetting IMAP). All machines have Thunderbird version 31.0 (dutch) installed. The IMAP machines will erase downloaded messages from the server. Unfortunatley I cannot find the setting to leave these messages on the server. Now when I use the win7 machines with POP setting (after the one of the other Win machines with IMAP setting were used) the messages will not appear anmore. On the machines using POP on the server settings screen this option for leaving the messages on the server is clearly shown (and active), wereas on the others it is not shown at all. Please clearify.

Fred Knijf (Netherlands)

Chosen solution

IMAP has no "Keep mail on the server for XX days" because mail MUST be kept on the server it is inherent in the whole IMAP protocol.

If mail is disappearing it is most likely your pop machine not honoring the leave on server setting for some reason (it is not 100% when set to so many days)

Read this answer in context 👍 2

All Replies (3)

more options

re: The IMAP machines will erase downloaded messages from the server. Unfortunatley I cannot find the setting to leave these messages on the server.

IMAP mail accounts see a remote view of the emails in folders on the server. You subscribe to see folders and headers are downloaded. When you click to read an email, a copy of the folder is downloaded to a temporary file to facilitate quicker access. If you sychronise subscribed folders then a copy is downloaded to the Thunderbird Profile, but this folder is constantly updated to match the server. If you delete any emails in any IMAP mail account folder then you are deleting off the server. If you delete any emails off the server via webmail then when Thunderbird synchronises with the server, it will show you a copy and the emails you deleted off the server will also be deleted off Thunderbird. The folders are one and the same.

if you want to keep a copy on your computer but delete off server, then synchronise the folder to get a copy, then go offline and then move the email into Local folders, which stores email on the computer and is not connected to the IMAP server. Then you can go back online and delete the email in the IMAP account, this will delete the email off the server. If you see emails you have deleted still on the server, then compact the folder. Right click on folder and select 'compact'.

You can set Thunderbird to auto expunge deleted emails off server here: "Tools -> Account Settings -> Server Settings for the IMAP mail account Select: Clean up ("Expunge") Inbox on Exit it will compact the Inbox folder when you exit Thunderbird.

If you check "Empty Trash on Exit" it will also empty and compact the Trash folder when you exit. Click on OK to save changes.

More info on deleting in IMAP mail accounts:

more info on IMAP mail accounts:


Pop mail accounts can only access the server Inbox, those emails are downloaded to Thunderbird profile and are on your computer. by default those messages on the server will be deleted. However, you can choose whether to keep messages on the server or not.

more options

Dear Toad Hall, I want to keep de e-mails on the server. I do not need help to delete the mails. They disappear without help. I want to keep them for download on another machine as explained in the question. Will my provider be able to solve this? Thanks anyway

Fred Knijf

more options

Chosen Solution

IMAP has no "Keep mail on the server for XX days" because mail MUST be kept on the server it is inherent in the whole IMAP protocol.

If mail is disappearing it is most likely your pop machine not honoring the leave on server setting for some reason (it is not 100% when set to so many days)