X
Tap here to go to the mobile version of the site.

Support Forum

Can't play flash videos in Firefox

Posted

I am unable to play flash video content from facebook or CNN. I am using Firefox 31 and Flash 14.0.0.179 (32 bit) running under Windows 7 Pro. I also have the 64 bit version installed for use with internet explorer. These videos play fine in internet explorer, but not in Firefox. CNN videos stopped playing in Firefox months ago, and Facebook stopped within the last few days.

I started Firefox in safe mode, reset Firefox, uninstalled and reinstalled flash, and uninstalled and reinstalled the latest realplayer (found that suggestion online). So far, nothing has helped.

CNN Videos just freeze once the player control bar appears at the bottom of the frame. The ad plays, but freezes when the actual news video starts.

Facebook shows the thumbnail for the video (will not autoplay like it does in IE) and when you click it you get the pop-up window with the user comments to the right but just a black square where the video should be playing.

If I right click and go to settings for flash, when I click disable hardware acceleration, it re-enables it as soon as I click close on the setting screen. When I go back to settings the box is checked again.

I am unable to play flash video content from facebook or CNN. I am using Firefox 31 and Flash 14.0.0.179 (32 bit) running under Windows 7 Pro. I also have the 64 bit version installed for use with internet explorer. These videos play fine in internet explorer, but not in Firefox. CNN videos stopped playing in Firefox months ago, and Facebook stopped within the last few days. I started Firefox in safe mode, reset Firefox, uninstalled and reinstalled flash, and uninstalled and reinstalled the latest realplayer (found that suggestion online). So far, nothing has helped. CNN Videos just freeze once the player control bar appears at the bottom of the frame. The ad plays, but freezes when the actual news video starts. Facebook shows the thumbnail for the video (will not autoplay like it does in IE) and when you click it you get the pop-up window with the user comments to the right but just a black square where the video should be playing. If I right click and go to settings for flash, when I click disable hardware acceleration, it re-enables it as soon as I click close on the setting screen. When I go back to settings the box is checked again.

Chosen solution

Crashes or other problems with certain multimedia content in Firefox (such as Youtube videos and Flash animations or games) can often be resolved by performing the steps in these Knowledge Base articles:

On Windows Vista and above, you can disable Flash protected mode by following the instructions on these pages:

(See this Adobe blog post for technical details about Flash protected mode.)

Please tell us if this helped!

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.11
  • This plug-in enables downloading of HTML5 videos
  • Google Update
  • 5.1.30514.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • iTunes Detector Plug-in
  • DYMO Label Framework Plugin
  • GEPlugin
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG
  • Plug-in for detecting Nero Kwik Media.
  • Windows Activation Technologies Plugin for Mozilla
  • MetaStream 3 Plugin r4

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Norton Toolbar 2014.7.6.15 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.2.0.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)
  • RealDownloader 17.0.13 ({9D2AA73B-6049-4799-B8AC-925723370070}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: VisionTek Radeon 4350
  • adapterDescription2:
  • adapterDeviceID: 0x955f
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 2-14-2012
  • driverDate2:
  • driverVersion: 8.950.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (VisionTek Radeon 4350 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage: http://www.msn.com/
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled: False
  • dom.ipc.plugins.enabled.npctrl.dll: False
  • dom.ipc.plugins.enabled.npqtplugin.dll: False
  • dom.ipc.plugins.enabled.npswf32.dll: False
  • dom.ipc.plugins.enabled.nptest.dll: False
  • dom.ipc.plugins.flash.subprocess.crashreporter.enabled: False
  • dom.ipc.plugins.reportCrashURL: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
Carm 5 solutions 178 answers

Flash content and the plugin-container have always been an issue for years now in Firefox. There have ALWAYS been the same suggestions over and over and over.. like a revolving door , and many people have tried them if you browse the forums. This does NOT happen in Internet Explorer or Chrome btw.. its a clear problem with the plugin-container.

I have an unorthidox method that involves wiping certain prefetch files on a regular basis. I am NOT saying this will resolve your issue, however you can try manually wiping them to see if it works in cmd prompt.

del "C:\Windows\Prefetch\flashpl*.pf" /q /f del "C:\Windows\Prefetch\PLUGIN-CONTAINER*.pf" /q /f del "C:\Windows\Prefetch\FIREFOX.EXE*.pf" /q /f del "C:\Windows\Prefetch\FLASHPLAYERUPDATESERVICE*.pf" /q /f

You can also read about my other fixes.. clink on my profile and there is a link to my blog that explains it in detail.

Best regards

Flash content and the plugin-container have always been an issue for years now in Firefox. There have ALWAYS been the same suggestions over and over and over.. like a revolving door , and many people have tried them if you browse the forums. This does NOT happen in Internet Explorer or Chrome btw.. its a clear problem with the plugin-container. I have an unorthidox method that involves wiping certain prefetch files on a regular basis. I am NOT saying this will resolve your issue, however you can try manually wiping them to see if it works in cmd prompt. del "C:\Windows\Prefetch\flashpl*.pf" /q /f del "C:\Windows\Prefetch\PLUGIN-CONTAINER*.pf" /q /f del "C:\Windows\Prefetch\FIREFOX.EXE*.pf" /q /f del "C:\Windows\Prefetch\FLASHPLAYERUPDATESERVICE*.pf" /q /f You can also read about my other fixes.. clink on my profile and there is a link to my blog that explains it in detail. Best regards

Question owner

Thanks for the tips. Unfortunately it didn't seem to help. I have another machine running XP and flash still works there under Firefox. It only seems to be an issue with the Windows 7 machine..

Thanks for the tips. Unfortunately it didn't seem to help. I have another machine running XP and flash still works there under Firefox. It only seems to be an issue with the Windows 7 machine..
FredMcD
  • Top 10 Contributor
3039 solutions 40980 answers

With the last Firefox upgrade, some plugins are no longer enabled until you enable it.

Open the Add-ons Manager by Pressing the Alt or F10 key to bring up the tool bar. Followed by; Tools > Add-ons.

Hot key; <Control> (Mac: <Command>) <Shift> A)

On the left side of the page, select Plugins.

BTW; At the top right is a link to check your plugins.

With the last Firefox upgrade, some plugins are no longer enabled until you enable it. Open the Add-ons Manager by Pressing the '''Alt''' or '''F10''' key to bring up the tool bar. Followed by; '''Tools > Add-ons.''' Hot key; '''<Control> ''(Mac: <Command>)'' <Shift> A)''' On the left side of the page, select Plugins. BTW; At the top right is a link to check your plugins.
FredMcD
  • Top 10 Contributor
3039 solutions 40980 answers

Chosen Solution

Crashes or other problems with certain multimedia content in Firefox (such as Youtube videos and Flash animations or games) can often be resolved by performing the steps in these Knowledge Base articles:

On Windows Vista and above, you can disable Flash protected mode by following the instructions on these pages:

(See this Adobe blog post for technical details about Flash protected mode.)

Please tell us if this helped!

Crashes or other problems with certain multimedia content in Firefox (such as Youtube videos and Flash animations or games) can often be resolved by performing the steps in these Knowledge Base articles: * [[Flash Plugin - Keep it up to date and troubleshoot problems]] * [[Flash 11.3 crashes]] * [[Flash 11.3 doesn't load video in Firefox]] On Windows Vista and above, you can disable Flash protected mode by following the instructions on these pages: * http://forums.adobe.com/thread/1018071#TemporaryWorkaround * http://kb.mozillazine.org/Flash#Disabling_Protected_Mode_in_Flash_11.3 (See [http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html this Adobe blog post] for technical details about Flash protected mode.) Please tell us if this helped!
cor-el
  • Top 10 Contributor
  • Moderator
15347 solutions 139140 answers

Why do you have the plugin-container process disabled?

Your System Details list shows:

  • dom.ipc.plugins.enabled: False
  • dom.ipc.plugins.enabled.npctrl.dll: False
  • dom.ipc.plugins.enabled.npqtplugin.dll: False
  • dom.ipc.plugins.enabled.npswf32.dll: False
Why do you have the plugin-container process disabled? *http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins Your System Details list shows: *dom.ipc.plugins.enabled: False *dom.ipc.plugins.enabled.npctrl.dll: False *dom.ipc.plugins.enabled.npqtplugin.dll: False *dom.ipc.plugins.enabled.npswf32.dll: False

Helpful Reply

Disabling the plug-in container was just a suggestion I was trying out. It has since been enabled.

Disabling the plug-in container was just a suggestion I was trying out. It has since been enabled.

Question owner

FredMcD thanks!! Disabling the Flash protected mode by adding ProtectedMode=0 to the mms.cfg file fixed the problem. Flash videos now play fine on facebook and cnn.

FredMcD thanks!! Disabling the Flash protected mode by adding ProtectedMode=0 to the mms.cfg file fixed the problem. Flash videos now play fine on facebook and cnn.
FredMcD
  • Top 10 Contributor
3039 solutions 40980 answers

Helpful Reply

Glad to help.

Glad to help.
fkbreitl 0 solutions 14 answers

From https://support.mozilla.org/en-US/questions/1014982#answer-626060

I had the same problem on Windows 7 with Firefox 32 and could fix it by deleting the folders

%AppData%\Roaming\Macromedia\Flash Player %AppData%\Local\Macromedia\Flash Player

Explanation: I realized that it had to do with my user configuration files by verifying with the Windows guest account that Firefox can play the video fine. Since also resetting my Firefox account didn't help, I suspected the Flash config to cause a problem.

From https://support.mozilla.org/en-US/questions/1014982#answer-626060 I had the same problem on Windows 7 with Firefox 32 and could fix it by deleting the folders %AppData%\Roaming\Macromedia\Flash Player %AppData%\Local\Macromedia\Flash Player Explanation: I realized that it had to do with my user configuration files by verifying with the Windows guest account that Firefox can play the video fine. Since also resetting my Firefox account didn't help, I suspected the Flash config to cause a problem.