X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

pdf files now have a firefox icon

Posted

WIN XP. Have checked file association settings and pdf files are directed towards using Adobe reader. Completed uninstall of FFox31 and icons changed back to Adobe. Cleaned computer and carried out clean install. Icons remained as pdf for two restarts and then changed back to FFox icons. Everything works normally but the icons remain as FFox. Have set FFox application options to 'always ask' temporarily. I have a second WinXP machine that has upgraded to FFox 31 without this problem. Strange!

WIN XP. Have checked file association settings and pdf files are directed towards using Adobe reader. Completed uninstall of FFox31 and icons changed back to Adobe. Cleaned computer and carried out clean install. Icons remained as pdf for two restarts and then changed back to FFox icons. Everything works normally but the icons remain as FFox. Have set FFox application options to 'always ask' temporarily. I have a second WinXP machine that has upgraded to FFox 31 without this problem. Strange!

Chosen solution

Hi CMBANA. I had exactly the same problem as you, and after a lot of searching couldn't find an answer that worked.

But I have now solved the problem of pdf files appearing as Firefox HTML documents. Perhaps you could try this, and hopefully it should work for you.

First of all, it wasn't entirely a Firefox problem. The solution is also within Adobe Reader itself.

1. Open Adobe Reader 2. Edit->Preferences 3. In the Categories column click 'General' 4. Near the bottom of the page click the button marked 'Select Default PDF Handler' 5 In the dialog, select 'Adobe Reader XI' and click 'Apply' 6. A Windows Configuration screen will appear. Allow it to do its stuff (takes a few minutes), then restart your computer when prompted.

After restarting you should find that all your PDF documents have returned to being Adobe Acrobat Documents, and have the appropriate icon. I also noticed that in the Firefox application options the option 'use Adobe Reader (default)' had appeared. You can then tweak the Firefox Application options as described in earlier posts according to how you want Firefox to handle the document, eg whether to preview it, download it, or open it directly with Adobe Reader.

Took a lot of sorting out, but it now works. Hope it does the same for you.

Read this answer in context 18

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Google Update
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.10
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • 1.0.0.8
  • 1,2,0,2022
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-GB/

Extensions

  • 1-Click YouTube Video Downloader 2.3.4 (YoutubeDownloader@PeterOlayev.com)
  • Disconnect 3.14.0 (2.0@disconnect.me)
  • DoNotTrackMe: Online Privacy Protection 3.2.1127 (donottrackplus@abine.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6150 LE
  • adapterDescription2:
  • adapterDeviceID: 0x0241
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-9-2006
  • driverDate2:
  • driverVersion: 8.2.0.8
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150 LE Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage: https://www.scbeasy.com/v1.4/site/presignon/index_en.asp
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.blacklist.layers.direct3d9: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1407669074
  • places.history.expiration.transient_current_max_pages: 25127
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1406254404

Misc

  • User JS: Yes
  • Accessibility: No
Sourjobraato Banerjee 14 solutions 232 answers

Hello,

In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps:

  1. Go to Tools > Options (or Firefox > Options).
  2. In the Options window, select the Applications tab.
  3. In the Search field, type PDF. You should find Portable Document Format (PDF).
  4. On the right handside you should find an Action column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose Preview in Firefox.

If this not works choose any PDF file and set the icon as you like from properties as set is as default.

Did this fix your problems? Please report back to us!

Thank you.

Hello, In order to change the default reader for PDF files (to not open PDF files with Firefox's internal PDF reader), follow these steps: #Go to ''Tools'' > ''Options'' (or ''Firefox'' > ''Options''). #In the Options window, select the ''Applications'' tab. #In the ''Search'' field, type ''PDF''. You should find ''Portable Document Format (PDF)''. #On the right handside you should find an ''Action'' column. Use that to select your favorite PDF reader. In order to view PDF files in Firefox, choose ''Preview in Firefox''. If this not works choose any PDF file and set the icon as you like from properties as set is as default. Did this fix your problems? Please report back to us! Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

If there is currently no file handler application that handles PDF files then the Firefox updater/installer registers Firefox as the default application to handle PDF files and thus they get a Firefox icon.

  • bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file. You may have to change the icon via other means to the icon of that application.

If there is currently no file handler application that handles PDF files then the Firefox updater/installer registers Firefox as the default application to handle PDF files and thus they get a Firefox icon. *[https://bugzilla.mozilla.org/show_bug.cgi?id=452254 bug 452254] - Register for audio/video .ogg and .pdf file handlers if nothing else has <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i> You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file. You may have to change the icon via other means to the icon of that application.

Question owner

Thanks for your comments. All my pdf files are associated with Adobe and open with Adobe when I click on them. Firefox has been set to open with Adobe through the options menu, so everything is working normally except for the icon problem. Are you able to explain 'changing the icon via other means' process (usingXP)? I will give that a try. What were your thoughts on both of my XP machines updating to FFox 31 - one has this problem the other doesn't? thanks

Thanks for your comments. All my pdf files are associated with Adobe and open with Adobe when I click on them. Firefox has been set to open with Adobe through the options menu, so everything is working normally except for the icon problem. Are you able to explain 'changing the icon via other means' process (usingXP)? I will give that a try. What were your thoughts on both of my XP machines updating to FFox 31 - one has this problem the other doesn't? thanks

Question owner

Second response - thanks again. Attempting to change icons as suggested did not change icons away from Fire Fox. Check the link for a screenshot. Here you will see Adobe as the default handle but the icon remains as Firefox.

https://www.dropbox.com/sh/nrvgh0mx1x4y8zg/AADK77Ds4blafRBR4A3nJor-a

Second response - thanks again. Attempting to change icons as suggested did not change icons away from Fire Fox. Check the link for a screenshot. Here you will see Adobe as the default handle but the icon remains as Firefox. https://www.dropbox.com/sh/nrvgh0mx1x4y8zg/AADK77Ds4blafRBR4A3nJor-a
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Did you try to change this icon in the Windows Control Panel?

  • Control Panel > Folder Options > File Types
Did you try to change this icon in the Windows Control Panel? *Control Panel > Folder Options > File Types

Question owner

Thanks for your help cor-el. I looked in there but I am not sure what I need to change. Can you step by step?

Thanks for your help cor-el. I looked in there but I am not sure what I need to change. Can you step by step?
dlschool 1 solutions 1 answers

Chosen Solution

Hi CMBANA. I had exactly the same problem as you, and after a lot of searching couldn't find an answer that worked.

But I have now solved the problem of pdf files appearing as Firefox HTML documents. Perhaps you could try this, and hopefully it should work for you.

First of all, it wasn't entirely a Firefox problem. The solution is also within Adobe Reader itself.

1. Open Adobe Reader 2. Edit->Preferences 3. In the Categories column click 'General' 4. Near the bottom of the page click the button marked 'Select Default PDF Handler' 5 In the dialog, select 'Adobe Reader XI' and click 'Apply' 6. A Windows Configuration screen will appear. Allow it to do its stuff (takes a few minutes), then restart your computer when prompted.

After restarting you should find that all your PDF documents have returned to being Adobe Acrobat Documents, and have the appropriate icon. I also noticed that in the Firefox application options the option 'use Adobe Reader (default)' had appeared. You can then tweak the Firefox Application options as described in earlier posts according to how you want Firefox to handle the document, eg whether to preview it, download it, or open it directly with Adobe Reader.

Took a lot of sorting out, but it now works. Hope it does the same for you.

Hi CMBANA. I had exactly the same problem as you, and after a lot of searching couldn't find an answer that worked. But I have now solved the problem of pdf files appearing as Firefox HTML documents. Perhaps you could try this, and hopefully it should work for you. First of all, it wasn't entirely a Firefox problem. The solution is also within Adobe Reader itself. 1. Open Adobe Reader 2. Edit->Preferences 3. In the Categories column click 'General' 4. Near the bottom of the page click the button marked 'Select Default PDF Handler' 5 In the dialog, select 'Adobe Reader XI' and click 'Apply' 6. A Windows Configuration screen will appear. Allow it to do its stuff (takes a few minutes), then restart your computer when prompted. After restarting you should find that all your PDF documents have returned to being Adobe Acrobat Documents, and have the appropriate icon. I also noticed that in the Firefox application options the option 'use Adobe Reader (default)' had appeared. You can then tweak the Firefox Application options as described in earlier posts according to how you want Firefox to handle the document, eg whether to preview it, download it, or open it directly with Adobe Reader. Took a lot of sorting out, but it now works. Hope it does the same for you.

Helpful Reply

Hi dlschool. That solution worked exactly as described. Thank you for your efforts and to passing this information along.

Hi dlschool. That solution worked exactly as described. Thank you for your efforts and to passing this information along.
egrasso 0 solutions 1 answers

Your a star. Thankyou and great instructions.

Your a star. Thankyou and great instructions.
saththomas 0 solutions 1 answers

I have the same problem. All my PDF files has been changed to Firefox icon. These kind of problems are coming in the latest versions.It must be fixed. Because on each versions new new problems are coming without improving the performance..

I have the same problem. All my PDF files has been changed to Firefox icon. These kind of problems are coming in the latest versions.It must be fixed. Because on each versions new new problems are coming without improving the performance..
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Hi saththomas

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.


If you set Firefox as the default browser and Firefox detects via a registry scan that there is currently no file handler application that handles PDF files and a few other file types then the Firefox updater/installer registers Firefox as the default application to handle these file types. This causes them to show with a Firefox icon on the desktop and in other places like Windows Explorer. You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file.

You can use the registry editor to check some keys.

  • Registry Editor:
    HKEY_CURRENT_USER\Software\Classes\.pdf\
    HKEY_CLASSES_ROOT\.pdf

Remove the FirefoxHTML value of the Default key and leave an empty value of that key. That should allow you to set another application as the default to handle PDF files.

Hi saththomas Could you please start a new thread for your question? Then you can provide more information like your operating system and installed extensions and installed plugins. *[[/questions/new start a new thread]] *[[/kb/Using+the+Troubleshooting+Information+page]] ----- If you set Firefox as the default browser and Firefox detects via a registry scan that there is currently no file handler application that handles PDF files and a few other file types then the Firefox updater/installer registers Firefox as the default application to handle these file types. This causes them to show with a Firefox icon on the desktop and in other places like Windows Explorer. You can right-click a PDF file in Windows Explorer and use the open with dialog to change the default application to the Adobe Reader or your preferred application to handle PDF file. You can use the registry editor to check some keys. *Registry Editor:<br>HKEY_CURRENT_USER\Software\Classes\.pdf\<br>HKEY_CLASSES_ROOT\.pdf Remove the FirefoxHTML value of the Default key and leave an empty value of that key. That should allow you to set another application as the default to handle PDF files.
AliceWyman
  • Moderator
240 solutions 2597 answers

/questions/1014919#answer-618531 by dlschool worked for me also (I opened Adobe Reader, went to Edit -> Preferences -> General and used the option, "Select Default PDF Handler" - see my screenshot). I've marked it as the solution since it's what the thread owner, CMBANA reported as fixing it.

P.S. Since this question has been resolved I closed the thread.

[/questions/1014919#answer-618531] by dlschool worked for me also (I opened Adobe Reader, went to Edit -> Preferences -> General and used the option, "Select Default PDF Handler" - see my screenshot). I've marked it as the solution since it's what the thread owner, CMBANA reported as fixing it. P.S. Since this question has been resolved I closed the thread.

Modified by AliceWyman