X
Tap here to go to the mobile version of the site.

Support Forum

No option for email address for import

Posted

I'm importing the 'people' list from outlook.com into a csv file. When I get the choice to realign the Address Book fields to the Record Data to Import, there is no option for 'email address' in the record data to link to. All it imports is the first and last name of the person (which i selected) but I want their email address also. Am I missing something or has the email option been removed for some reason??

I'm importing the 'people' list from outlook.com into a csv file. When I get the choice to realign the Address Book fields to the Record Data to Import, there is no option for 'email address' in the record data to link to. All it imports is the first and last name of the person (which i selected) but I want their email address also. Am I missing something or has the email option been removed for some reason??

Chosen solution

OK, I created an OutlookContacts.csv file from my Hotmail account and tried to import it in the usual way, and found, like you, there was no email address in the 'Record data to import' column. So, I opened the csv in a csv editor (CSVed) and found that the E-mail Address is in column 48 of a 56 column file. I deleted all the unnecessary columns to make it a 16-column file. After realigning the records up and down and checking the boxes for the relevant fields, the new csv file imported perfectly.

I guess TB has a limit on the number of columns that are read during the import.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

More Information

Matt
  • Top 10 Contributor
  • Moderator
3216 solutions 22007 answers

see my notes here http://thunderbirdtweaks.blogspot.com.au/2013/03/importing-csv-files.html you will probably need to tidy up the million or so fields that Outlook exports to a half a dozen.

see my notes here http://thunderbirdtweaks.blogspot.com.au/2013/03/importing-csv-files.html you will probably need to tidy up the million or so fields that Outlook exports to a half a dozen.

Question owner

I read your notes, but they don't seem to apply specifically to my situation.

I'm importing the contacts from outlook.com into a csv file. There is not even an option for an email address on the Record Data side for me to realign the Address Book field to ...

I read your notes, but they don't seem to apply specifically to my situation. I'm importing the contacts from outlook.com into a csv file. There is not even an option for an email address on the Record Data side for me to realign the Address Book field to ...
sfhowes
  • Top 10 Contributor
1438 solutions 6814 answers

Chosen Solution

OK, I created an OutlookContacts.csv file from my Hotmail account and tried to import it in the usual way, and found, like you, there was no email address in the 'Record data to import' column. So, I opened the csv in a csv editor (CSVed) and found that the E-mail Address is in column 48 of a 56 column file. I deleted all the unnecessary columns to make it a 16-column file. After realigning the records up and down and checking the boxes for the relevant fields, the new csv file imported perfectly.

I guess TB has a limit on the number of columns that are read during the import.

OK, I created an OutlookContacts.csv file from my Hotmail account and tried to import it in the usual way, and found, like you, there was no email address in the 'Record data to import' column. So, I opened the csv in a csv editor (CSVed) and found that the E-mail Address is in column 48 of a 56 column file. I deleted all the unnecessary columns to make it a 16-column file. After realigning the records up and down and checking the boxes for the relevant fields, the new csv file imported perfectly. I guess TB has a limit on the number of columns that are read during the import.

Question owner

THANK YOU for hanging in there with me in order to replicate the problem. I appreciate it very much!!

THANK YOU for hanging in there with me in order to replicate the problem. I appreciate it very much!!