X
Tap here to go to the mobile version of the site.

Support Forum

Phone calls ends after a few minutes

Posted

Hi,

Phone calls ends abruptly after a few minutes, whenever I am on the phone using a headset. It is as if the application didn't detect I was calling and would go to "sleep" mode, ending my conversation in the process. If I keep on touching the screen however, I can maintain my phone calls for longer.

I have activated the phone lock to be used "immediately" whenever there's no action. I don't know if that could be related. But in any case having a phone conversation should be detected as an "action", shouldn't it ?

If I don't use any headset, then it will stay on for nearly 45 min, before stopping eventually.

Anyone else had problems with phone calls or has any suggestions to make ?

Hi, Phone calls ends abruptly after a few minutes, whenever I am on the phone using a headset. It is as if the application didn't detect I was calling and would go to "sleep" mode, ending my conversation in the process. If I keep on touching the screen however, I can maintain my phone calls for longer. I have activated the phone lock to be used "immediately" whenever there's no action. I don't know if that could be related. But in any case having a phone conversation should be detected as an "action", shouldn't it ? If I don't use any headset, then it will stay on for nearly 45 min, before stopping eventually. Anyone else had problems with phone calls or has any suggestions to make ?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

Andrew
  • Moderator
321 solutions 4037 answers

Helpful Reply

Hello,

Thank you for contacting Mozilla. I understand that you are having problems with placing calls with and without a headset. In order to better understand and investigate on the issue that you are encountering, please reply to this message with the following information:

  • What is the model of your phone? (ZTE Open, LG Fireweb or Alcatel OneTouch Fire)
  • What is the OS version found in the Device Information page? Please visit this link if you need help finding the Build ID of your phone.
  • Please provide the exact steps to reproduce the issue you are encountering.
  • Who is your current cell phone carrier?
  • How often do you encounter this issue?
  • What is your current screen timeout set to?

Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we will have all the information needed to investigate into this. Thank you for your help and we look forward to hearing from you!

Hello, Thank you for contacting Mozilla. I understand that you are having problems with placing calls with and without a headset. In order to better understand and investigate on the issue that you are encountering, please reply to this message with the following information: * What is the model of your phone? (ZTE Open, LG Fireweb or Alcatel OneTouch Fire) * What is the OS version found in the Device Information page? Please visit [http://mzl.la/Gzz6Kp this link] if you need help finding the Build ID of your phone. * Please provide the exact steps to reproduce the issue you are encountering. * Who is your current cell phone carrier? * How often do you encounter this issue? *What is your current screen timeout set to? Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we will have all the information needed to investigate into this. Thank you for your help and we look forward to hearing from you!

Question owner

Hi Andrew,

Thanks for taking the time to look into my issue.

I have the ZTE Open and OS version 1.0.1.0. I had the same issue regardless of the SIM card or phone carrier (I travel between 2 countries and often need to swap SIM cards). I have this issue each time I make a phone call or receive one.

My current screen time-out ? Is it when the password is needed for the phone lock ? It is set to "immediately".

I don't get any error messages. The phone call application just crashes and ends the call after a few minutes.

Hi Andrew, Thanks for taking the time to look into my issue. I have the ZTE Open and OS version 1.0.1.0. I had the same issue regardless of the SIM card or phone carrier (I travel between 2 countries and often need to swap SIM cards). I have this issue each time I make a phone call or receive one. My current screen time-out ? Is it when the password is needed for the phone lock ? It is set to "immediately". I don't get any error messages. The phone call application just crashes and ends the call after a few minutes.
Andrew
  • Moderator
321 solutions 4037 answers

Helpful Reply

Hi,

Have you looked into getting the latest version? There should be an update available for your device. May I ask where you purchased the device?

If you go to settings -> Display -> and look for Screen timeout what do you currently have set there? If you change it to Never, does this solve the issue?

Hi, Have you looked into getting the latest version? There should be an update available for your device. May I ask where you purchased the device? If you go to settings -> Display -> and look for '''Screen timeout''' what do you currently have set there? If you change it to '''Never''', does this solve the issue?

Question owner

I purchased it in the UK from eBay (zte_uk).

Thanks for indicating where the screen timeout was, for some reason I hadn't noticed it, and kept on focusing on the phone lock instead.

It was set to "2 minutes". I have just set to "Never". I have a feeling it could just solve it, but I can't test it and make any phone calls right now. And it is not too convenient for me to make some this week-end either, so I'll report back on Monday to let you know.

I app update notifications, but not OS upgrade. How should I do to upgrade it ?

I purchased it in the UK from eBay (zte_uk). Thanks for indicating where the screen timeout was, for some reason I hadn't noticed it, and kept on focusing on the phone lock instead. It was set to "2 minutes". I have just set to "Never". I have a feeling it could just solve it, but I can't test it and make any phone calls right now. And it is not too convenient for me to make some this week-end either, so I'll report back on Monday to let you know. I app update notifications, but not OS upgrade. How should I do to upgrade it ?

Question owner

Hi Andrew,

No, changing the timeout didn't solve it : I make or receive a phone call and then 30 seconds later the call gets cut off. The phone application stays open though, it doesn't crash, only the call ends.

I have to use an other phone with the same SIM card to make calls.

Hi Andrew, No, changing the timeout didn't solve it : I make or receive a phone call and then 30 seconds later the call gets cut off. The phone application stays open though, it doesn't crash, only the call ends. I have to use an other phone with the same SIM card to make calls.
Ralph Daub
  • Locale Leader
158 solutions 1182 answers

Hi Taoma,

I am sorry to hear that you are having issues when placing a call on your ZTE Open device from Ebay, and that the calls are ending abruptly.

I see that your phone is currently on version 1.0.1.

On 10th December 2013, ZTE released a Firefox OS 1.1 upgrade for the ZTE OPEN. We suggest that you update your device to version 1.1, which may help resolve this issue.

Please look into this MDN (Mozilla Developer Network) article for more information on how to update your Developer device:

We hope you find this information helpful. Please let us know if you have any other questions.

Thanks,

- Ralph

Hi Taoma, I am sorry to hear that you are having issues when placing a call on your ZTE Open device from Ebay, and that the calls are ending abruptly. I see that your phone is currently on version 1.0.1. On 10th December 2013, ZTE released a Firefox OS 1.1 upgrade for the ZTE OPEN. We suggest that you update your device to version 1.1, which may help resolve this issue. Please look into this MDN (Mozilla Developer Network) article for more information on how to update your Developer device: * [https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/ZTE_OPEN] We hope you find this information helpful. Please let us know if you have any other questions. Thanks, - Ralph