X
Tap here to go to the mobile version of the site.

Support Forum

Firefox says Google Services is Secure Connection Failed (sec_error_inadequate_key_usage). It does not give me an option to load the page anyway.

Posted

Detailed error message is below shown :


Secure Connection Failed

mail.google.com uses an invalid security certificate. The certificate does not come from a trusted source. (Error code: sec_error_inadequate_key_usage)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

Try again


I am using Windows 7 ultimate and I have Kaspersky Anti virus 2013 for internet security.

I am using Firefox version 30.0.

I have tried opening google services with different profiles(guest, administrator,standard user) but each time the same error messages are displayed and google services can not open.

Is this problem is created because of missing authorities certificates? I am using firefox on another computer but it has more authorities certificates than this computer with error message. In other computer google(search, mail, maps etc.) services are working correctly.

Detailed error message is below shown : ----------------------------------------------------------------------------------------------------------- Secure Connection Failed mail.google.com uses an invalid security certificate. The certificate does not come from a trusted source. (Error code: sec_error_inadequate_key_usage) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site. Try again ------------------------------------------------------------------------------------------------------------ I am using Windows 7 ultimate and I have Kaspersky Anti virus 2013 for internet security. I am using Firefox version 30.0. I have tried opening google services with different profiles(guest, administrator,standard user) but each time the same error messages are displayed and google services can not open. Is this problem is created because of missing authorities certificates? I am using firefox on another computer but it has more authorities certificates than this computer with error message. In other computer google(search, mail, maps etc.) services are working correctly.

Additional System Details

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • Dangerous Websites Blocker 13.0.1.4401 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4401 (url_advisor@kaspersky.com) (Inactive)
  • Virtual Keyboard 13.0.1.4401 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 12-12-2012
  • driverDate2:
  • driverVersion: 9.17.10.2932
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1402731325
  • places.history.expiration.transient_current_max_pages: 104379
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1402731325

Misc

  • User JS: No
  • Accessibility: No
christ1
  • Top 25 Contributor
2169 solutions 15878 answers

It may be Kaspersky intercepting your secure connection to Gmail.

Try to start Windows in safe mode with networking enabled to verify if this is the case.

Do you see this problem with other secure sites too?

It may be Kaspersky intercepting your secure connection to Gmail. Try to start Windows in safe mode with networking enabled to verify if this is the case. Do you see this problem with other secure sites too?
christ1
  • Top 25 Contributor
2169 solutions 15878 answers

I was wrong, it's probably Microsoft intercepting your secure connection.

This may be caused by a windows update - please see http://support.microsoft.com/kb/2965142/en-us#2 for details.

I was wrong, it's probably Microsoft intercepting your secure connection. This may be caused by a windows update - please see http://support.microsoft.com/kb/2965142/en-us#2 for details.