X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Disable security features in Firefox

Posted

I am testing a website using selenium web driver. The particular site contains nested iframes. I cannot access content of Iframes, because of the Same Origin Policy. Therefore I disabled web security in chrome web driver and access those contents using following Jquery script.

$(‘#data’).find(‘iframe’).contents().find(‘html’) I achieved this in chrome by setting these features when it is initializing.

options.AddArguments("--allow-file-access-from-files"); options.AddArguments("--disable-web-security");

Now I need to do this in Firefox. I followed instructions in this URL. But that is not working.

about:config -> security.fileuri.strict_origin_policy -> false

I haven't got what I expected using above edits. Error was Permission denied to access property 'document'

There should be way to achieve this. I am using Firefox 29.0.1

I am testing a website using selenium web driver. The particular site contains nested iframes. I cannot access content of Iframes, because of the Same Origin Policy. Therefore I disabled web security in chrome web driver and access those contents using following Jquery script. $(‘#data’).find(‘iframe’).contents().find(‘html’) I achieved this in chrome by setting these features when it is initializing. options.AddArguments("--allow-file-access-from-files"); options.AddArguments("--disable-web-security"); Now I need to do this in Firefox. I followed instructions in this URL. But that is not working. about:config -> security.fileuri.strict_origin_policy -> false I haven't got what I expected using above edits. Error was Permission denied to access property 'document' There should be way to achieve this. I am using Firefox 29.0.1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36

More Information

guigs 1072 solutions 11697 answers

You may need to change the second one as well. security.fileuri.strict_origin_policy;true network.http.referer.XOriginPolicy

You may need to change the second one as well. security.fileuri.strict_origin_policy;true network.http.referer.XOriginPolicy

Question owner

I tired set values to network.http.referer.XOriginPolicy. But it was not working,,,Can you tell me the values that relate with parameter. I couldn't able to find references.

Thank u for your reply.

I tired set values to network.http.referer.XOriginPolicy. But it was not working,,,Can you tell me the values that relate with parameter. I couldn't able to find references. Thank u for your reply.
cor-el
  • Top 10 Contributor
  • Moderator
17087 solutions 154328 answers
That pref is about sending a referrer. *http://mxr.mozilla.org/mozilla-release/source/netwerk/protocol/http/HttpBaseChannel.cpp#872