X
Tap here to go to the mobile version of the site.

Support Forum

ZTE Open C crashes during calls.. Falsh

Posted

Hi

I bought a ZTE Open C, and unfortunately it frequently reboots when I answer or initiate a call. After the reboot it usually lets me retry the call succesfully, but it is very disruptive for answering calls

I have colleagues with the same issue who got the ZTE Open C at the same time as me. We work in a position where we take a lot of calls on our mobiles and we cannot see who calls (routed through a PBX) and so we cannot call back and it is very bad for customers :-/

I was wondering if there is an update to the dialer app, or if someone knows how I can maybe flash the phone to 1.4 FFOS or 2.0 or something ?

Hi I bought a ZTE Open C, and unfortunately it frequently reboots when I answer or initiate a call. After the reboot it usually lets me retry the call succesfully, but it is very disruptive for answering calls I have colleagues with the same issue who got the ZTE Open C at the same time as me. We work in a position where we take a lot of calls on our mobiles and we cannot see who calls (routed through a PBX) and so we cannot call back and it is very bad for customers :-/ I was wondering if there is an update to the dialer app, or if someone knows how I can maybe flash the phone to 1.4 FFOS or 2.0 or something ?

Chosen solution

Hi

Just wanted to update this thread, I received a software update a few days ago that appears to have resolved the issue. At least I have not had the issue for 5-6 days now.

My current software version FFOS_EU_EBAY_OPENCV1.0.0B06 OS Version: 1.3.0.0 Platform Version: 28.0

Seems to work

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

iamjayakumars 489 solutions 5951 answers

Hello,

Warning: Resetting your phone will delete all data stored on the device, including apps, calendar data, email accounts, and settings.

To reset the device, follow these instructions:

  1. Open the Settings application.
  2. Tap on the Device Information button.
  3. Tap on the More Information button.
  4. Tap on the Reset phone button.
  5. Tap OK to continue or Cancel to cancel.

We hope that this fixed the issue you were having. Please report back to us if this helped!

Thank you!

Hello, '''Warning:''' Resetting your phone will delete all data stored on the device, including apps, calendar data, email accounts, and settings. To reset the device, follow these instructions: # Open the Settings application. # Tap on the Device Information button. # Tap on the More Information button. # Tap on the Reset phone button. # Tap OK to continue or Cancel to cancel. We hope that this fixed the issue you were having. Please report back to us if this helped! Thank you!

Question owner

Hi I have already done this twice, and the issue have been there straight from when I unboxed the phone and the very first calls

Resetting does not help, and also happens for other people with this phone model

Hi I have already done this twice, and the issue have been there straight from when I unboxed the phone and the very first calls Resetting does not help, and also happens for other people with this phone model
mluna 70 solutions 486 answers

Helpful Reply

Hi Swulff,

Thanks for using Firefox OS, I'm sorry you are having this crashing issue. Do you have crash reports enabled in the Settings > Improve Firefox OS? And does it ask you to send a report if that is set?

Can you tell me the number of colleagues you know of with this same problem and the number of restarts you are experiencing per day? Also, your region and carrier would help as well if you are comfortable to share that here.

This data will enable me to escalate the issue with our partners if needed or find a device where we can reproduce it and take a look at the crash reports in the meantime.

Thanks in advance, Michelle Luna, Mozilla Support Manager

Hi Swulff, Thanks for using Firefox OS, I'm sorry you are having this crashing issue. Do you have crash reports enabled in the Settings > Improve Firefox OS? And does it ask you to send a report if that is set? Can you tell me the number of colleagues you know of with this same problem and the number of restarts you are experiencing per day? Also, your region and carrier would help as well if you are comfortable to share that here. This data will enable me to escalate the issue with our partners if needed or find a device where we can reproduce it and take a look at the crash reports in the meantime. Thanks in advance, Michelle Luna, Mozilla Support Manager

Question owner

Hi Michelle

Under settings, it is set to Ask, but it does not ask me to send one ever when this happens, so no reports have been sent. I have for good measure now set it to Always Send.

We are 4 people with this issue. The number of restarts vary depending on the number of calls. I have had 1 restart in 1 hour today, but yesterday I had 3 in an hour and sometimes less, it does however happen consistently and both in in- and outgoing calls

We are all in Dublin, Ireland, but using a Danish cell carrier called TDC. Phones are connecting to the Vodafone Network in Ireland

Hi Michelle Under settings, it is set to Ask, but it does not ask me to send one ever when this happens, so no reports have been sent. I have for good measure now set it to Always Send. We are 4 people with this issue. The number of restarts vary depending on the number of calls. I have had 1 restart in 1 hour today, but yesterday I had 3 in an hour and sometimes less, it does however happen consistently and both in in- and outgoing calls We are all in Dublin, Ireland, but using a Danish cell carrier called TDC. Phones are connecting to the Vodafone Network in Ireland
mluna 70 solutions 486 answers

Hi Swullf,

Thanks for these details, much appreciated! I have filed bug https://bugzilla.mozilla.org/show_bug.cgi?id=1017604 to track this and get QA and crash experts to have a look.

If you have more details about exactly what you see (white screen/black, if the entire device reboots or just the dialer and if you get any error message that might help us as well).

Regards, Michelle

Hi Swullf, Thanks for these details, much appreciated! I have filed bug https://bugzilla.mozilla.org/show_bug.cgi?id=1017604 to track this and get QA and crash experts to have a look. If you have more details about exactly what you see (white screen/black, if the entire device reboots or just the dialer and if you get any error message that might help us as well). Regards, Michelle

Question owner

Hi

Thanks

I do not get any error, the phone vibrates very quickly (just as long as if I press a button on the keyboard during a text message) and then the phone reboots with no warnings or error messages.

No black/white/blue screen or anything like that, it simply turns off and quickly after the boot screen is there and phone is back again

Hi Thanks I do not get any error, the phone vibrates very quickly (just as long as if I press a button on the keyboard during a text message) and then the phone reboots with no warnings or error messages. No black/white/blue screen or anything like that, it simply turns off and quickly after the boot screen is there and phone is back again
mluna 70 solutions 486 answers

Hi,

My QA lead has asked that you turn on WiFi as crash reports only get sent over WiFi. (We only see two crashes for Open C in our crash-stats.mozila.org for the Open C signature right now.)

Thank you in advance! Michelle

Hi, My QA lead has asked that you turn on WiFi as crash reports only get sent over WiFi. (We only see two crashes for Open C in our crash-stats.mozila.org for the Open C signature right now.) Thank you in advance! Michelle

Question owner

Hi

I have done, but as this is a work phone I some days have to switch back to my android to ensure stability and a service to my customers. I am trying to re create the issue as often as I have a chance.

Also, when I had it set to "Ask", it never asked me and it makes me wonder does it even generate a crash report ?

Hi I have done, but as this is a work phone I some days have to switch back to my android to ensure stability and a service to my customers. I am trying to re create the issue as often as I have a chance. Also, when I had it set to "Ask", it never asked me and it makes me wonder does it even generate a crash report ?

Question owner

Hi

I just managed to reproduce it twice in a row, once with incoming call and once with outgoing

Crash reports are on and so is WiFi although I am not sure anything is being sent (the number on the link in the bug tracker is not rising :-) )

Is there any way I can extract log files from the phone and send on or something like that ?

Hi I just managed to reproduce it twice in a row, once with incoming call and once with outgoing Crash reports are on and so is WiFi although I am not sure anything is being sent (the number on the link in the bug tracker is not rising :-) ) Is there any way I can extract log files from the phone and send on or something like that ?
Andrew
  • Moderator
321 solutions 4037 answers

I have posted back to the bug. The team is looking into the issue.

thanks

I have posted back to the bug. The team is looking into the issue. thanks

Question owner

I have been in touch with the reseller reg this issue as well, they have advised that I performed an upgrade that was listed on ZTEs website on http://www.ztedevice.com/support/smart_phone/46d40c52-bed4-4cdc-9df9-01719cdf0a70.html

I did this, but the issue happened again at the very first call I made after the upgrade :-(

I have been in touch with the reseller reg this issue as well, they have advised that I performed an upgrade that was listed on ZTEs website on http://www.ztedevice.com/support/smart_phone/46d40c52-bed4-4cdc-9df9-01719cdf0a70.html I did this, but the issue happened again at the very first call I made after the upgrade :-(
CleverWhiteWolf 0 solutions 1 answers

Hello! Sorry for my English. I confirm this problem. My phone hangs when I make a call or receive a call. For example, you call, you hear the first beep and the phone hangs with a white screen. Only helps to remove and insert the battery. This does not happen all the time. But it can happen at any time. Sometimes up to 3 times per day. To solve the problem, I tried the following steps: 1. Reset to factory settings. 2. Used firmware from Comebuy with root access. 3. Used Android KitKat 4.4 from Comebuy. 4. Tried to replace the SIM card. Unfortunately, none of the above did not help. I am from Russia. And my operator MTS.

Hello! Sorry for my English. I confirm this problem. My phone hangs when I make a call or receive a call. For example, you call, you hear the first beep and the phone hangs with a white screen. Only helps to remove and insert the battery. This does not happen all the time. But it can happen at any time. Sometimes up to 3 times per day. To solve the problem, I tried the following steps: 1. Reset to factory settings. 2. Used firmware from Comebuy with root access. 3. Used Android KitKat 4.4 from Comebuy. 4. Tried to replace the SIM card. Unfortunately, none of the above did not help. I am from Russia. And my operator MTS.

Chosen Solution

Hi

Just wanted to update this thread, I received a software update a few days ago that appears to have resolved the issue. At least I have not had the issue for 5-6 days now.

My current software version FFOS_EU_EBAY_OPENCV1.0.0B06 OS Version: 1.3.0.0 Platform Version: 28.0

Seems to work

Hi Just wanted to update this thread, I received a software update a few days ago that appears to have resolved the issue. At least I have not had the issue for 5-6 days now. My current software version FFOS_EU_EBAY_OPENCV1.0.0B06 OS Version: 1.3.0.0 Platform Version: 28.0 Seems to work
OnkelGonzo 0 solutions 2 answers

Hi,

I have the same problem. And although I have the same hard- and software, the problem still exists.

My hardware: ZTE Open C hardware version: P821A10B01

My software version: FFOS_EU_EBAY_OPENCV1.0.0B06 OS version: 1.3.0.0 platform version: 28.0

Any hints?

Thanks, Alex

Hi, I have the same problem. And although I have the same hard- and software, the problem still exists. My hardware: ZTE Open C hardware version: P821A10B01 My software version: FFOS_EU_EBAY_OPENCV1.0.0B06 OS version: 1.3.0.0 platform version: 28.0 Any hints? Thanks, Alex
Ralph Daub
  • Locale Leader
158 solutions 1182 answers

Helpful Reply

Hi OnkelGonzo,

Do you have any new updates on your ZTE Open C? To check, tap on the Update Software icon on your home screen.

If the problem persists, you may attempt to flash your device with an image from ZTE:

If you are technically savvy, you may even install newer, test versions of Firefox OS:

Please let us know if your problem is resolved, or feel free to Ask a New Question! =)

- Ralph

Hi OnkelGonzo, Do you have any new updates on your ZTE Open C? To check, tap on the '''Update Software''' icon on your home screen. If the problem persists, you may attempt to flash your device with an image from ZTE: * [http://en.comebuy.com/developer-firefox-os-open-c.html] If you are technically savvy, you may even install newer, test versions of Firefox OS: * [https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/ZTE_OPEN_C] Please let us know if your problem is resolved, or feel free to [https://support.mozilla.org/en-US/questions/new Ask a New Question]! =) - Ralph

Question owner

Hi Alex

You could try to build a new FFOS from scratch, just note that you cannot flash the entore FFOS to the phone (not sure why) but the important parts, Gecko and Gaia can easily be flashed.

Its fairly easy, I can recommend following the guide referred to in Ralphs suggestion https://developer.mozilla.org/en-US/F.../ZTE_OPEN_C

Hi Alex You could try to build a new FFOS from scratch, just note that you cannot flash the entore FFOS to the phone (not sure why) but the important parts, Gecko and Gaia can easily be flashed. Its fairly easy, I can recommend following the guide referred to in Ralphs suggestion https://developer.mozilla.org/en-US/F.../ZTE_OPEN_C
SB84 0 solutions 4 answers

Hello everybody

Same thing here too : ZTE OPEN c FFOS 1.3.0.0 FFOS_FR_ZTE_OPENCV1.0.0B01

It crashes when calling or called, seems to happen a lot more when the battery is half-full. It only hangs and reboot no crash report seems to have been sent (always ask before send and nothing asked) The missed or crashed calls do not appear in the call log. I did not try to upgrade with the mentionned version above (FFOS_EU_EBAY_OPENCV1.0.0B06) Do you think I should try ? No danger for my phone ?

Thanks for your work !!

Hello everybody Same thing here too : ZTE OPEN c FFOS 1.3.0.0 FFOS_FR_ZTE_OPENCV1.0.0B01 It crashes when calling or called, seems to happen a lot more when the battery is half-full. It only hangs and reboot no crash report seems to have been sent (always ask before send and nothing asked) The missed or crashed calls do not appear in the call log. I did not try to upgrade with the mentionned version above (FFOS_EU_EBAY_OPENCV1.0.0B06) Do you think I should try ? No danger for my phone ? Thanks for your work !!
SB84 0 solutions 4 answers

Hello, Yesterday a new Firefox Os version was succesfully installed on my ZTE open c FFOS_FR_ZTE_OPENCV1.0.0B02 (instead of B01). It came automatically. Will keep updated the thread.

Hello, Yesterday a new Firefox Os version was succesfully installed on my ZTE open c FFOS_FR_ZTE_OPENCV1.0.0B02 (instead of B01). It came automatically. Will keep updated the thread.
SB84 0 solutions 4 answers

As promised : update !

Nothing better with 1.0.0B02. Crash when called or answering. This is a real issue.

As promised : update ! Nothing better with 1.0.0B02. Crash when called or answering. This is a real issue.
Ralph Daub
  • Locale Leader
158 solutions 1182 answers

Hi SB84,

Thank you for your additional information. I updated bug 1017604 to reflect this.

Unfortunately, this appears to be a device-specific issue with the ZTE's build of Firefox OS for the ZTE Open C. I also updated the bug to reflect this and will be including our Technical Account Manager contacts so that ZTE can be informed.

Unfortunately, there is not much that Mozilla can do to resolve bugs introduced by manufacturer-specific builds. I would also suggest contacting ZTE's support channels directly for further assistance and resolution.

Please let us know if you have any further questions or issues with your Firefox OS device.

Thanks,

- Ralph

Hi SB84, Thank you for your additional information. I updated [https://bugzilla.mozilla.org/show_bug.cgi?id=1017604 bug 1017604] to reflect this. Unfortunately, this appears to be a device-specific issue with the ZTE's build of Firefox OS for the ZTE Open C. I also updated the bug to reflect this and will be including our Technical Account Manager contacts so that ZTE can be informed. Unfortunately, there is not much that Mozilla can do to resolve bugs introduced by manufacturer-specific builds. I would also suggest contacting ZTE's support channels directly for further assistance and resolution. Please let us know if you have any further questions or issues with your Firefox OS device. Thanks, - Ralph