X
Tap here to go to the mobile version of the site.

Support Forum

sec_error_ca_cert_invalid error on all pages

Posted

Hello,

I am running FF 29.0.1 and going to ANY page gives me the same error, over and over again.


Tijdstempel: 21-5-2014 01:13:13 Error: localhost:26143 uses an invalid security certificate.

the certificate is not trusted because it is self-signed

(Errorcode: sec_error_ca_cert_invalid)


As for an example, when I go to google.com, this error will showup a couple of thousand times in the FF errorconsole. When I press 1 letter in the google search bar, the error shows up 37 times...

As I am using the error console allot for site debugging, I really have to get ride of these errors that flush away the important ones. My system is running a Apache server, for local developing purposes. However, I have NOT set a certificate, nor am I using port localhost:261432 (or SSL for that matter). CMD->Netstat tells me that programID "4" is listening to that port, which is the "System" (NT Kernel & System). But I assume "System" functions as an internal proxy, so what program really listens to that port, is unclear to me... I have not been able to find any rootkits on my PC and I am not using any proxies. Also, I have not seen any screen asking me to "trust" the certificate, nor have I been able to actually find the un-trusted certificate in FF........ Left of the address bar, FF shows me the correct certificate of the site, in green and does not tell me that it is invalid...

The weird part of this all; the error stops showing up when I enable private mode!

Any help is welcome!

Hello, I am running FF 29.0.1 and going to ANY page gives me the same error, over and over again. ------------------------------ Tijdstempel: 21-5-2014 01:13:13 Error: localhost:26143 uses an invalid security certificate. the certificate is not trusted because it is self-signed (Errorcode: sec_error_ca_cert_invalid) ------------------------------ As for an example, when I go to google.com, this error will showup a couple of thousand times in the FF errorconsole. When I press 1 letter in the google search bar, the error shows up 37 times... As I am using the error console allot for site debugging, I really have to get ride of these errors that flush away the important ones. My system is running a Apache server, for local developing purposes. However, I have NOT set a certificate, nor am I using port localhost:261432 (or SSL for that matter). CMD->Netstat tells me that programID "4" is listening to that port, which is the "System" (NT Kernel & System). But I assume "System" functions as an internal proxy, so what program really listens to that port, is unclear to me... I have not been able to find any rootkits on my PC and I am not using any proxies. Also, I have not seen any screen asking me to "trust" the certificate, nor have I been able to actually find the un-trusted certificate in FF........ Left of the address bar, FF shows me the correct certificate of the site, in green and does not tell me that it is invalid... The weird part of this all; the error stops showing up when I enable private mode! Any help is welcome!

Chosen solution

If you try to access https://localhost:26143/ does Firefox present the certificate error page? Going through the motions of calling up the Add Exception dialog to view the certificate issuer might help shed more light. I don't recommend actually adding an exception, however.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Google Update
  • npIPcam DLL - 2.0.1.4
  • 5.1.30214.0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft Lync
  • Foxit Reader Plug-In For Firefox and Netscape
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Happy Cloud Web Plugin
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Winamp Application Detector
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

jscher2000
  • Top 10 Contributor
6622 solutions 54115 answers

It sounds like you have a proxy running, otherwise, it is very hard to understand why your Google traffic would trigger an error on localhost. Could you double check:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

Private browsing is an intriguing clue. Maybe there is a glitch in the cache that private mode works around?

If you haven't recently cleared your cache, you can do that using:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab

In the Cached Web Content section, click "Clear Now"

If you have a large hard drive, this might take a few minutes.

It sounds like you have a proxy running, otherwise, it is very hard to understand why your Google traffic would trigger an error on localhost. Could you double check: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button Private browsing is an intriguing clue. Maybe there is a glitch in the cache that private mode works around? If you haven't recently cleared your cache, you can do that using: "3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab In the Cached Web Content section, click "Clear Now" If you have a large hard drive, this might take a few minutes.
jscher2000
  • Top 10 Contributor
6622 solutions 54115 answers

Chosen Solution

If you try to access https://localhost:26143/ does Firefox present the certificate error page? Going through the motions of calling up the Add Exception dialog to view the certificate issuer might help shed more light. I don't recommend actually adding an exception, however.

If you try to access https://localhost:26143/ does Firefox present the certificate error page? Going through the motions of calling up the Add Exception dialog to view the certificate issuer might help shed more light. I don't recommend actually adding an exception, however.

Question owner

Thank you for your reply jscher!

The proxy was turned off and cache I don't use (so that the page reloads at each visit, which is quite useful if you change css/js files).

I was under the impression that I already went to the address, however, it seems I forgot the s in httpS://localhost:26143/

The certificate is made by the organisation: "Skupre Click to Call". After turning off the plug-in "Skype Click to Call" plugin, the error stopped popping!

Thank you for your help! problem solved :)

Thank you for your reply jscher! The proxy was turned off and cache I don't use (so that the page reloads at each visit, which is quite useful if you change css/js files). I was under the impression that I already went to the address, however, it seems I forgot the s in httpS://localhost:26143/ The certificate is made by the organisation: "Skupre Click to Call". After turning off the plug-in "Skype Click to Call" plugin, the error stopped popping! Thank you for your help! problem solved :)