Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I Can't install Firefox Sync on Firefox 25.0.1 for Mac, which I need to use Firefox on iphone.

  • 2 replies
  • 4 have this problem
  • 21 views
  • Last reply by Katzmau

more options

When I tried to install Firefox sync it said it was not compatible with firefox 25.0.1. Mac 10.6.8 is the most my system can handle.

I have an iphone 4 running iOS 7.0.3.

I want to use firefox on my iphone and believe i need to install Firefox Sync to accomplish this. Is there anyway where i can run firefox on my iphone?

Syncing between the Mac and the iphone would be good but is not essential.

Chosen solution

hello, due to apple's restrictive policies it is unfortunately not possible to implement & offer independent third-party browsers for idevices.
mozilla is prohibited to bring the rendering & javascript engine of firefox onto iOS, since apple is only allowing the use of its own webkit in the terms & conditions for developers - as long as this is the case, firefox and its addon ecosystem cannot be ported to iOS devices.

http://www.pcmag.com/article2/0,2817,2416461,00.asp

Read this answer in context 👍 5

All Replies (2)

more options

Chosen Solution

hello, due to apple's restrictive policies it is unfortunately not possible to implement & offer independent third-party browsers for idevices.
mozilla is prohibited to bring the rendering & javascript engine of firefox onto iOS, since apple is only allowing the use of its own webkit in the terms & conditions for developers - as long as this is the case, firefox and its addon ecosystem cannot be ported to iOS devices.

http://www.pcmag.com/article2/0,2817,2416461,00.asp

more options

This is disappointing, but thank you very much for your time. This will save me many hours of frustration.