X
Tap here to go to the mobile version of the site.

Support Forum

My Mac software is up to date but Firefox wont update what to do??

Posted

I am using OS X version 10.9.2 on my Mac. I have Firefox 29.0.1 installed. When I click about it says its up to date. However many websites say my browser is not up to date and so I cant use that site on Firefox. Hotmail for example. However when I go to Firefox to up date it says I do not meet requirements. Not sure what to do??

I am using OS X version 10.9.2 on my Mac. I have Firefox 29.0.1 installed. When I click about it says its up to date. However many websites say my browser is not up to date and so I cant use that site on Firefox. Hotmail for example. However when I go to Firefox to up date it says I do not meet requirements. Not sure what to do??

Chosen solution

You either have or at one point had "Fast Browser Search" malware installed. It has frozen the version listed in your user agent string at Firefox 3.5.13.

First, make sure you don't have any unwanted extensions in the Add-ons Manager, Extensions category.

Once you've done that,

  1. Type about:config into the address bar and press Enter.
  2. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  3. In the search box, type useragent
  4. In the search results, right-click (or Ctrl+click) each preference listed and choose Reset. If Reset is grayed out, then that particular preference is already at the default value — simply move on to the next one.
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Provides information about the default web browser
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX Web Player version 2.0.0.263
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.13) Gecko/20100914 Firefox/3.5.13 FBSMTWB

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 solutions 10658 answers
Try the steps at [[Websites say that Firefox is outdated or incompatible even though it's the latest version]]
Gingerbread Man 403 solutions 1537 answers

Chosen Solution

You either have or at one point had "Fast Browser Search" malware installed. It has frozen the version listed in your user agent string at Firefox 3.5.13.

First, make sure you don't have any unwanted extensions in the Add-ons Manager, Extensions category.

Once you've done that,

  1. Type about:config into the address bar and press Enter.
  2. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  3. In the search box, type useragent
  4. In the search results, right-click (or Ctrl+click) each preference listed and choose Reset. If Reset is grayed out, then that particular preference is already at the default value — simply move on to the next one.
You either have or at one point had "Fast Browser Search" malware installed. It has frozen the version listed in your user agent string at Firefox 3.5.13. First, make sure you don't have any unwanted extensions in the Add-ons Manager, Extensions category. * [[Disable or remove Add-ons]] Once you've done that, # Type ''about:config'' into the address bar and press Enter. # To bypass the warning, press the big button labeled "I'll be careful, I promise!". # In the search box, type ''useragent'' # In the search results, right-click (or Ctrl+click) each preference listed and choose Reset. If Reset is grayed out, then that particular preference is already at the default value — simply move on to the next one.

Question owner

Thank you solved! Finally after a very long time!

Thank you solved! Finally after a very long time!