Troubleshoot and diagnose Firefox problems

Revision Information
  • Revision id: 24187
  • Created:
  • Creator: Tonnes
  • Comment: remove first {/for}
  • Reviewed: Yes
  • Reviewed:
  • Reviewed by: Verdi
  • Is approved? Yes
  • Is current revision? No
  • Ready for localization: No
Revision Source
Revision Content

Most problems with Firefox can be fixed by following the troubleshooting methods described below. Try these in order. If one doesn't work, move on to the next. If you need extra help with any of this, we have a community of volunteers standing by.

Note:

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Consider using it before going through a lengthy troubleshooting process.

The Refresh Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Consider using it before going through a lengthy troubleshooting process.

1. Restart your computer

Sometimes problems can be fixed by simply restarting your computer and then starting Firefox again.

2. Clear your cookies and cache

Many problems with loading web pages can be resolved by clearing Firefox's cookies and cache:

  1. At the top of the Firefox window, click on the Firefox button, go over to the History menu and select Clear Recent History....On the menu bar, click on the Tools menu, and select Clear Recent History....At the top of the Firefox window, click on the Tools menu, and select Clear Recent History....
  2. In the Time Range to clear: drop-down, select Everything.
  3. Click the arrow next to Details to display the list of items that can be cleared.
  4. Select both Cookies and Cache.
  5. Click Clear Now.
  1. At the top of the Firefox window, click on the Firefox button, go over to the History menu and select Clear Recent History....On the menu bar, click on the History menu, and select Clear Recent History....At the top of the Firefox window, click on the History menu, and select Clear Recent History....
  2. In the Time Range to clear: drop-down, select Everything.
  3. Click the arrow next to Details to display the list of items that can be cleared.
  4. Select both Cookies and Cache.
  5. Click Clear Now.
  1. Click the menu button New Fx Menu , choose History and select Clear Recent History....
  2. In the Time Range to clear: drop-down, select Everything.
  3. Click the arrow next to Details to display the list of items that can be cleared.
  4. Select both Cookies and Cache.
  5. Click Clear Now.
For more information, see Delete browsing, search and download history on Firefox.

3. Update your plugins

Sometimes plugins for Firefox (such as Adobe Reader, Flash, Java, QuickTime, RealPlayer, and Windows Media Player) can cause problems. Often this is because they are out of date. To check to see if you have the latest versions of all your plugins, go to our Plugin Check page:

  1. If any of your plugins are out of date, click Update and follow the instructions for updating that plugin.
  2. After you've updated all of your plugins, restart Firefox
    • At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

      Click the menu button New Fx Menu and then click ExitQuit Close 29

      Then start Firefox again.

4. Restart Firefox in Safe Mode

Troubleshoot Firefox issues using Safe Mode is a troubleshooting mode that disables all extensions, uses the default theme, turns off hardware acceleration, and uses default toolbar settings and controls, among other things. To start Firefox in Safe Mode:

  1. At the top of the Firefox window, click the Firefox button, go over to the Help menuOn the menu bar, click the Help menuAt the top of the Firefox window, click the Help menu and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog.
    Note: You can also start Firefox in Safe Mode by holding down the shift key while starting Firefox.holding down the option key while starting Firefox.quitting Firefox and then going to your Terminal and running: firefox -safe-mode
    You may need to specify the Firefox installation path (e.g. /usr/lib/firefox)
    Click the menu button New Fx Menu , click help Help-29 and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog.
    Note: You can also start Firefox in Safe Mode by holding down the shift key while starting Firefox.holding down the option key while starting Firefox.quitting Firefox and then going to your Terminal and running: firefox -safe-mode
    You may need to specify the Firefox installation path (e.g. /usr/lib/firefox)
  2. In the Firefox Safe Mode dialog, click Continue in Safe Mode.
  3. Check whether your problem is still happening while in Safe Mode.

5. Troubleshoot your plugins

Some problems can be caused by a plugin that no longer works with Firefox. To see if this is the issue, disable all of your plugins. If the problem goes away, it's likely that a plugin is the cause:

  1. At the top of the Firefox window, click on the Firefox buttonOn the menu bar, click on the Tools menuAt the top of the Firefox window, click on the Tools menu, and then click Add-ons. The Add-ons Manager tab will open. Click the menu button New Fx Menu and choose Add-ons. The Add-ons Manager tab will open.

  2. In the Add-ons Manager tab, select the Plugins panel.
  3. Click each plugin in the list and then click Disable.
  4. Check whether your problem happens when you have all plugins disabled.

If your problem goes away when all of your plugins are disabled, see the Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems article to learn how to narrow down which one is causing it.

6. Reset your Firefox settings

Some problems can be fixed by resetting your Firefox preference settings:

  1. At the top of the Firefox window, click the Firefox button, go over to the Help menuOn the menu bar, click the Help menuAt the top of the Firefox window, click the Help menu and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog.
    Note: You can also start Firefox in Safe Mode by holding down the shift key while starting Firefox.holding down the option key while starting Firefox.quitting Firefox and then going to your Terminal and running: firefox -safe-mode
    You may need to specify the Firefox installation path (e.g. /usr/lib/firefox)
    Click the menu button New Fx Menu , click help Help-29 and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog.
    Note: You can also start Firefox in Safe Mode by holding down the shift key while starting Firefox.holding down the option key while starting Firefox.quitting Firefox and then going to your Terminal and running: firefox -safe-mode
    You may need to specify the Firefox installation path (e.g. /usr/lib/firefox)
  2. In the Firefox Safe Mode dialog, click to put a check mark by Reset all user preferences to Firefox defaults.
  3. To apply your changes, click Make Changes and Restart.

7. Reinstall Firefox

Some Firefox issues can be caused by a problem with one of the Firefox program files. Follow these steps to completely remove and reinstall Firefox.

You might want to print these steps or view them in another browser.
  1. Download the latest official version of Firefox from Mozilla.com.
  2. Exit Firefox:

    At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  3. Delete the Firefox installation folder which is located here by default: C:\Program files\Mozilla Firefox. The 64-bit version is located in: C:\Program Files (x86)\Mozilla Firefox.
  4. Reinstall Firefox - see How to download and install Firefox on Windows for instructions.
  1. Download the latest official version of Firefox from Mozilla.com.
  2. Quit Firefox:

    At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  3. Uninstall Firefox by opening the Applications folder in the Finder and dragging the Firefox application to the Trash.
  4. Reinstall Firefox - see How to download and install Firefox on Mac for instructions.
  1. Download the latest official version of Firefox from Mozilla.com.
  2. Quit Firefox:

    At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  3. Uninstall Firefox - If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux for details. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory to uninstall Firefox.
  4. Reinstall Firefox - see How to download and install Firefox on MacInstall Firefox on Linux for instructions.

Now start Firefox and check to see if your problem has been fixed. If it has, you can reinstall the extensions and themes you verified (in part 4 above) were not causing problems. If your problem hasn't been fixed continue with the next troubleshooting method.

8. Make a new profile

A bad profile can cause all kinds of problems with Firefox. To see whether your problem is caused by a bad profile, make a new one. If that fixes the problem, you can copy your data (bookmarks, saved passwords, etc.) over to the new profile.

  1. Use the instructions in the Use the Profile Manager to create and remove Firefox profiles article to start the Profile Manager and create a new profile.
    When creating a new profile, do not delete your old profile. You will lose all of your bookmarks, history, passwords and settings.
  2. Once you've created a new profile, select it in the Profile Manager and click Start Firefox.

Test to see if your problem occurs with the new profile. If it doesn't, you can copy your data to the new profile - see Recovering important data from an old profile for instructions.

Other solutions

If you've tried all of these troubleshooting methods and you're still having problems the issue may be with other software or your Windows system.

This section does not contain step-by-step instructions. For more information on any of these solutions, please check the related documentation.

Check for conflicts with your Internet security software

Some Internet security software (including antivirus, antispyware, and firewall programs) can cause problems with Firefox including blocking it from opening websites, crashes, and more. Often you can open the program's settings, remove Firefox from its list of allowed or trusted programs and it will be re-detected and things should start working again. If your program is listed at the Configure firewalls so that Firefox can access the Internet article, you can get specific instructions for how to properly reconfigure it.

Scan your system for viruses and spyware

Periodically, you should scan your system for viruses, spyware, or other malware. These free services are often useful:

Check your hard drive for errors

A problem with your computer's hard drive may prevent Firefox from running. Here are instructions for checking your hard drive:



Based on information from Standard diagnostic - Firefox (mozillaZine KB)