Google Hangouts temporarily won't work on Firefox

In order to improve performance and focus on technologies that use Web standards, Firefox has dropped support for NPAPI plugins except for Flash, starting with version 52 (see this article for details).

If you use Google Hangouts, you will have issues with audio and video calls, but chat will still work. This is a temporary issue while Google develops a way to make Hangouts work without plugins. See the official Google communication on this issue.

In the meantime, you can download and install the Extended Support Release (ESR) version of Firefox 52 until Google releases a fix. Important: Choose the Windows (32-bit) download.

By default, Firefox 52 ESR will use the same user profile data as other versions of Firefox. Installing Firefox 52 ESR after using Firefox version 55 or above can cause problems such as error messages, breakage in portions of Firefox and issues with some websites. You should either create a new profile to use with Firefox 52 ESR or else refresh Firefox after installing Firefox 52 ESR.

Was this article helpful? Please wait...

These fine people helped write this article: AliceWyman. You can help too - find out how.