Recuperar dados importantes de um perfil antigo

Um perfil do Firefox armazena todos os seus dados importantes, como marcadores, histórico, cookies e palavras-passe. Este artigo explica como copiar estes ficheiros para um novo perfil, lista ficheiros importantes no perfil e descreve a informação guardada nesses ficheiros.

Se está a ter um problema com o Firefox, por vezes é mais simples criar um novo perfil Firefox e copiar os dados mais importantes para esse mesmo perfil, em vez de tentar identificar a causa exata para resolver o problema. Criar um novo perfil do Firefox e depois copiar certos ficheiros permite-lhe começar de novo, ao mesmo tempo que retém os seus dados pessoais de maior importância.

Se esta a ter um problema com o Firefox, por vezes é mais simples criar um novo perfil Firefox e copiar os dados mais importantes para esse mesmo perfil, em vez de tentar identificar a causa exata para resolver o problema. A funcionalidade de reposição do Firefox pode fazer isso por si automaticamente.A funcionalidade de renovação do Firefox pode fazer isso por si automaticamente.

Nota: Uma vez que as suas preferências e extensões são frequentemente as causas de problemas, este artigo não explica como os copiar entre perfis. Assim, se seguir os passos neste artigo, terá de reinstalar as extensões e reconfigurar as suas preferências posteriormente.

Faça uma cópia de segurança do seu perfil atual

Antes de começar, recomenda-se que faça uma cópia de segurança do seu perfil Firefox atual, no caso de algo correr mal. Consulte o artigo Fazer cópias de segurança e restaurar informação em perfis do Firefox para instruções sobre como o fazer.

Crie um novo perfil Firefox

Para informação sobre como criar um perfil Firefox novo, consulte o artigo Utilizar o Gestor de Perfis para criar e remover perfis do Firefox prestando especial atenção à secção Criar um perfil.

Copiar ficheiros entre pastas de perfil

Nota: O Firefox tem de estar fechado enquanto se processa a cópia de ficheiros entre pastas de perfil.
  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Clique com o botão direito do ratoPressione a tecla Ctrl enquanto clica Num ficheiro que pretenda copiar e selecione Copiar.
  6. Abra a pasta de perfil do novo perfil Firefox.
  7. Clique com o botão direito do ratoPressione a tecla Ctrl enquanto clica dentro da pasta de perfil e selecione Colar item.

Repita os passos 2-5 para cada ficheiro que deseje transferir para a nova pasta de perfil.

Ao copiar os seus dados pessoais de um perfil Firefox antigo para um novo, é possível que copie também o ficheiro causador do problema que está a tentar resolver! Quantos mais ficheiros copiar, maior é a probabilidade de isso acontecer. Assim, recomenda-se que:

  • Copie o número mínimo de ficheiros, que contenham a informação mais importante, sem a qual não pode viver.
  • Copie poucos ficheiros de cada vez, e verifique intercaladamente se o problema que está a tentar resolver não reapareceu.

Os seus dados importantes e respetivos ficheiros

Marcadores e Histórico de Pesquisa

  • places.sqlite

Este ficheiro contém todos os seus marcadores no Firefox e uma lista de sítios que já visitou. Para mais informação, consulte Criar marcadores para guardar as suas páginas favoritas.

Marcadores, Transferências e Histórico de Pesquisa

  • places.sqlite

Este ficheiro contém todos os seus marcadores no Firefox e listas de ficheiros que transferiu e sítios que já visitou. Para mais informação, consulte Criar marcadores para guardar as suas páginas favoritas.

Palavras-passe

As palavras-passe estão guardadas em dois ficheiros diferentes, sendo ambos necessários:

  • key3.db - Este ficheiro armazena a base de dados chave para as suas palavras-passe. Para transferir as palavras-passe guardadas, deve copiar este ficheiro juntamente com o seguinte.
  • signons.sqlitelogins.json - Palavras-passe guardadas.

Para mais informação, consulte Gestor de palavras-passe - Guarde, apague e altere as palavras-passe guardadas no Firefox.

Preferências específicas para um sítio (site)

  • permissions.sqlite

Este ficheiro armazena muitas das suas preferências individuais de sítios específicos. Por exemplo, armazena quais os sítios que podem, ou não, criar cookies, instalar extensões, mostrar imagens, apresentar pop-ups, etc.

Motores de pesquisa

  • search.sqlite
  • \searchplugins\ folder

Se instalou motores de pesquisa adicionais, estarão na pasta \searchplugins\. O ficheiro search.sqlite guarda a ordem pela qual os seus motores de pesquisa aparecem no Firefox. Para mais informações, consulte Barra de Pesquisa - Escolha facilmente o seu motor de pesquisa favorito.

  • search.json

Este ficheiro armazena os dados do motor de pesquisa. Para mais informação consulte Barra de Pesquisa - Escolha facilmente o seu motor de pesquisa favorito.

Dicionário pessoal

  • persdict.dat

Este ficheiro armazena as palavras personalizadas que adicionou ao dicionário do Firefox. Se nunca adicionou uma palavra, este ficheiro não existirá Como utilizar o corretor ortográfico do Firefox?.

Histórico de conclusão automática

  • formhistory.sqlite

Este ficheiro guarda aquilo que introduziu na barra de Pesquisa e a informação que introduziu em formulários online. Para mais informação, consulte Controlar o preenchimento automático com a minha informação no Firefox.

Cookies

  • cookies.sqlite

Cookies - Informação que os sítios guardam no seu computador são utilizados pelos sítios por imensas razões, algumas das quais incluem manter a sua sessão iniciada num sítio no qual já tenha iniciado sessão, recordar preferências que o sítio lhe tenha permitido definir, autenticá-lo como alguém que já visitou um site específico anteriormente, etc.

Definições de certificados de segurança

  • cert8.db

Este ficheiro armazena todas as suas definições de certificados de segurança e quaisquer cetificados SSL que tenha importado para o Firefox.

Tipos de ficheiros e ações de transferência

  • mimeTypes.rdf

Este ficheiro armazena as suas preferências relativas às ações do Firefox quando se depara com um tipo conhecido de ficheiro, como guardá-lo, ou abri-lo com um programa específico. Para mais informação consulte Alterar as ações do Firefox quando faço clique ou transfiro um ficheiro.

Histórico de Transferências

  • downloads.sqlite

Este ficheiro guarda informação sobre os ficheiros que transferiu. Para mais informação, consulte Utilize a janela de Transferências para gerir ficheiros transferidos.



Baseado em informação de Transferir dados para um novo perfil - Firefox (mozillaZine KB)


Partilhar este artigo: http://mzl.la/1xKrzkF

Este artigo foi útil? Por favor, aguarde...

Essas pessoas maravilhosas ajudaram a escrever este artigo: cesperanc, Y4zata. Você também pode ajudar - descubra como.