Diagnosticar e resolver problemas do Firefox

A maioria dos problemas do Firefox pode ser resolvida seguindo as soluções de problemas mais comuns descritas abaixo. Tente estas etapas em ordem. Se uma não funcionar, passe para a próxima. Se precisar de ajuda extra, nós temos uma comunidade de voluntários que estão prontos para te ajudar.

1. Reinicie seu computador

Às vezes os problemas são resolvidos simplesmente reiniciando seu computador e iniciando o Firefox novamente.

2. Faça uma limpeza de cookies e cache

Muitos problemas com o carregamento de páginas podem ser resolvidos pela limpeza de cookies e cache do Firefox:

  1. No topo da janela do Firefox, clique no botão Firefox, passe o mouse sobre o Histórico e selecione Limpar Histórico Recente....Na barra de menu, clique em Ferramentas e selecione Limpar Histórico Recente....No topo da janela do Firefox, clique no menu Ferramentas e selecione Limpar Histórico Recente....
  2. Na lista Limpar este período, selecione Tudo.
  3. Clique na seta ao lado de Detalhes para exibir a lista de itens que podem ser limpos.
  4. Selecione as opções Cookies e Cache.
  5. Clique em Limpar agora.
  1. No topo da janela do Firefox, clique no botão Firefox, passe o mouse sobre o Histórico e selecione Limpar Histórico Recente....Na barra de menu, clique em Histórico e selecione Limpar Histórico Recente....No topo da janela do Firefox, clique no menu Histórico e selecione Limpar Histórico Recente....
  2. Na lista Limpar este período, selecione Tudo.
  3. Clique na seta ao lado de Detalhes para exibir a lista de itens que podem ser limpos.
  4. Selecione as opções Cookies e Cache.
  5. Clique em Limpar agora.
  1. Clique no botão de menu New Fx Menu depois em Histórico em seguida Limpar dados de navegação….
  2. No menu Limpar este período, selecione Tudo.
  3. Clique na seta ao lado de Detalhes para exibir a lista de itens que podem ser limpos.
  4. Selecione as opções Cookies e Cache.
  5. Clique em Limpar agora.
Para mais informações, veja Apague o histórico de navegação, pesquisa e download no Firefox.

3. Reinicie o Firefox em modo de segurança

O Safe Mode é um modo de solucionar problemas comuns, este modo usa o tema padrão; desativa a aceleração de hardware; e usa a forma padrão da barra de ferramentas e dos controles, entre outras coisas. Para iniciar o Firefox em Modo de Segurança:

  1. No topo da janela do Firefox, clique no botão Firefox, vá para o menu AjudaNa barra de menus, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajudae selecione Reiniciar com extensões desativadas…. O Firefox irá iniciar com o diálogo Modo de segurança do Firefox.
    Nota: Você também pode iniciar o Firefox em modo de segurança segurando a tecla Shift ao abrir o Firefoxsegurando a tecla option ao abrir o Firefoxfechando o Firefox, abrindo o seu Terminal e executando: firefox -safe-mode
    Pode ser necessário informar o diretório onde o Firefox foi instalado (ex.: /usr/lib/firefox)
    Clique no botão de menu New Fx Menu , depois em ajuda Help-29 e então em Reiniciar com extensões desativadas…. O Firefox irá iniciar com a caixa de diálogo do Modo de Segurança.
    Nota: Você também pode iniciar o Firefox em modo de segurança segurando a tecla Shift ao abrir o Firefoxsegurando a tecla option ao abrir o Firefoxfechando o Firefox, abrindo o seu Terminal e executando: firefox -safe-mode
    Pode ser necessário informar o diretório onde o Firefox foi instalado (ex.: /usr/lib/firefox)
  2. Na caixa de diálogo do Modo de Segurança do Firefox, clique Iniciar no modo de segurançaIniciar no modo de segurança.
  3. Verifique se o problema persiste no Modo de Segurança.

4. Verifique os plugins

As vezes os plugins do Firefox (como Adobe Reader, Flash, Java, QuickTime, RealPlayer, and Windows Media Player) causam problemas que podem já ter sido sanados na versão mais recente. Para checar se você possui as versões mais recentes dos seus plugins, vá até a nossa página para checar plugins. Se algum de seus plugins estiverem desatualizados, clique em Atualizar e siga as instruções para atualizar esse(s) plugin(s). Após a atualização, feche o Firefox:

No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

Clique no botão de menu New Fx Menu e clique em SairSair Close 29

e o abra novamente. Se o problema persistir, você pode desativar todos os plugins para ver se um deles é a causa:

  1. Na parte superior da janela, clique no botão FirefoxNa barra de menu do Firefox, clique em FerramentasNa parte superior da janela, clique em Ferramentas, e depois em Complementos para abrir a aba do gerenciador de complementos. Clique no botão de menu New Fx Menu e selecione Complementos para abrir a aba do gerenciador de complementos.

  2. No gerenciador de complementos, selecione o painel Plugins.
  3. Clique em cada plugin da lista clicando em Desativar.
  4. Verifique se o problema ocorre após desativar todos os plugins.
  1. Na parte superior da janela, clique no botão FirefoxNa barra de menu do Firefox, clique em FerramentasNa parte superior da janela, clique em Ferramentas, e depois em Complementos para abrir a aba do gerenciador de complementos. Clique no botão de menu New Fx Menu e selecione Complementos para abrir a aba do gerenciador de complementos.

  2. No gerenciador de complementos, selecione o painel Plugins.
  3. Clique em cada plugin da lista e selecione Nunca Ativar no menu.
  4. Verifique se o problema ocorre após desativar todos os plugins.

Se o problema não acontecer mais após a desativação de todos os plugins, veja o artigo Soluções de problemas com plugins como Flash ou Java para corrigir problemas comuns do Firefox para saber como descobrir o que está causando o problema.

5. Reinstale o Firefox

Alguns problemas podem ocorrer no Firefox devido a um dos arquivos do programa. Siga esses passos para removê-lo e instalá-lo completamente. Este processo não irá apagar os dados do seu perfil do Firefox (como favoritos e senhas salvas) porque estas informações são salvas eu um local diferente.

Nota: Você terá que imprimir esses passos ou vê-los em outro navegador.
  1. Baixe a versão oficial do Firefox mais recente em [www.mozilla.org/pt-BR/firefox#desktop mozilla.org].
  2. Saia do Firefox:

    No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  3. Desinstale o Firefox do seu computador.
  4. Delete a pasta da instalação do Firefox, localizada em um desses locais, por padrão:
    • (32-bit Windows) C:\Arquivos de Programas\Mozilla Firefox
    • (64-bit Windows) C:\Arquivos de Programas (x86)\Mozilla Firefox
  5. Reinstale o Firefox - veja Instalando o Firefox no Windows se precisar de instruções.
  1. Baixe a versão oficial do Firefox mais recente em [www.mozilla.org/pt-BR/firefox#desktop mozilla.org].
  2. Finalize o Firefox:

    No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  3. Desinstale o Firefox do seu computador abrindo a pasta Aplicações, pelo Finder e arrastando-o para a Lixeira.
  4. Reinstale o Firefox - veja Instalando o Firefox no Mac se precisar de instruções.
  1. Baixe a versão oficial do Firefox mais recente em [www.mozilla.org/pt-BR/firefox#desktop mozilla.org].
  2. Finalize o Firefox:

    No topo da janela do Firefox, clique no botão Firefox e então clique em SairNo topo da janela do Firefox, clique no menu Arquivo e selecione SairNa barra de menus, clique no menu Firefox e selecione Fechar o FirefoxNo topo da janela do Firefox, clique no menu Arquivo, e então selecione Sair

    Clique no botão de menu New Fx Menu e clique em SairSair Close 29

  3. Desinstale o Firefox - Se você instalou o Firefox pelo gerenciador de pacote da sua distribuição, você deve desinstalar da mesma forma - veja Instalando o Firefox no Linux para maiores detalhes. Se você baixou e instalou o pacote binário da página de download do Firefox, basta remover a pasta firefox do seu diretório inicial para desinstalá-lo.
  4. Reinstale o Firefox - veja Instalando o Firefox no Linux se precisar de instruções.

Agora execute o Firefox e verifique se o problema foi resolvido. Se o problema não foi resolvido, continue com as próximas verificações.

6. Restaure o Firefox

A função Restaurar o Firefox pode resolver diversos problemas através da restauração do seu perfil do Firefox sem perder seus dados.

Nota: Ao usar o recurso de restauração, seus favoritos, histórico, abas abertas, janelas, senhas, cookies e informações de preenchimento automático de formulários serão salvos. No entanto, seus complementos e temas serão removidos e suas preferências serão reiniciadasAo usar o recurso de restauração, seus favoritos, histórico, abas abertas, janelas, senhas, cookies e informações de preenchimento automático de formulários serão salvos. No entanto, seus complementos e temas serão removidos e suas preferências serão reiniciadas Ao usar o recurso de restauração, seus favoritos, histórico, senhas, cookies e informações de preenchimento automático de formulários serão salvos. Porém, seus complementos e temas serão removidos. Abas abertas, janelas e grupos de abas não serão salvos e suas preferências serão reiniciadas. Veja mais.
  1. Clique no menu Ajuda e selecione Dados para suporte., clique no botão Firefox, vá para o dub-menu Ajuda e selecione Dados para suporte.Na barra de menu, clique em Ajuda e selecione Dados para suporte.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Se não for possível acessar o menu Ajuda menu, digite about:support na barra de endereços para abrir a página Dados para suporte.
  2. Clique em Restaurar o Firefox no canto superior direito da página de Informação de Resolução de Problemas.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Para continuar, clique em Restaurar o Firefox na janela de confirmação que se abriu.Para continuar, clique em Restaurar Firefox na janela de confirmação que se abriu.
  4. Firefox irá fechar e ser restaurado. Quando estiver feito, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox irá abrir.Firefox irá fechar e ser restaurado. Quando estiver feito, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox irá abrir.
  1. Clique no botão de menu New Fx Menu e a seguir clique em ajuda Help-29 .
  2. No menu Ajuda selecione Dados para suporte.
    Se não for possível acessar o menu Ajuda menu, digite about:support na barra de endereços para abrir a página Dados para suporte.
  3. Clique no botão Restaurar o Firefox... no canto superior direito da página de Dados para Suporte.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Para continuar, clique em Restaurar o Firefox na janela de confirmação que será aberta.
  5. O Firefox será fechado e reiniciado. Quando terminar, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox abrirá.
  1. Clique no botão Restaurar o Firefox... no canto superior direito da página de Dados para Suporte.
  2. Para continuar, clique em Restaurar o Firefox na janela de confirmação que será aberta.
  3. O Firefox será fechado e reiniciado. Quando terminar, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox abrirá.

Nota: O botão Refresh FirefoxReset Firefox também está disponível no Modo Seguro do Firefox se você não consegue iniciar o Firefox normalmente.

6. Restaure o Firefox

A função Restaurar o Firefox pode resolver diversos problemas através da restauração do seu perfil do Firefox sem que suas informações essenciais se percam.

Nota: Ao usar o recurso de restauração, seus favoritos, histórico, abas abertas, janelas, senhas, cookies e informações de preenchimento automático de formulários serão salvos. No entanto, seus complementos e temas serão removidos e suas preferências serão reiniciadasAo usar o recurso de restauração, seus favoritos, histórico, abas abertas, janelas, senhas, cookies e informações de preenchimento automático de formulários serão salvos. No entanto, seus complementos e temas serão removidos e suas preferências serão reiniciadas Ao usar o recurso de restauração, seus favoritos, histórico, senhas, cookies e informações de preenchimento automático de formulários serão salvos. Porém, seus complementos e temas serão removidos. Abas abertas, janelas e grupos de abas não serão salvos e suas preferências serão reiniciadas. Veja mais.
  1. Clique no menu Ajuda e selecione Dados para suporte., clique no botão Firefox, vá para o dub-menu Ajuda e selecione Dados para suporte.Na barra de menu, clique em Ajuda e selecione Dados para suporte.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Se não for possível acessar o menu Ajuda menu, digite about:support na barra de endereços para abrir a página Dados para suporte.
  2. Clique em Restaurar o Firefox no canto superior direito da página de Informação de Resolução de Problemas.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Para continuar, clique em Restaurar o Firefox na janela de confirmação que se abriu.Para continuar, clique em Restaurar Firefox na janela de confirmação que se abriu.
  4. Firefox irá fechar e ser restaurado. Quando estiver feito, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox irá abrir.Firefox irá fechar e ser restaurado. Quando estiver feito, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox irá abrir.
  1. Clique no botão de menu New Fx Menu e a seguir clique em ajuda Help-29 .
  2. No menu Ajuda selecione Dados para suporte.
    Se não for possível acessar o menu Ajuda menu, digite about:support na barra de endereços para abrir a página Dados para suporte.
  3. Clique no botão Restaurar o Firefox... no canto superior direito da página de Dados para Suporte.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Para continuar, clique em Restaurar o Firefox na janela de confirmação que será aberta.
  5. O Firefox será fechado e reiniciado. Quando terminar, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox abrirá.
  1. Clique no botão Restaurar o Firefox... no canto superior direito da página de Dados para Suporte.
  2. Para continuar, clique em Restaurar o Firefox na janela de confirmação que será aberta.
  3. O Firefox será fechado e reiniciado. Quando terminar, uma janela irá listar as informações que foram importadas. Clique em Concluir e o Firefox abrirá.

Nota: O botão Refresh FirefoxReset Firefox também está disponível no Modo Seguro do Firefox se você não consegue iniciar o Firefox normalmente.

7. Crie um novo perfil do Firefox

As vezes um arquivo no diretório do seu perfil do Firefox que corresponde a informações essenciais que uma Restauraçãoum Refresh não consegue remover (como favoritos ou histórico de navegação) pode estar causando o problema. Você pode criar um perfil novo que não contém dados do seu perfil antigo do Firefox. Veja Gerenciando perfis para obter instruções.

Outras soluções

Se você já tentou todas as verificações mas ainda assim você está com problemas, talvez a causa seja outro programa ou então um hardware.

Essa seção não contém instruções passo-a-passo. Para mais informações a respeito de uma dessas soluções, favor verificar a documentação indicada.

Verifique se há conflitos com o seu(s) programa(s) de segurança de internet

Certos programas de segurança de Internet (incluindo programas antivírus, antispyware, e firewall) podem causar problemas ao Firefox, incluindo bloqueio no carregamento de páginas, travamentos e outros. Geralmente você pode acessar as configurações destes programas, e incluir o Firefox na lista de programas permitidos ou programas confiáveis e as coisas voltam a funcionar normalmente. Você poderá obter instruções específicas para reconfigurar seu(s) programa(s) caso ele esteja listado no artigo Configurando o firewall de modo que o Firefox acesse a internet.

Escaneie seu sistema à procura de Vírus e Spyware

Periodicamente você deve escanear seu sistema à procura de Vírus e Spyware, ou outro malware. Essas ferramentas de remoção de Spywares gratuitas podem ser bastante úteis:

Se você precisar de ajuda para remover malware, veja Solucione problemas causados por Malware no Firefox.

Verifique se seu Disco Rígido (HD) ou memória RAM possuem erros

Um problema com o disco rígido ou memória RAM do seu computador pode impedir o Firefox de funcionar ou fazê-lo travar repetidamente. Aqui você encontra instruções ou ferramentas para verificação:



Based on information from Standard diagnostic - Firefox (mozillaZine KB)


Compartilhe este artigo: http://mzl.la/16zLrEU

Este artigo foi útil? Por favor, aguarde...

Contribuidores que ajudaram a escrever esse artigo: fernandopsilveira, ouesten, Ronan_Costa, brwolfgang. Você também pode ajudar - descubra como.