X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

How to hide/disable Firefox notification for addon/application

Posted

Yahoo Mail is asking me to add an application (a Yahoo Mail app) for "mailto" links. I don't want it. Closing the notification works for as long a refresh, which means I'd be forever closing the notification, thus I want to disable the notification in about:config but what exactly do I need to disable?

Update. Here is someone with a similar problem: http://superuser.com/questions/363827/how-can-i-disable-add-application-for-mailto-links-bar-in-firefox

Update: is this relevant? https://developer.mozilla.org/en-US/docs/Web/API/navigator.registerProtocolHandler

Update: thanks to Gingerbread_man for the chosen solution: https://support.mozilla.org/en-US/questions/994658#answer-556629

Cor-el also gave some helpful info: https://support.mozilla.org/en-US/questions/994658#answer-556727

Thank you all, guys. Cheers!

Yahoo Mail is asking me to add an application (a Yahoo Mail app) for "mailto" links. I don't want it. Closing the notification works for as long a refresh, which means I'd be forever closing the notification, thus I want to disable the notification in about:config but what exactly do I need to disable? Update. Here is someone with a similar problem: http://superuser.com/questions/363827/how-can-i-disable-add-application-for-mailto-links-bar-in-firefox Update: is this relevant? https://developer.mozilla.org/en-US/docs/Web/API/navigator.registerProtocolHandler Update: thanks to Gingerbread_man for the chosen solution: https://support.mozilla.org/en-US/questions/994658#answer-556629 Cor-el also gave some helpful info: https://support.mozilla.org/en-US/questions/994658#answer-556727 Thank you all, guys. Cheers!

Modified by singy1234567891234

Chosen solution

I don't think there's an about:config preference to get rid of that notification bar, since it would break important functionality.

  1. Install Stylish and restart Firefox when prompted.
  2. Opens the Add-ons Manager (Ctrl+Shift+A), then the User Styles category.
  3. Click the Write New Style button at the top. Paste the following in the text box, give the style a name, then click the Save button.

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/*
Title: Yahoo! Mail - hide "add as an application for mailto links" notification
Author: http://forums.mozillazine.org/memberlist.php?mode=viewprofile&u=261941
Tested on: Firefox 28, Firefox 31
*/

notification[label^="Add Yahoo!"][value="Protocol Registration: mailto"] {
  display: none !important;
}

Note: if you absolutely don't want to install Stylish, you can use the userChrome.css file instead. Just make sure the first line of the style only appears once in that file.

Edit: I filed a bug report. If anyone here has the privileges to mark it NEW, please do so. There's already an identical one for Firefox OS that's ASSIGNED, so I think it's perfectly reasonable.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • npsitesafety (Official)
  • Shockwave Flash 12.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

Moses
  • Moderator
459 solutions 3607 answers

Helpful Reply

Hi,

I think I have an idea on what's happening but can you take a screenshot using the Screenshot application?

Hi, I think I have an idea on what's happening but can you take a screenshot using the Screenshot application?

Question owner

Screen shot with personal and geo details removed.

Screen shot with personal and geo details removed.
Moses
  • Moderator
459 solutions 3607 answers

You could try toggling the follow prefs in about:config:

  • network.protocol-handler.external.mailto (change to true)
  • network.protocol-handler.expose.mailto (change to false)
  • network.protocol-handler.warn-external.mailto (change to false)

I can't test because I don't use Yahoo therefore cannot reproduce the issue.

Be careful when editing this config as it may cause strange things to happen maybe even break Firefox
If you see that things get worse, reset those prefs by right clicking them and selecting 'Reset' and we can troubleshoot some more.

You could try toggling the follow prefs in about:config: *network.protocol-handler.external.mailto (change to true) *network.protocol-handler.expose.mailto (change to false) *network.protocol-handler.warn-external.mailto (change to false) I can't test because I don't use Yahoo therefore cannot reproduce the issue. Be careful when editing this config as it may cause strange things to happen maybe even break Firefox<br> If you see that things get worse, reset those prefs by right clicking them and selecting 'Reset' and we can troubleshoot some more.

Question owner

Thanks for the quick reply Moses, did you see the screenshot? Here it is again.

Thanks for the quick reply '''Moses''', did you see the screenshot? Here it is again.
Moses
  • Moderator
459 solutions 3607 answers

Yes I did. Try the instrutions above and let me know what happens,

Yes I did. Try the instrutions above and let me know what happens,

Question owner

I am using webmail, on the Yahoo site, so I can't see why I need to be messing around with mailto prefs. Surely it would make more sense to disable all notifications of this type instead of disabling aspects of mailto?

I am using webmail, on the Yahoo site, so I can't see why I need to be messing around with mailto prefs. Surely it would make more sense to disable all notifications of this type instead of disabling aspects of mailto?

Question owner

I use Thunderbird for mailto links.

I use Thunderbird for mailto links.

Question owner

LOL, those points you mentioned were already set as you suggested:

true false false

LOL, those points you mentioned were already set as you suggested: true false false
Moses
  • Moderator
459 solutions 3607 answers

If you use Thunderbird you can set Firefox to respect that:

  • Go to Edit > Preferences
  • Click the Applications tab
  • Scroll down to mailto and set it as Use Thunderbird.
If you use Thunderbird you can set Firefox to respect that: *Go to Edit > Preferences *Click the Applications tab *Scroll down to mailto and set it as Use Thunderbird.

Question owner

I was already using Thunderbird as the default.

IN: Tools > Options > Applications.

I just want to disable the notification, is there anywhere to do this?

I was already using Thunderbird as the default. IN: Tools > Options > Applications. I just want to disable the notification, is there anywhere to do this?

Question owner

I need to set Yahoo to respect that. I already use Thunderbird as the default and Firefox respects that. I just want to disable or hide the notifications.

Something like this:

go to About:config and find plugins.hide_infobar_for_outdated_plugin then double-click on it, to toggle it to "true". https://support.mozilla.org/en-US/questions/939294

I need to set Yahoo to respect that. I already use Thunderbird as the default and Firefox respects that. I just want to disable or hide the notifications. Something like this: go to About:config and find plugins.hide_infobar_for_outdated_plugin then double-click on it, to toggle it to "true". https://support.mozilla.org/en-US/questions/939294

Question owner

This is similar to, or the same as, my problem: http://superuser.com/questions/363827/how-can-i-disable-add-application-for-mailto-links-bar-in-firefox
Gingerbread Man 403 solutions 1537 answers

Chosen Solution

I don't think there's an about:config preference to get rid of that notification bar, since it would break important functionality.

  1. Install Stylish and restart Firefox when prompted.
  2. Opens the Add-ons Manager (Ctrl+Shift+A), then the User Styles category.
  3. Click the Write New Style button at the top. Paste the following in the text box, give the style a name, then click the Save button.

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/*
Title: Yahoo! Mail - hide "add as an application for mailto links" notification
Author: http://forums.mozillazine.org/memberlist.php?mode=viewprofile&u=261941
Tested on: Firefox 28, Firefox 31
*/

notification[label^="Add Yahoo!"][value="Protocol Registration: mailto"] {
  display: none !important;
}

Note: if you absolutely don't want to install Stylish, you can use the userChrome.css file instead. Just make sure the first line of the style only appears once in that file.

Edit: I filed a bug report. If anyone here has the privileges to mark it NEW, please do so. There's already an identical one for Firefox OS that's ASSIGNED, so I think it's perfectly reasonable.

I don't think there's an about:config preference to get rid of that notification bar, since it would break important functionality. # Install Stylish and restart Firefox when prompted. #* https://addons.mozilla.org/firefox/addon/stylish/ # Opens the Add-ons Manager (Ctrl+Shift+A), then the User Styles category. # Click the Write New Style button at the top. Paste the following in the text box, give the style a name, then click the Save button. ---- <pre><nowiki> @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* Title: Yahoo! Mail - hide "add as an application for mailto links" notification Author: http://forums.mozillazine.org/memberlist.php?mode=viewprofile&u=261941 Tested on: Firefox 28, Firefox 31 */ notification[label^="Add Yahoo!"][value="Protocol Registration: mailto"] { display: none !important; } </nowiki></pre> ---- Note: if you absolutely don't want to install Stylish, you can use the ''userChrome.css'' file instead. Just make sure the first line of the style only appears once in that file. * http://kb.mozillazine.org/UserChrome.css '''Edit:''' I filed a bug report. If anyone here has the privileges to mark it NEW, please do so. There's already an identical one for Firefox OS that's ASSIGNED, so I think it's perfectly reasonable. * [https://bugzilla.mozilla.org/show_bug.cgi?id=998427 Bug 998427 - Don't Ask Again option for Add Application (registerProtocolHandler)]

Modified by Gingerbread Man

Question owner

That sounds like an excellent solution Gingerbread Man. But before I saw your reply I got fed-up waiting, so I just added the thing; thankfully the world didn't fall apart by adding it.

I am already using stylish, thus if any future problems of a similar nature occur I will remember your solution. I will mark your answer as the solution although I have not tried it. Your solution seems like a very valid and good idea, neat indeed, much appreciated, thanks.

I've not really explored modifying Firefox with Stylish, it is now on my to-do list.

That sounds like an excellent solution Gingerbread Man. But before I saw your reply I got fed-up waiting, so I just added the thing; thankfully the world didn't fall apart by adding it. I am already using stylish, thus if any future problems of a similar nature occur I will remember your solution. I will mark your answer as the solution although I have not tried it. Your solution seems like a very valid and good idea, neat indeed, much appreciated, thanks. I've not really explored modifying Firefox with Stylish, it is now on my to-do list.
cor-el
  • Top 10 Contributor
  • Moderator
17531 solutions 158524 answers

Note that you do not really need the Stylish extension and that you can also create a userChrome.css file with the default @namespace line and paste the extra lines below this namespace line in the userChrome.css file.

The Stylish extension merely makes it possible to manage these instructions more easily and you do not need to close and restart Firefox to make changes effective.

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder)
Note that you do not really need the Stylish extension and that you can also create a userChrome.css file with the default @namespace line and paste the extra lines below this namespace line in the userChrome.css file. The Stylish extension merely makes it possible to manage these instructions more easily and you do not need to close and restart Firefox to make changes effective. The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder)
Gingerbread Man 403 solutions 1537 answers

singy1234567891234 wrote:

I will mark your answer as the solution although I have not tried it.

You didn't. You marked cor-el's reply as the solution, which provided no suggestion relating to issue described in this thread.

singy1234567891234 wrote:

I just added the thing; thankfully the world didn't fall apart by adding it.

You've just added Yahoo! Mail as an option for mailto under Options - Applications, that's all.

''singy1234567891234 wrote:'' I will mark your answer as the solution although I have not tried it. You didn't. You marked cor-el's reply as the solution, which provided no suggestion relating to issue described in this thread. ''singy1234567891234 wrote:'' I just added the thing; thankfully the world didn't fall apart by adding it. You've just added Yahoo! Mail as an option for ''mailto'' under [[Set how Firefox handles different types of files|Options - Applications]], that's all.

Question owner

Sorry for the confusion I must have clicked the solved button on my inbox mistakenly thinking it was merely the link to the problem regarding the latest reply.

Hopefully your solution is now the chosen solution again, and to be sure I have edited the post to include a link to your solution.

Yes adding the mailto option doesn't really solve it, it just gets rid of it on this occasion. If it happens again I will adopt your solution. Thanks.

Sorry for the confusion I must have clicked the solved button on my inbox mistakenly thinking it was merely the link to the problem regarding the latest reply. Hopefully your solution is now the chosen solution again, and to be sure I have edited the post to include a link to your solution. Yes adding the mailto option doesn't really solve it, it just gets rid of it on this occasion. If it happens again I will adopt your solution. Thanks.
Chrome_user23 0 solutions 1 answers

I'm not installing Stylish spyware/adware to fix the single popup. Firefox should block these kinds of messages from websites and not annoy the hell out of user. Mozilla fail. I just installed Google Chrome and problem is solved.

I'm not installing Stylish spyware/adware to fix the single popup. Firefox should block these kinds of messages from websites and not annoy the hell out of user. Mozilla fail. I just installed Google Chrome and problem is solved.
Moses
  • Moderator
459 solutions 3607 answers

Chrome_user23:

Why are you even commenting on a SOLVED question in the first place? If you don't like the workarounds given by Gingerbread_Man and cor-el, then simply don't comment just to say you're not going to use it.

Thread closed by me.

Chrome_user23: Why are you even commenting on a SOLVED question in the first place? If you don't like the workarounds given by Gingerbread_Man and cor-el, then simply don't comment just to say you're not going to use it. Thread closed by me.