Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why don't add-ons upgrade to work on the latest version of Firefox?

  • 1 reply
  • 2 have this problem
  • 28 views
  • Last reply by NEKST

more options

Having all these add-ons doesn't make much sense if you keep getting a "not compatible with latest Firefox version. Yea sure I bought a s4 to run the older versions. Firefox seems to have alittle google mindset about themselves. Without the add-ons Firefox is just another search engine. Please make everything compatible.

Chosen solution

Add-ons are upgraded by the creator. It's their responsibility to keep their app/add-on up to date and working with the current Firefox browser.

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Add-ons are upgraded by the creator. It's their responsibility to keep their app/add-on up to date and working with the current Firefox browser.