X
Tap here to go to the mobile version of the site.

Support Forum

Why does not Firefox OS simulator (1.1) start on Firefox 27 on OpenSuse 13.1?

Posted

I am using the default version of Firefox (27) on OpenSuse 13.1. I downloaded and installed Firefox os simulator plugin, version 1.1 searched with Google, but it does not start. If I open the App Manager and then I click "launch simulator", I will receive the error that no simulator is installed. But the menu item "Firefox OS Simulator" is in "Tools"->"Web development" menu... EDIT: in "tools"->"plugins" there is "Firefox OS simulator 4.0.1 by Myk Melez". But why??

I am using the default version of Firefox (27) on OpenSuse 13.1. I downloaded and installed Firefox os simulator plugin, version 1.1 searched with Google, but it does not start. If I open the App Manager and then I click "launch simulator", I will receive the error that no simulator is installed. But the menu item "Firefox OS Simulator" is in "Tools"->"Web development" menu... EDIT: in "tools"->"plugins" there is "Firefox OS simulator 4.0.1 by Myk Melez". But why??

Modified by spode

Chosen solution

Okay, thanks for that info.

You're not the only Linux user having trouble, as there have been some other reports of this. Please follow this bug as we work to resolve the issue.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

ideato
  • Top 25 Contributor
772 solutions 5542 answers

Helpful Reply

Hello spode, i think for firefox 26 and above you need version 1.2 and above (1.1 can only be installed on Firefox 24 or Firefox 25.) see : https://developer.mozilla.org/en-US/docs/Tools/Firefox_OS_1.1_Simulator https://hacks.mozilla.org/2013/10/introducing-the-firefox-os-app-manager/ https://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator/ https://developer.mozilla.org/en-US/Firefox_OS/Using_the_App_Manager thank you

Modified by ideato

Question owner

No, Firefox OS Simulator 1.2 is not launched...But now it is recognized by App Manager.

No, Firefox OS Simulator 1.2 is not launched...But now it is recognized by App Manager.
J. Ryan Stinnett 1 solutions 2 answers

Do you see any errors if you open the Browser Console (Tools -> Web Developer -> Browser Console) after trying to start the simulator?

Are you on a 32 bit or 64 bit OS (from uname -a)? Is your installation of Firefox itself 32 bit or 64 bit (check output of "file /usr/lib/firefox/firefox" or a similar command based on where Firefox is installed)?

Do you see any errors if you open the Browser Console (Tools -> Web Developer -> Browser Console) after trying to start the simulator? Are you on a 32 bit or 64 bit OS (from uname -a)? Is your installation of Firefox itself 32 bit or 64 bit (check output of "file /usr/lib/firefox/firefox" or a similar command based on where Firefox is installed)?

Question owner

I am on a 32 bit Opensuse 13.1 and my installation of Firefox is the default one. So I would hope it is the 32 bit one.

This is the message that I obtain with App Manager: "22:17:55: Found simulator: Firefox OS 1.2 22:17:55: Starting simulator... 22:17:55: Simulator ready. Connecting. 22:17:55: connecting to localhost:42039 22:18:15: connection timeout. Possible causes: didn't click on 'accept' (prompt). 22:18:15: disconnecting 22:18:15: disconnected"

and this is the error within Console: "Il box XUL per l'elemento hbox contiene un elemento figlio inline #text, tutti gli elementi figlio verranno forzati in un blocco. line 3 about:app-manager" (it is italian)

I am on a 32 bit Opensuse 13.1 and my installation of Firefox is the default one. So I would hope it is the 32 bit one. This is the message that I obtain with App Manager: "22:17:55: Found simulator: Firefox OS 1.2 22:17:55: Starting simulator... 22:17:55: Simulator ready. Connecting. 22:17:55: connecting to localhost:42039 22:18:15: connection timeout. Possible causes: didn't click on 'accept' (prompt). 22:18:15: disconnecting 22:18:15: disconnected" and this is the error within Console: "Il box XUL per l'elemento hbox contiene un elemento figlio inline #text, tutti gli elementi figlio verranno forzati in un blocco. line 3 about:app-manager" (it is italian)
J. Ryan Stinnett 1 solutions 2 answers

Chosen Solution

Okay, thanks for that info.

You're not the only Linux user having trouble, as there have been some other reports of this. Please follow this bug as we work to resolve the issue.

Okay, thanks for that info. You're not the only Linux user having trouble, as there have been some other reports of this. Please follow [https://bugzilla.mozilla.org/show_bug.cgi?id=980437 this bug] as we work to resolve the issue.