Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I restore "I'm feeling lucky" search to the firefox url bar?

  • 5 replies
  • 9 have this problem
  • 47 views
  • Last reply by sugarcookie

more options

I used to be able to type in the name of a webpage in the firefox url bar, and I would go straight to to the website. For example, I would type in "rotten tomatoes," hit enter, and arrive at www.rottentomatoes.com. Now, instead of going directly to the website, it takes me to a google search page. This used to be set in about:config in keyword.url, but it's not working anymore. I have firefox 27 for windows.

I used to be able to type in the name of a webpage in the firefox url bar, and I would go straight to to the website. For example, I would type in "rotten tomatoes," hit enter, and arrive at www.rottentomatoes.com. Now, instead of going directly to the website, it takes me to a google search page. This used to be set in about:config in keyword.url, but it's not working anymore. I have firefox 27 for windows.

Chosen solution

Hello,


keyword.URL Hack!

Brings back the keyword.URL preference on Firefox 23 and up.

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

Hello,


keyword.URL Hack!

Brings back the keyword.URL preference on Firefox 23 and up.

Modified by Diego Victor

more options

So, this worked on my work computer, but not at home. It's the same version of firefox. At home, I installed keyword hack, but can't find keyword.URL in about:config. Other ideas?

more options

Hmm, create new thread for this issue, More contributors can help!

more options

Okay, I miraculously figured it out on my own. You can add keyword:URL back if it's missing. In case anyone else is having this problem: Go into about:config, right click where it says "preference name", select "new", select "string", for the name type "keyword.URL", for the string use this: http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=

You also have to have the keyword hack add-on installed or it won't work.

Modified by sugarcookie