Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Phone SD card not detected on my computer over USB

  • 24 replies
  • 43 have this problem
  • 12732 views
  • Last reply by choco-banana

more options

I have a ZTE phone running with FF OS 1.1. Since yesterday I don't know why the SD card is not recognized anymore on my computer. - USB storage is enabled on my phone - SD card is recognized on my phone - It doesn't work on other computers either - I tried to power off / restart the phone : no change - It was working before...

Any ideas? Thanks!

All Replies (4)

more options

I did an upgrade of several applications (not the OS), restarted the phone, and the connection via usb now works. I guess that one of the applications was blocking the access to the usb card (is it possible?). Anyway everything is fine now. Thanks for all the suggestions.

more options

Is there a new thread about it? I also experience this.

My SD is formatted as FAT32. In Linux I see devices sdd and sde appear (no sdd1 or sde1) but they're not mountable ("No medium found" error). Same thing in Windows 7: two removable devices appear with 0 bytes capacity.

I can use the card in my card reader and I see the files in File Manager in Firefox OS. Tried with other cables as well.

more options

choco-banana, I love your enthusiasm for the new zte c. Start a new thread on this for the zte c please and lets take a look. If there is an issue with the formatting of the sd card lets get a bug on this for your device.  :-)

more options

I installed an update today and SD card visibility is now fixed and they finally added Russian keyboard layout. Happy now :)

  1. 1
  2. 2