Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 27 keeps crashing

  • 21 replies
  • 106 have this problem
  • 5352 views
  • Last reply by Galvin

more options

Safe mode crash log. https://crash-stats.mozilla.com/report/index/dd6d1ea6-8488-4e36-93e9-011012140206

It crashes in safe mode. A lot more in normal. I think the main cause is tradingview.com. But vertsion 26 was very stable could run days with never crashing.

If I can't fix this i'll need to go back to version 26.

Chosen solution

Using firefox 28 beta. And I no longer crash when a website makes use of audio.

Read this answer in context 👍 1

All Replies (20)

more options

Several user comments indicate this crash occurs on Battlelog/Battlefield; one user each mentioned Command and Conquer Tiberium Alliances, an audio bible, and Vimeo. I'm not sure where any of these share a problem in common with the site you referenced.

There is a bug on file that doesn't seem to be close to a solution, which references sound card drivers. Possibly and update to those has created a new issue? I'm not aware of any workaround for this if it is the problem.

If you want to roll back to Firefox 26.0 to see whether that works better, you can find a link in this article, following the security warning: Install an older version of Firefox.

more options

I didn't change anything. Just upgraded to version 27.

more options

Try to set the Boolean pref media.windows-media-foundation.enabled to false on the about:config page.

more options

Still crash after setting that to false. Looks like I'm going to have to roll back. I wish I knew what they changed to cause so much instability.

more options

I found out the trigger for the crash. When ever someone does @myname in the chat I crash everytime. Maybe someone that knows about websites can track down why that is?

So far the only site thats crashing firefox is tradingview.com chat system.

more options

Is there any special notification that occurs when the chat script displays @myname?

Is the chat window just regular HTML, or does it run in Flash or Java? Usually if you right-click you will get a special context menu if a plugin is being used.

more options

It suppose to make a beep sound. Thats about it. Not sure what else. But I have media.windows-media-foundation.enabled set to false.

more options

When I right click there is an inspect element. But all that is greek to me.

more options

Hi Galvin, Inspect Element (Q) is part of Firefox's normal right-click menu, so it's probably not a Flash-based or Java-based chat window, at least not directly.

I'm not sure whether there are any other settings that come into play with making the beep sound that you could turn off.

I think it might be worth posting on the site's forum to see whether there is an option to disable the notification sound as a workaround.

https://getsatisfaction.com/tradingview

more options

I tried turning off the beep sound for when someone sends a message to me. But that doesn't work. But its 100% reproducible. So only thing is someone else needs to try it that's good with trouble shooting. Maybe someone can get to the bottom of it.

Crash log https://crash-stats.mozilla.com/report/index/c36e2f28-963c-408f-bcb0-0307b2140207

Modified by Galvin

more options

Downgraded to version 26. First time I had to do this. Let you know if I get issues still. So far looking good.

more options

I had to do this to can't use firefox 27 or 27.1 it crashing on the battlefield4 page when i play a game revert back to 26 works no problem.

more options

Hi Newfe, could you mention which operating system and version you use (is it Windows 8.1 like the original poster)?

more options

yes it is win 8.1pro (retail version) with all the updates.

if there any other thing u need let me know also version 26 works with no problems. soon has i install version 27 bf4 crashing and also i find it lags out .


Cooler Master HAF 932 GIGABYTE GA-Z77X-UD5H Intel Core i7 Processor Core™ i7-3770K OC 4.6 (Batch 3226C194 ) Patriot Viper 3 Series, Black Mamba Edition DDR3 8GB Patriot Viper 3 Series, Black Mamba Edition DDR3 16GB GTX770 Direct CU II OC GeForce GTX 770 2GB PCI-E (x2 SLI) Corsair Neutron Series GTX 240GB SSD Hitachi 1TB Deskstar 7K1000.C (x2 Raid 0) Seagate Barracuda 7200rpm 3TB (x2 Raid 0) Creative Sound Blaster X-Fi Titanium PCIE Corsair AX1200 Power Supply Noctua NH-C14 CPU Cooler 27" 350 Series LED Monitor (Samsung) Siberia v2 CS:GO Edition Headset Creative Inspire 5.1 5100 speakers Razer BlackWidow Ultimate Gaming Keyboard Razer Taipan Gaming Mouse

Modified by Newfe

more options

A fix has been created for Firefox 30, which obviously is a long way away. See: Bug 970147 – Crash due to fatal assert in WASAPI: handle_channel_layout asserts with "Format not supported, and no suggestion from WASAPI." While this avoids the crash, it sometimes leads to the audio not playing instead, which depending on the situation, may not be acceptable. A fix for that second problem is still in the works.

I don't fully understand the discussion in the bug, but it appears that a possible temporary workaround is to open the Sound Control Panel, find the Sound Blaster settings, and check the box for "Disable Sound Blaster Enhancements". Unfortunately, it's a global setting.

Often a fix can be "uplifted" to the next forthcoming release (Firefox 28) when there is enough time for testing and there are not a lot of related things that need to be changed, so there is hope.

About the bug tracking system: it's generally not helpful to add comments to bugs unless it contributes to a solution (i.e., "me too" and "hurry up" doesn't help). See: Bugzilla Etiquette.

more options

they should fix it bug if not i am going to have to go with chrome over even have to go with ie(NOOOOOOOOOOOOOOOOO).

more options

I can confirm that the Sound Blaster Enhancement has been causing my Fire Fox to crash since I upgraded to FireFox 27.01. I had a mono video that would cause my browser to crash everytime I played it. If I played it in Stereo I had no problem. I then unchecked the "Disable Sound Blaster Enhancement" box in my control panel and I no longer crash.

I certainly hope they are working on a fix for this. Sound Blaster cards and especially those using Enhancements has to be very high. Just fyi - I have the X-Fi Titantium HD card.

more options

download version 28 29 and 30 all fixed now

28 will be beta here is the bug link https://bugzilla.mozilla.org/show_bug.cgi?id=970147

status-firefox28:fixed status-firefox29:fixed status-firefox30:fixed

Like to say thanks for firefox for fixing the problem

more options

version 27 will not be fix 28 will be release in about 2 weeks i think.

https://wiki.mozilla.org/RapidRelease/Calendar

more options

That's great to know. I can hold off for a few weeks if I know a fix is coming. This is great news.

Thanks so much for everyones help.

  1. 1
  2. 2