Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Use volume button on ZTE Open only for music and not for ringtone/sms/alarm


I wounder if its possible to override the volume button on the device so it dosent change the ringtone and sms volume? I had this feature on iOS where I can set the ringtone and notification volume then a switch that sad "Change with buttons" = true || false. My Android device (Padfone2) did not have this feature and I end up missing calls and sms because you turn the volume up and down when you browse the web, listening to music ect.

Does someone know if this is possible on my ZTE Open with FFOS 1.1?

Post a Reply

Additional System Details


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

  • Top 25 Contributor
  • Moderator
252 solutions 3019 answers

Helpful Reply

The application volumes are different from the ringer and notification volume. If you look in your Sound settings, there are 2 settings to adjust for ringer and notifications (which takes cares of text and calls) and the Alarm volume (which obviously takes care of the alarm). If you go into an application and use the volume button changer, you are only changing the volume for the application. If this does not answer your question/ issue, please post back to us so we can know more to better suit our users and file a bug to have what you are looking for to be added in later versions.


Was this helpful to you? 2

Helpful Reply

Thanks for your reply! Try this: 1. Go to settings/sound, set max volume on ringer & notifications. 2. Open firefox browser and press volume down to nothing. Press o to get to home screeen. 3. Press power button to lock phone. 4. Press it again to light the screen up and press volume button one time up. 5. Go to settings/sound again...

My ringer volume is affected by the application volume, is this only for my phone?

It would be perfect if user could choose that volume button cant affect ringtone/sms volume (like it is with alarm) then a silent mode that mute not just ringtone but alarm and notifications to.

Was this helpful to you? 1
nhirata 2 solutions 41 answers

To further explain where the volume controls are going, 'There's multiple different settings for audio volume:

  • audio.volume.content: Affects the "content" and "normal" audio channels. It's an integer between 0 and 15 where 0 means muted (but not paused).
  • audio.volume.notification: Affects the "notification" and "ringer" channels. It's an integer between 0 and 15.
  • audio.volume.alarm: Affects the "alarm" channel. It's an integer between 0 and 15.
  • audio.volume.telephony: Affects the "telephony" channel. It's an integer between 0 and 5.
  • audio.volume.bt_sco: Volume when bluetooth headset is plugged in. It's an integer between 0 and 15.'

Take from https://wiki.mozilla.org/WebAPI/AudioChannels

So as per stated before, the Ringer & Notification has a different setting than the Alarm, as well as the Telephony voice and the content as well as blue tooth volume.

I agree that it can get rather confusing with which volume is getting affected when. In general if the sound is currently going off, then most likely that is what the volume is controlling. We should probably file a bug on somehow getting the volume controlling less confusing.

Was this helpful to you? 1
  • Top 10 Contributor
  • Administrator
  • Moderator
123 solutions 1476 answers

I did find this one for 1.3 Bug 887633 - Ringer and notification volume setting needs separation (edit) https://bugzilla.mozilla.org/show_bug.cgi?id=887633

I added info, not sure if this could be a separate bug.

Modified by guigs2

Was this helpful to you? 1
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.