X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I help to solve marketplace download error?

Posted

After a long time of wait for a new release I'd got my ZTE Open sucessfully updated to FFOS v1.1. But like before checking for updates and now especially downloading marketplace update will end in recurring errors.

Where can I found more information? Are there any logs that can help developers to solve this problem? Is it a ZTE Open only trouble?

Please help me to help you ...

Post a Reply

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

Diego Victor
  • Top 10 Contributor
  • Moderator
380 solutions 2227 answers

Hello, sometimes this happens with me too, what i do, i exit marketplace and back later and i can download, but i dont know how and why this happens

Was this helpful to you? 3
Reply
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Are you talking about downloading the marketplace update and installing it but then the update still appears after downloading? If not, please elaborate on the issue you are having.

Was this helpful to you?
Reply

Question owner

Exactly,

  1. "check now" for or "daily" update repeatedly ends in "There was an error when checking for updates",
  2. followed by notification "1 update available.",
  3. tapping that notification shows info "Marketplace 153.50 kb",
  4. selecting "Download" seems to get the whole file "153.50 kb downloaded",
  5. but really ends in "There was an error while downloading the updates."

Same maloperation with "Data connection" over my carrier instead of my wifi.

There have to be a simple tech reason for this misbehavior, so I want to help to find log files which can help to solve my and (as I can read in this forum) many other peoples problem.

Was this helpful to you?
Reply
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

I have made log files with my device and am filing a bug. Thank you for reporting back! You are helping to make Firefox OS better :)

Was this helpful to you?
Reply
Diego Victor
  • Top 10 Contributor
  • Moderator
380 solutions 2227 answers

Hello,

After reading the information provided about your issue I suggest a soft reset of the phone.

  1. Take the back cover of the phone off.
  2. Take the battery out.
  3. Take the SIM card and microSD card out (if applicable).
  4. Wait 10 seconds.
  5. Put the SIM card and microSD card back in (if applicable).
  6. Put the battery back in.
  7. Put the back cover back on.
  8. Turn the device on.
  9. Check if the issue you were having is still present.

Please report back to us if this solved your problem!

Thank you

EDIT: Sorry, this reply was to other question, can you delete this post, please?

Modified by Diego Victor

Was this helpful to you?
Reply
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Toddy, that won't fix the issue. This is a bug.

Was this helpful to you?
Reply
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Please note the link to the bug filed:

https://bugzilla.mozilla.org/show_bug.cgi?id=955755

Important: Please do not comment or post on bug reports unless you have substantial information that could benefit the process of the bug being processed. Thank you.

Was this helpful to you?
Reply

Question owner

Thanks Andrew, during the last hours I learned a lot of adb ;-) So, I added my own logcat file to your bug report to clarify that further builds of FFOS 1.1.0 (mine was from 2013-12-04) for ZTE Open got the same misbehavior.

Was this helpful to you?
Reply
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Thank you Neuromancer2013 for adding your log. Hopefully we will get somewhere, we have had reports in the past but unfortunately users did not have ADB or did not know how to use it. As well as, I as a volunteer just had time recently to get a bug on file. Thanks again!

Was this helpful to you?
Reply
Pycnopodia 0 solutions 9 answers

Hi I also have this problem with the ZTE orange model. I thought I would just say something about my experience. I live in a country not supported by ZTE and had to manually update the OS from 1.0.1 to 1.1.0. Soon after I started to get the message that I could update the marketplace but have never been able to (same problem as above). I am not sure if this is a similar problem that I do not live in a country with ZTE support and I have to update it manually...? Cheers,

Was this helpful to you?
Reply

Question owner

Thanks for your comment, Pycnopodia.

No, the misbehavior of our marketplace updates has nothing to do with dependencies on regional service providers for FFOS-Updates from ZTE.

As you can read in the filed bug https://bugzilla.mozilla.org/show_bug.cgi?id=955755 there is a comment related to Geeksphone Peak and Firefox OS Nightly images too.

So, stay patient like me and wait for a free developer with expertise on this error having a time slot for solution.

Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.