X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Untrusted connection

Posted

The issue started randomly 3 weeks ago. It keeps telling me that "no issuer chain was provided" I am EXTREMELY upset about this because I do not feel this is my issue to fix. Plus the problem only seems to happen on YOUR HOME PAGE, GOOGLE! I have not changed any settings on my computer to cause this issue and it only started after a firefox update! I have tried adding exceptions and it does not work! Here is the message I am getting.


"This Connection is Untrusted

You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

www.google.com uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer)"

Chosen solution

Try going into Firefox options and going to the advanced tab then into the Network sub-tab. Once there, under Connection, click Settings and then hit No Proxy. Firefox might be going through a Proxy Server which is making Google have an invalid Security Certificate.

Read this answer in context 9
Post a Reply

Additional System Details

Installed Plug-ins

  • npsitesafety (Official)
  • Shockwave Flash 11.9 r900
  • Google Update
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Shockwave Flash 11.7 r700
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG SafeGuard toolbar 17.2.0.38 (avg@toolbar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 10-17-2012
  • driverDate2:
  • driverVersion: 9.17.10.2875
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.urlbar.autocomplete.enabled: False
  • extensions.lastAppVersion: 26.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

Helpful Reply

"... only seems to happen on YOUR HOME PAGE, GOOGLE!"

Firefox hasn't used Google as the homepage for many years now.

Was this helpful to you? 15
Reply

Question owner

So why then did it pop up automatically as the home page when I reinstalled firefox? Doesn't matter whether I set it to be the home page or it was built in. The point is I can not add exceptions to get google to work with out this error. As I said before I have made no changes to this computer to make it do this. It is a windows 8 computer barely a year old.

Was this helpful to you? 2
Reply
Brayden M 4 solutions 26 answers

Chosen Solution

Try going into Firefox options and going to the advanced tab then into the Network sub-tab. Once there, under Connection, click Settings and then hit No Proxy. Firefox might be going through a Proxy Server which is making Google have an invalid Security Certificate.

Was this helpful to you? 9
Reply

Question owner

Thanks Baxterz! That fixed the problem. Can you tell me why this would have just happened like it did. Like I said in my first post it was after an update.

Thanks again for the help!

Was this helpful to you? 5
Reply
Brayden M 4 solutions 26 answers

I'm glad I could help! It's pretty weird that this happened only after updating but I might be able to tell you what the problem was if you remember what it was set to before you changed it.

Modified by Brayden M

Was this helpful to you? 0
Reply

Question owner

It was set on "use system proxy settings"

Was this helpful to you? 0
Reply
Brayden M 4 solutions 26 answers

Then it might be that you have some sort of proxy software installed or setup on your computer in which Firefox was using. If you don't, well then it's weird that it was doing that but at least the problem has been solved.

Was this helpful to you?
Reply

Question owner

Haha ok thanks again!

Was this helpful to you?
Reply
jscher2000
  • Top 10 Contributor
2359 solutions 20896 answers

A proxy often is set up by security software on your system as a way to intercept and filter your connections (for example, BitDefender and ESET). This doesn't create any errors for non-secure HTTP connections, but for secure HTTPS connections, you usually need to set up Firefox to recognize and trust your security software.

The proxy also can be set up by malware. You don't want to set Firefox to trust malware.

Was this helpful to you? 1
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

We have also seen reports where Fiddler got installed on the computer and that sends its own certificate to Firefox.

You should always check the details to see who issued the certificate or if an intermediate certificate is missing.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

Was this helpful to you? 5
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.