X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can select STARTTLS in 1.1.0.0-prerelease (Alcatel Onetouch) but get "bad security".

Posted

Alcatel Onetouch Fire, version 1.1.0.0-prerelease (Congstar). I try to add an email account with IMAP and STARTTLS. And keep getting the error message "bad security" and the information that no secure connection could be set up. The mailserver uses certificates - could this be the problem? Is there any way for me to fix this?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Curtis Parfitt-Ford 35 solutions 315 answers

Hello,

Thank you for reaching out to Mozilla Support about your issue. We are glad to assist you with your problem. After reading your issue, I would like to kindly ask you to update your device and applications if applicable.

Please check for updates by following these instructions:

Note:Updates will only download over Wi-fi to prevent data usage charges.

  1. Open the Settings application by tapping the Settings App (small) icon.
  2. Tap the Device Information button.
  3. Tap the Check now button.
  4. A notification will appear in the notication bar if an update is available.
  5. Swipe down the notification bar to get the utility tray and install the updates.

Did this fix your problem?

Hope this helps!

Curtis

Question owner

Hello Curtis,

thank you for your reply. Unfortunately, this did not help - when I check for updates, I get the notification that the system is already up-to-date. Should there be an update available for Alcatel?

kind regards,

 Waltraud
Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

Hi Waltraud!

Please file a bug: https://bugzilla.mozilla.org and post back the link to the bug here. I'll be glad to check on in after filing.
The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

Curtis Parfitt-Ford 35 solutions 315 answers

Helpful Reply

Hi,

Having reviewed the problem, it appears the problem is that your mail server is using certificates that are either self-signed or not signed by a CA trusted root. At the minute unfortunately it is not possible to add a new certificate into the Trusted Certificates on your phone.

Sorry about that!

Curtis

Question owner

Thank you Curtis and feer56 for your answers.

Following your information I checked bugzilla and there is a similar bug (https://bugzilla.mozilla.org/show_bug.cgi?id=850535), which was closed with "resolved invalid", because the self-signed certificates are not supported in the current version. So I will not open another bug, unless you think it would be helpful.

The GUI, as mentioned by Curtis does not have any option to add the certificate. Would there be any way to add it via the remote-management feature of the firefox os emulator?

Sorry, if this is a silly question - I've only had this phone for 2 days and I'm still trying to settle in....

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

According to the bug it seems that we won't have this feature available for a long period of time. You can file a bug as a suggestion but as I see from the bug, no action will be taken and it is possible that the bug may be even closed/ marked as a duplicate.

Supercalifragilistic 0 solutions 2 answers

I also have the Alcatel Onetouch Fire, version 1.1.0.0-prerelease (Congstar) and experienced the same problem. After changing both settings to SSL (port 993 & 465) it worked and I was able to connect to my e-mail-account (at 1&1).

Modified by Supercalifragilistic

Question owner

@Supercalifragilistic - thank you for your reply. However, this did not make it work in my case, because the self-signed certificate of the server is also used for the SSL-case and this seems to be the underlying problem.

@feer56 - thank you for your explanation. I opened the bug https://bugzilla.mozilla.org/show_bug.cgi?id=934176 with a suggestion to add this feature.

gb2g 0 solutions 17 answers

Hello Waltraud, hello Supercalifragilistic,

unfortunately, I have no solution for the issue. May I ask you a question instead? You have an Alcatel One Touch Fire from Congstar, with FFOS v1.1: is it correct that in the email app you are able to chose IMAP and SMTP with STARTTLS? I ask because I have a ZTE Open from Movistar (Spain) v1.1 and in the email app there is no such option. I can only chose between IMAP+SMTP (with SSL, port 993 and 465) and ActiveSync. My email providers SMTP server works with STARTTLS (port 587) so I am not able to set up my email account. May I also ask you for the Build ID of Congstars 1.1? The build ID of my device is 20130926115300.

Thank you.

Modified by gb2g

Supercalifragilistic 0 solutions 2 answers

Helpful Reply

I also have the two options IMAP+SMTP and ActiveSync. In the IMAP and SMTP-field there are SSL and STARTTLS as options. Seems to be the same as on your phone.

Question owner

Hello gb2g,

as Supercalifragilistic mentioned, the email app still has the selection between imap+smtp and active sync. For imap accounts it then has (under imap settings) SSL or STARTTLS + separate port selection.

Regarding the Build-ID - I have to admit that I could not find this information. I checked under settings->device information->additional information and found FW-Version, HW-Version, Platform-Version and, but no Build-ID. Where do I have to look? I'll be glad to tell you what it is, once I can find it...

gb2g 0 solutions 17 answers

Thank you for your answers. From what you tell me the options are not identical, as on my ZTE Open there is no SSL or STARTTLS option: under IMAP+SMTP there are only fields for the loginname, the server (and the port numbers, but these have to be set to SSL port numbers in order to work). So my device only works with SSL, not with STARTTLS.

https://support.cdn.mozilla.net/media/uploads/images/2013-11-05-14-07-52-89ce1a.png


I found the Build ID information exactly where you looked, so the devices seem to be different also in that regard. Maybe you can find a "Git commit info"? (same place) Mine says "2013-09-26 03:41:00 ...". What I am interested in is the date of the software, because from what I read on Bugzilla, the STARTTLS option was introduced end of september. Seems that I missed it for a few days! I am afraid all I can do right now is to wait for the next update...

Cheers

Modified by gb2g

Question owner

Looking at your picture and the description I can confirm that this really looks quite different. Unfortunately, I also have no "Git commit info" under device information. Maybe I can help a bit with the date: the first shipping of the Congstar Alcatel phones was delayed until 25th of October, because they got a last minute SW-update due to a bug in the battery-meter display (that was the explanation they provided). So my guess is that the STARTTLS option also arrived with this update.

gb2g 0 solutions 17 answers

Thanks for your feedback Waltraud. Yes, maybe this battery-meter bug was not such a bad thing then!

BTW, the ZTE update came only one week earlier on October 17th (OTA). So maybe it was not the date but simply Telekom that was pushing for the STARTTLS support, as their SMTP server work with STARTTLS.

nonotford 0 solutions 1 answers

I'm running into a similar issue on 1.4. It would be nice to have an option to allow self-signed certs.

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

I am locking this thread due to it being an old asked original question. If you have any new or further questions please ask a new question at /questions/new.

Thanks!