X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't boot after OTA v1.1 upgrade (ZTE Open Spain)

Posted

Hello,

I got my ZTE Open (Spain) pretty much working very well with the 1.0.1 official upgrade from ZTE (for Spain models). Then today I got a new system upgrade available (30Mb+) and proceed to download the upgrade.

After a while, the phone rebooted and kept in the loading screen rebooting again and again. I did tried soft reset, factory reset and didn't work out.

Then, as I found the update was stored in the SD card (updates/fota/update.zip), I did tried to apply it again but got "Error in /tmp/sideload/package.zip". Here is my recovery log: http://dpaste.com/1420406/

I tried also downgrading to v1.0.1 but I can't because it complains is not v1.0.0 system.

I hope anybody can point me out a solution, I live in south america and bought this phone from Spain , so having to return it will not be easy nor quick.

Modified by rolando1

Chosen solution

I have good news!

Today I noticed in the ZTE website, even though the System OS version didn't change, the date for the upgrade image was just few days ago (2013-11-08).

So, I downloaded the image, proceeded with the upgrade and EVERYTHING WORKED RIGHT!

Sorry the caps, I'm so excited :)

Thank you all for your help, especially Mozilla staff.

Download page for ZTE Open Spain: http://www.ztedevices.com/support/smart_phone/176dd5a1-9d70-40a5-80ce-baa1c4ca6173.html?type=software

Here is the country selector: http://www.ztedevices.com/support/selectproduct.html?type=software

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36

More Information

Ralph Daub
  • Administrator
58 solutions 431 answers

Hi Rolando1,

I am sorry to hear that you are having issues with your ZTE Firefox OS device from Spain after downloading an Over The Air (OTA) update. I understand your frustration, and hope that we will be able to find a quick solution.

Thank you so much for your detailed information and the recovery logs. I am forwarding this issue to our helpdesk and engineering departments.

Would you please, also provide some additional information that may be helpful for our engineers?

  • Can you please describe how the update process went? Did you see an installation bar before the device fail? Did it complete the installation before the device fail?
  • Do you remember anything unusual about the battery status when installing the update? Was it near empty, full, plugged in to the outlet?
  • Can you please describe the steps that you are using to attempt downgrading your ZTE Firefox OS device?

Thank you for your assistance in helping us find a solution to this problem. We look forward to hearing back from you.

- Ralph

Question owner

> Can you please describe how the update process went? Did you see an installation bar before the device fail? Did it complete the installation before the device fail?

Sadly, I left the phone unattended as it was a relatively large download. I just noticed the phone when it went off and started again. At this point the phone reached the sitting fox loading screen and kept rebooting again and again.

After I tried installing the downloaded update.zip (in /sdcard/updates/fota/), when the phone starts reaches the sitting fox loading screen and it keeps there indefinitely.

> Do you remember anything unusual about the battery status when installing the update? Was it near empty, full, plugged in to the outlet?

I plugged the usb charger, then started to download the update.

> Can you please describe the steps that you are using to attempt downgrading your ZTE Firefox OS device?

As I already had the update.zip in the /sdcard/ downloaded from http://www.ztedevices.com/support/smart_phone/176dd5a1-9d70-40a5-80ce-baa1c4ca6173.html?type=software I boot into the recovery screen and select the option to install the update from external device and choose the update.zip in the root of the sdcard.

The error is like: assert ro.build.display.id == ...

Ralph Daub
  • Administrator
58 solutions 431 answers

Hi Rolando1,

Thank you for your continued patience and for providing all these details. This issue has already been escalated and we are looking into it.

In the meantime - I imagine that you may have already tried this, but if not, can you try to Wipe cache partition and Wipe data/factory reset while in the recovery mode screen?

Please be aware that these steps will delete all the settings stored in your phone. Your SD card will remain intact.

If you decide to try these steps, please let us know what were the results. We hope to resolve this issue as soon as possible.

Thank you,

- Ralph

Question owner

Thanks for your reply.

Yes, I did tried to wipe cache/data many times without any change in my issue.

I had enabled the remote debugging option before updating but it seems now it is disabled. Do you know if it's possible to enable the remote debugging somehow in this scenario?

Ralph Daub
  • Administrator
58 solutions 431 answers

Hi Rolando1,

I am not certain if it is possible to enable remote debugging in this scenario, but I will try to find this out for you. I have filed bugs for this issue and we are still looking into it.

In the meantime, I am curious to know what happens if you try to go into Fastboot mode. Can you please try the following instructions from our QA:

https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Hardware_Cheat_codes
FYI, Inari refers to the ZTE Open.
Doing the vol down+up + power should put you in fastboot mode. This means that the "fastboot" should be able to see the device. ie, by running the command:
fastboot devices
If this works, you may be able to flash partition images onto the phone using fastboot.

Thank you for your help!

- Ralph

Question owner

I tried to boot in fastboot mode, only the red light turned on and no screen signal (no vibration too). I plugged the usb cable and ran 'fastboot devices', no output. The device didn't respond to the power button so I had to remove the battery.

Question owner

For the record, other Movistar users reported the same problem:

https://www.mozilla-hispano.org/foro/viewtopic.php?f=47&t=16762 (spanish forum) http://comunidad.movistar.es/t5/Software-y-Sistemas-Operativos/ZTE-Open-Nueva-versi%C3%B3n-disponible/td-p/1506550 (Movistar spanish forum)

Modified by rolando1

Black_Cat 0 solutions 8 answers

Hello,

I have a similar problem on a "ZTE open" from Movistar spanish operator.

After downloading the OTA 1.1, my phone succeeded in rebooting BUT it can't access anymore to the memory SD card as if it wasn't there.

SO THEN, I had a bad idea : I reseted my phone to factory from the special menu (holding power+up).

SINCE this time, it can't reboot and stays with the sitting fox blue screen.

After that, I tried to use the OTA update.zip in SD Card but I've obtained "Error in /tmp/sideload/package.zip" (status 0).

If i used the stock rom "Spain OPEN SD card upgrading instruction & software package(TME)-216640B0996OPEN_FFOS_V1.0.0B04_TME" from ZTE website, I have "Error in /tmp/sideload/package.zip" (status 7).

My phone is now useless thanks to zte/movistar/firefoxOs update. I start regreting my choice in trusting in this new OS mobile with ZTE as manufacturer. :-(

I will undergo very complicated processes, wich are not easy for common people, to restore it (if it's possible!) OR it will go to trash..........

I hope a solution quickly from anyone.

Regards,

EDIT : the md5 check fails with : Finding file_list package... Opening file_list package... Verifying file_list package... E:failed to open /system/etc/verify.zip (No such file or directory) E:signature verification failed

Modified by Black_Cat

Black_Cat 0 solutions 8 answers

I don’t know how to begin this message, I’m tired, pissed of and angry because of all the problems I have now for a damned update. And no one seems to care about my/our problem.

I asked help directly from ZTE and the only answer I got was :

Dear Valued ZTE Customer Thank you for contacting ZTE. We apologize for the inconvenience caused to you. Please contact the local dealer where you purchased the device to or network operator to know the after sales policy so that they can assist you to fix this issue. Should there be further assistance, please do not hesitate to contact us. Best Regards

I don’t know what to do. I’m not in Spain anymore, it’s not possible for me to go in a shop for the next months. My local dealer is 1500km away. I don’t even know if Movistar took my problem seriously but, whatever, it’s a shame. I don’t know if I have to ask to ZTE, Mozilla or Movistar to be heard. First solution is not an option anymore. I bought my phone only 2 months ago and now is bricked: its only destination is the trash.

Actually I can only discourage you to buy the combo ZTE/Movistar/FOs phone. I don’t even know where the trouble is because I NEVER HAD A PROPER ANSWER so how can I be positive about FirefoxOs experience now ????

mluna
  • Administrator
  • Moderator
66 solutions 462 answers

Hi Black_Cat,

I apologize that we missed your post about this on Saturday, we are very concerned about this problem with the update to v1.1 and we are investigating how to resolve it with Movistar and ZTE.

We have one other user on the mozilla-hispano forum with the same issue we are trying to resolve. Did you post your question there originally? (I want to be sure I know that we have two different users with this issue).

We do take this issue very seriously and we should have responded to your post sooner. Thank you for your patience and for the detailed issue you posted above, this will help us to investigate it and hopefully get an image that works for you or some alternate means to install if that is the root problem.

Thanks again for your post and I apologize for our delay in responding, we have every intention to help any user with a critical issue.

Regards, Michelle Luna Firefox OS Support Manager, Mozilla

mluna
  • Administrator
  • Moderator
66 solutions 462 answers

Ok, thanks for the link and confirmation.

Regards, Michelle

Black_Cat 0 solutions 8 answers

How many people buy a FirefoxOS smartphone?

How many people buy a ZTE open?

How many people buy in Spain in a Movistar shop?

How many people have a problem with the update OTA 1.1?

How many people are next to their local dealer to eventually change the phone?

How many people can go here to explain their problem?


With all these questions, it seems to be clear that we represent a minority and big companies don't really care about us. It's almost normal, because we don't bring much money. They had their international glory time with incredible promotional ads: for Movistar one of the first network operator proposing this OS, for ZTE an incredible chance to introduce them on the occidental market.

Now, months have passed and perhaps they are not so interested. If they don't find a solution quickly, they will probably forget us and it will be very bad news for the development of FirefoxOS and the users who tried to help for the birth of new mobile OS.

In this story, I have the impression to be the bad guys/troll, and I'm really sorry but I only updated my phone by the official way and now it doesn't work anymore. I have to find another phone and I'm still disapointed.

I know this is a new OS with its bugs and features but a bricked phone... I think people can understand our feelings: it's a big failure. I didn’t buy a smartphone in development proposed by the great little spanish company which is now well known by FirefoxOS users community, but I bought the smartphone in the historical network operator shop in order to have something more or less stable even if I had to wait more, so then users like us could expect more support but finally, it’s the opposite.


Last thing, english and spanish are not my native language. Unfortunately there is no official suppport in my native language so I do my best to be understandable.

Movistar shy reaction seems to begin today, so maybe we can expect a move?

Now I'll shut my mouth here for a moment, wait and see...

Regards,

PS: Rolando1 gave some interesting logs in the movistar forum (link above). One of them is on the first message of this topic. It could be helpful for you.

Modified by Black_Cat

mluna
  • Administrator
  • Moderator
66 solutions 462 answers

Hi,

Just an update today that we have requested a new package from ZTE to try to resolve the issue you are having. I will post more details when I have them, thanks for your patience.

I hear your frustration and appreciate your understanding. These are the early days (today is day 116), so I hope you do know that we appreciate very much your contribution to this effort by being one of the first adopters of the fxos commercial devices, we'll do all we can from our side to get you up and running again asap. Apologies for the delay and inconvenience.

Regards, Michelle

Question owner

Thank you very much Michelle for the update.

aledelreal 0 solutions 3 answers

Well, I am joining the growing club of people with an expensive brick as a smartphone :(

I had the update notification, system one and mandatory. Then it restarted on the recovery mode, asked to apply update, tried to restart and since then it doesn't boot. It only goes as far as showing the red fox and blue background, and the tail isn`t even moving.

I am in Colombia, so I went to ZTE website, downloaded the update zip file, put it on the sd card, well, followed the entire plan exposed before here and nothing. I always get the same answer: "E: failed to verify whole-file signature E: signature verification failed"

I decided to try with every update file available: Colombia, Spain, Venezuela and UK/US, but I always get the same answer.

I wonder if the file provided by ZTE is corrupted? Where can I find one that actually works? Either an older version, newer, whatever. I mean, even an Android just to be able to re-install Firefox OS.

And my device was purchased in the very early days, so I have read there are some problems with fastboot (or something like that, I am not sure because I work in social sciences, technology computers are not my forte)

I really feel the same frustration and anger Black_Cat and other users talked about. I bought it as my mom`s very first smartphone, I didn't even have one myself when I got it for her. She barely could use it and then, an OFFICIAL update kills it. It is a prepaid phone, so no money back, or replacement because of a contract.

mluna
  • Administrator
  • Moderator
66 solutions 462 answers

Hi Aledelreal,

Thank you for notifying us that you also had this problem, I'm sorry for the frustration this has caused you. Did you buy the device in Colombia?

I do have some updates from the partners on this issue this morning.

If you are able to go back to the shop where you bought the phone, the ZTE post-sales center has agreed to either fix it or replace it.

If you are not able to return to the shop where it was purchased ZTE is preparing a new update package that will include the fix to avoid the boot up problem after the update. I appreciate your patience while they prepare the solution.

Best regards, Michelle Luna, Firefox OS Support Manager, Mozilla

aledelreal 0 solutions 3 answers

Hi mluna. Thanks for your asnwer. I took it to Movistar, Tech Support, because I bought it here as well. They tried to make it boot, but they were unable to, so i had to leave it there. They will return it on Nov 6th, and I will tell you what they said and what they did to it, or if they end up replacing it. I will keep you all posted.

Black_Cat 0 solutions 8 answers

Thanks for the feeback but d+11 without phone...

Black_Cat 0 solutions 8 answers

Seriously, is there something new?