X
Tap here to go to the mobile version of the site.

Support Forum

How do I prevent Firefox to use: www.foo.bar instead of foo.bar?

Posted

When I enter: foo.bar in the url/search box in the firefox android browser, it will invariably be converted to: www.foo.bar. FYI: adding a specific page does not alter this behaviour. Setting: browser.urlbar.autocomplete.enabled to false does not stop this. Is there a way to prevent Firefox on Android to display this unwanted behaviour? Firefox on Windows and Linux does not change the url entered. Why (this difference)?

Thanks in advance for your answer.

Ron

When I enter: foo.bar in the url/search box in the firefox android browser, it will invariably be converted to: www.foo.bar. FYI: adding a specific page does not alter this behaviour. Setting: browser.urlbar.autocomplete.enabled to false does not stop this. Is there a way to prevent Firefox on Android to display this unwanted behaviour? Firefox on Windows and Linux does not change the url entered. Why (this difference)? Thanks in advance for your answer. Ron

Chosen solution

Does it help to set browser.fixup.alternate.prefix to an empty string or set browser.fixup.alternate.enabled to false?

If there are pages in the history (don't know about the cache) with a www. prefix then Firefox might prefer those.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

anushbmx 17 solutions 214 answers

Ronzt, Only the website owner can do that, FF cannot force you to go for www version or non www version of a website.

for example you cannot visit http://google.com it will be redirected to http://www.google.com

and in case of twitter you can only visit http://twitter.com

got it.

A website can exist in http://www.example.com or http://example.com , in fact both are same for us humans, but search engine bots take them as different and they will be treated as duplicate content.

In order to prevent that web masters according to their choice select a version and redirect visits to other on to the one they are interested in.

Check My blog post for a little more info - http://techstream.org/Web-Development/SEO/URL-Normalization

Thank you

Ronzt, Only the website owner can do that, FF cannot force you to go for www version or non www version of a website. for example you cannot visit http://google.com it will be redirected to http://www.google.com and in case of twitter you can only visit http://twitter.com got it. A website can exist in http://www.example.com or http://example.com , in fact both are same for us humans, but search engine bots take them as different and they will be treated as duplicate content. In order to prevent that web masters according to their choice select a version and redirect visits to other on to the one they are interested in. Check My blog post for a little more info - http://techstream.org/Web-Development/SEO/URL-Normalization Thank you
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156790 answers

Chosen Solution

Does it help to set browser.fixup.alternate.prefix to an empty string or set browser.fixup.alternate.enabled to false?

If there are pages in the history (don't know about the cache) with a www. prefix then Firefox might prefer those.

Does it help to set browser.fixup.alternate.prefix to an empty string or set browser.fixup.alternate.enabled to false? If there are pages in the history (don't know about the cache) with a www. prefix then Firefox might prefer those.
anushbmx 17 solutions 214 answers
  1. cor-el i didn't get what you meant...?
#cor-el i didn't get what you meant...?

Question owner

As I use: <machine>.<organisation> to connect to machines in my LAN, it doesn't help if Firefox changes: 'foo.bar' into: 'www.foo.bar'. Besides, this effect is only seen in Firefox for Android not in the windows or linux version. The solution for me lies in the answer user: cor-el suggested.

Thanks for your reply!

Greetz,

RonZt

As I use: <machine>.<organisation> to connect to machines in my LAN, it doesn't help if Firefox changes: 'foo.bar' into: 'www.foo.bar'. Besides, this effect is only seen in Firefox for Android not in the windows or linux version. The solution for me lies in the answer user: cor-el suggested. Thanks for your reply! Greetz, RonZt

Question owner

Hi Cor-el,

setting: browser.fixup.alternate.enabled to disabled does the trick for me. Thanks!

Greetz,

RonZt

Hi Cor-el, setting: browser.fixup.alternate.enabled to disabled does the trick for me. Thanks! Greetz, RonZt