X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to stop Document Expired security message

Posted

What is the config setting to stop Firefox putting up the Document Expired message when using the Back button? I don't regard the security 'risk' of automatically reloading the page as being significant.

comment deleted
from a moderator: please do not tell a support contributor not to respond to your support thread

Modified by the-edmeister

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.28
  • Version 3.18.3.12840
  • Shockwave Flash 11.5 r502

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

backbuttonsucks 0 solutions 10 answers

Did you try this:

go to about:config in location bar

search for browser.sessionstore.postdata

set value to -1

Some people say it doesn't work though. https://support.mozilla.org/en-US/questions/922734

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

This issue is caused by sites instructing Firefox not to cache the page. When you go back to the page, Firefox honors the site's instructions and requires you to regenerate the request. When it's a POST request, this requires an extra confirmation. Yes, that is annoying.

In many cases, you can work around this by opening links off the page in a new tab or new window.

If that isn't an option, you may need a program to modify the site's instructions (the cache headers) on the fly -- before they are received by Firefox. While it might be possible to do this with a Firefox extension, in a brief search, I didn't see any extensions that mentioned it. In an unrelated forum, I saw a suggestion to use an external proxy application such as Proxomitron.

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

I am attaching the HTTP Response Headers for a forum site where going back to your search results displays a Document Expired message. If there is any other way to tell Firefox not to cache the page -- in other words, to force a fresh request every single visit to the page -- I'm not aware of it.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8020 answers

N.B. Apparently fx21 still in use.

Comment OP dugeen1 from duplicate postpost now locked /questions/969465

"I still need to know how to stop the 'document expired' message coming up when I reload certain pages. "

Modified by John99

jrwhart 0 solutions 2 answers

this nuisance occurs when returning to home page from a visited site so I can not see why the visited site would/could object to that

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

Hi jrwhart, I don't think the site's goal is to chase you away, but for you always to see fresh information when you load that page. In the case of pages generated by a form submission, Firefox shows warnings instead of reloading automatically. I haven't learned of any workarounds.

jrwhart 0 solutions 2 answers

I have a workaround, get a programmer with a brain to look at the problem saving a return address was a basic function, initially pf3, this crap we are fed about sites objecting to this procedure is just that misinformation to cover up incompetence.