X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop Firefox for Android from popping up the on-screen keyboard when loading a page with a search box on my Samsung Galaxy Tab 2?

Posted

When I go to certain sites on the web which have search boxes, Firefox will pop up the onscreen keyboard as the page load completes, without me doing anything to focus the search box. It's annoying to have to tell the keyboard to go away each time before I can navigate in the page.

I specified the device I am using (Galaxy Tab 2 7 inch) because it uses a nonstandard keyboard applet, called simply the Samsung Keyboard, which could be doing something different than the regular Android one. I don't have the option of switching to the stock Android keyboard.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Type about:config in the address bar and search dom.disable_open_during_load and set it to false.

kbrosnan
  • Top 25 Contributor
  • Moderator
248 solutions 1749 answers

Helpful Reply

That won't help iamjayakumars. That pref blocks popup windows on load. The keyboard is not a popup window.

This behavior happens because the website sets focus to a text box on the page. Firefox is following the standard behavior for desktop browsers.