Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Load Images Automatically Missing


Firefox Version 23.0 Mac 10.8.4

With version 23 of Firefox the preference "Load Images Automatically" under the content tab is GONE. The only options that remain are Block Pop Up Windows, Fonts & Colors, and Languages.

I use this preference EXTENSIVELY and I have searched every corner of the preference panel in case it was moved and I cannot find it anywhere. Please do not tell me you got rid of this function.

UNRELATED - On this website there is no way to contact support with an existing account. Clicking on the 'I already have an account' button does absolutely nothing. I have tried it in every browser. You must create a new user account to get the page I am writing you on.

This thread has been locked by a moderator because the recent tone of the responses has deteriorated into the gutter. Question asked and answered (repeatedly). Please start your own thread using Ask a question if you need support.

Modified by the-edmeister

Chosen solution

The checkbox was a convenient way to switch the permissions.default.image preference between 1 (checked) and 2 (cleared). However, it did not provide any additional functionality.

Do you want to investigate this extension as a workaround? A toolbar button would be more convenient than using the Options dialog or about:config.

Image Block - "Image Block adds a toggle button that conditionally blocks/allows loading of images on webpages."

Read this answer in context 3

Additional System Details


  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/536.30.1 (KHTML, like Gecko) Version/6.0.5 Safari/536.30.1

More Information

dashcam1701d 0 solutions 1 answers

I also use(d) "Load Images Automatically" a great deal when using Firefox over a remote desktop session (from work to home) in order to reduce bandwidth, and to be discrete. I'm very disappointed that it's been removed from the user settings. I'll use the about:config workaround, that's not a big deal. I just might leave it off all of the time now that it's more work to turn it on and off.

I've been looking for a reason to switch to Chrome. Haven't found one yet. Maybe this is it.

Modified by dashcam1701d

  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Did you look for extensions?

Ashtoreth 0 solutions 1 answers

Sure, I was upset at first. But I for one am going to embrace the unnecessary complexity of these hitherto fundamental browser functions. By declaring these simple on-off switches too complex for the numb hordes to be trusted with, Mozilla has elevated us low-power power users to the hacker 1337. We are lords among Eloi! High Elves in the ruins of Middle Earth! Those of us with borderline competence are now the new brain trust! Look out, Mensa! All hail the new idiocracy!

Mozilla has sensibly deemed the blanket activation and deactivation of images and Javascript to be far too volatile a decision to leave to common rabble, and thus has wisely removed the relevant checkboxes and buried this functionality in the about:config page where it cannot easily fall into ordinary users' hairy paw-hands. Thank god we're safe now.

Modified by Ashtoreth

Edgar_Wine 1 solutions 2 answers

> Translated with http://translate.google.ru


>> "Load images automatically" and Always show the tab bar" checkboxes
>> removed from preferences and reset to defaults.

NOOOOO!!!!! I really do need this setting! I had a lot of items there! About 2700 domain names! I've collecting them for years!! My personal image-block-list! Where are them?? What you have done!((

  • Top 10 Contributor
  • Moderator
3202 solutions 24452 answers


I don't believe the actual domain preferences were removed, only the preferences related to those two check-boxes.

Try this extension which provides a UI for accessing and modifying the permissions.sqlite file where those settings are saved.

bfishyb 0 solutions 1 answers

I use this feature extensively to block exposure to immodest images. I heavily use the exceptions for websites that I regularly visit that don't have such images. It is not sufficient to set the exception just for the website name, but it often must be done for several related URLs, because websites often host their images on other URLs.

This feature is so critical to me that I will now switch to Chrome, which has this feature. Please let me know if you restore this feature.

  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

I use the PrefBar extension to manage a lot of prefs easily via check boxes and menu lists.

nullsix 0 solutions 3 answers

i use old version of firefox because of this situation.

Please, in next version of firefox, BRING BACK the

Load images automatically and Enable Javascript Options

nx9010 0 solutions 1 answers

I'm disappointed : ( hope this will be fixed soon. Until then someone know where can i download the last version of Firefox where the "Load Images Automatically" option is still present?

thank you all

  • Top 10 Contributor
  • Moderator
3202 solutions 24452 answers

There's nothing to "fix" in the view of the Mozilla developers - they made these changes on purpose.

My suggestion is to install the Quick Java add-on.
Quick Java allows quick enable and disable of Java, Javascript, Cookies, Image Animations, Flash, Silverlight, Images, Stylesheets and Proxy from the Statusbar and/or Toolbar.


If you want to complain to Mozilla, please do so here:
The people doing support here are users just like you. We have no "say" in the development process (or destruction process)

ballhest 0 solutions 1 answers

I think the developers who came up with this genius change should buy me dinner at a fancy restaurant, because I like to at least get wined and dined after I get F*CKED!!!!!!!!!!! The old way worked exactly as intended, you could globally turn off images and javascript for a while, when going to a website where you need to. I tested the solution with right-click, view page info, and set the image load under permissions, but for me it still kept loading images on the page where I need to block them the most, because the images I need to block aren't originating from THAT domain of course..

I am very angry with this new change! I see the explanations in this thread trying to justify the change, and I see that I have to remove and re-install to a previous version, if its possible at all.. I'm afraid you guys don't realize what you have done. A global image block is really neccessary when for instance using certain forums for communicating, because other users can get your IP address by post images in threads or sending you a PM with an image. And someone getting your IP address is not always very good, if you know what I'm saying. I dont like being DDOSed.

If I cannot roll back to a previous version, then I am done with firefox for good, thanks to you guys wanting to make it nicer for the idiots (who are btw using internet explorer anyways so they dont care)... This change is so unbelieveably stupid, I find it hard to get how you could keep your jobs..

The other thing, yeah, the javascript.. I guess you guys aren't aware that now there are javascript bitcoin miners that can be easily implemented on websites, so since you are now making it harder to turn javascript off too, hackers and miners are going to pop the champagne bottle and celebrate your ignorance..

The time I spent complaining here, I should have used for uninstalling what was my favorite browser, that now turned into a TURD!

Modified by ballhest