X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I stop Firefox from blocking a Java applet from a site that I trust?

Posted

I'm trying to run an application that displays competitors' routes at an orienteering event. My problem is that Firefox blocks the Java applet. I get a window saying "Application Blocked by Security Settings. Your security settings have blocked an application from running with an insecure or expired jre."

I've tried looking at the Firefox help on "How to enable Java if it's been blocked", but that's no help. It talks about clicking on the red plug-in icon in the address bar, but there isn't a red plug-in icon in the address bar.

The application is from www.epoc.routegadget.co.uk. It worked when I used it last Sunday.

Help, please!

Chosen solution

hello, this warning isn't coming from firefox but from the java plugin itself - please update your plugins.

some more information about java's security settings are also available at oracle's support: https://www.java.com/en/download/help/jcp_security.xml

Read this answer in context 41

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-In 4.0.4.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Yahoo! activeX Plug-in Bridge
  • Windows Multimedia Services DRM Store Plug-In

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Norton Toolbar 2013.4.1.2 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Download Accelerator Plus Integration 8.0.6.5 ({F17C1572-C9EC-4e5c-A542-D05CBB5C5A08}) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Norton Vulnerability Protection 11.3.0.9 - 5 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82945G Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2772
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.14.10.4926']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 10-14-2005
  • driverDate2:
  • driverVersion: 6.14.10.4410
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.14.10.4926']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.14.10.4926']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 686080
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: http://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.warnOnClose: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • gfx.blacklist.suggested-driver-version: 6.14.10.4926
  • network.cookie.prefsMigrated: True
  • network.http.spdy.enabled: False
  • network.image.imageBehavior: 0
  • places.database.lastMaintenance: 1372446810
  • places.history.expiration.transient_current_max_pages: 80271
  • places.history.expiration.transient_optimal_database_size: 42533354
  • places.last_vacuum: 1326755002
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.item.downloads: False
  • privacy.item.formdata: False
  • privacy.item.history: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_tls: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
rfeichel 0 solutions 5 answers

I am having similar problems. I have the current version of FF installed, Java 7 update 25 and I continually get a message which says I need ver 6 and update 10 or higher. The plugins are current per FF. I need to unblock Java so that I can do business with my bank. FF or something blocks a jar file and the plugin is blocked. It is all reported as a security issue. I am never given an option to unblock.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Did you check the security settings in Java?

rfeichel 0 solutions 5 answers

I tried that and it makes no difference. (I disabled Java and then did a restart of the computer.)

jpdemers 1 solutions 11 answers

Your banking site may be using an outdated version of Java, in which case you'll need to revert to Apple's SE 6 plug-in. (It gets removed when you install the more recent versions of Java, or allow OS-X to install updates automatically.) Instructions for resuscitating the plug-in are at http://support.apple.com/kb/HT5559

Coogie 0 solutions 1 answers

Windows 7, Vista Windows XP

   Click on the Start button and then click on the Control Panel option.
   In the Control Panel Search enter Java Control Panel.
   Click on the Java icon to open the Java Control Panel.

(1) In the Java Control Panel, under the General tab, click Settings under the Temporary Internet Files section. The Temporary Files Settings dialog box appears. (2)Click Delete Files on the Temporary Files Settings dialog. The Delete Files and Applications dialog box appears.

 (3)  Click OK on the Delete Files and Applications dialog. This deletes all the Downloaded Applications and Applets from the cache.
   (4)Click OK on the Temporary Files Settings dialog. If you want to delete a specific application and applet from the cache, click on View Application and View Applet options respectively.

That's what finally helped me after following all the other confusing solutions. Go back to the site you want to use and it should work. Good Luck