Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox android app fails when using orbot (tor)

more options

I have Orbot installed and have torified Firefox, my stock browser and several other apps in my Orbot settings. I after activating Orbot and connecting to the Tor network, my stock browser works just fine and I can go to websites. Firefox however returns an error page (unable to connect/check your network settings). What settings do I need to adjust to use Firefox for android and orbot. Also, my stock browser apears to work fine and, as intended, sites cannot identify my origin. I am using a Droid X running Cyanogen Mod 7. Thanks

Chosen solution

Thank you for your help. Just in case other users need help I included my solution below.

I was able to solve this issue by doing the following: 1. Went to about:config 2. entered 'proxy' in the search field 3. Changed the following settings:

 network.proxy.http   127.0.0.1
 network.proxy.http_port   8118
 network.proxy.socks   127.0.0.1
 network.proxy.socks_port   9050
 network.proxy.socks_remote_dns   true
 network.proxy.type   1

4. Quit and restart Firefox

A user can also use the Proxy Mobile add-on from the Guardian Project. The add-on changes these settings for you, but before this post I was having compatibility problems with the add-on from addons.mozilla.org so I wanted to do it manually. I found the most updated add-on (https://guardianproject.info/releases/proxymob-latest.xpi) and installed. You'll still need to put in the port numbers specified in 3 above.

Thanks again

Read this answer in context 👍 3

All Replies (5)

more options

You may need to manually setup the proxy info. If you can find that data it can be added to the proxy parts of about:config.

more options

Chosen Solution

Thank you for your help. Just in case other users need help I included my solution below.

I was able to solve this issue by doing the following: 1. Went to about:config 2. entered 'proxy' in the search field 3. Changed the following settings:

 network.proxy.http   127.0.0.1
 network.proxy.http_port   8118
 network.proxy.socks   127.0.0.1
 network.proxy.socks_port   9050
 network.proxy.socks_remote_dns   true
 network.proxy.type   1

4. Quit and restart Firefox

A user can also use the Proxy Mobile add-on from the Guardian Project. The add-on changes these settings for you, but before this post I was having compatibility problems with the add-on from addons.mozilla.org so I wanted to do it manually. I found the most updated add-on (https://guardianproject.info/releases/proxymob-latest.xpi) and installed. You'll still need to put in the port numbers specified in 3 above.

Thanks again

more options

G'day...

I have the same prob with my LG P-880g 4X on Wind Mobile. Installed onion router (Orbot) and blew thru firewall in Tim Hortons to get to banned site ok. Then turned off Orbot and now FF erroring out with "connection refused by proxy". Not good. I tried setting FF proxy settings as shown in this solution but no joy. Maybe someone at Mozilla could post a roadmap of about:config settings so we somewhat advanced users don't have to guess... its a lot better on desktop FF but basic setting like Proxy SHOULD be in the Options menu accessable for all in the mobile browser as well. ---== Hummer ==---

more options

Oh Joy!!!

Here are the settings to put FF back to no Proxy:

<vbox xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

 <setting pref="network.proxy.type" type="boolint" on="1" off="2" title="Use Proxy"/>
 <setting pref="network.proxy.http" type="string" title="HTTP Proxy Host"/>
 <setting pref="extensions.proxymob.network.proxy.http_port" type="string" title="HTTP Proxy Port"/> 
 <setting pref="network.proxy.socks" type="string" title="SOCKS Proxy Host"/>
 <setting pref="extensions.proxymob.network.proxy.socks_port" type="string" title="SOCKS Proxy Port"/>
 <setting pref="network.proxy.socks_remote_dns" type="bool" title="SOCKS Remote DNS"/>
 <setting pref="network.proxy.ssl" type="string" title="SSL Proxy Host"/>
 <setting pref="extensions.proxymob.network.proxy.ssl_port" type="string" title="SSL Proxy Port"/>

</vbox>


This is the code from the file [ options.xul ] contained within the [ proxymob-latest.xpi ] FF installer. It pays to dig a little to find what you want. Been a problem-solver all my life. I sincerely hope this helps someone else who finds himself stuck after installing OrBot.

-)) --== Hummer ==--
more options

BTW, it is the FIRST setting that counts! Just set [network.proxy.type] to boolian value [ 2 ] and the proxy is OFF> set to [ 1 ] and its ON... the rest of the settings are for when the proxy is on (connected to TOR). If one is stuck with this prob, then he will not be able to DL the .xpi to install a Proxy controller app to his 'droid. Why is this not an option in the regular options menu for all to see? With all due respect, IMHO [about:config] is not for the faint of heart where a noob can kill his Firefox real quick with one mis-step. Better the noob finds the settings in a menu with some kind of direction as to how to do what he needs to do. Sorry for being such a nit-picker! Otherwise, Firefox Mobile is a great app... 5 stars anyway.

--== Hummer ==--

Modified by --== Hummer ==--