Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I fix very slow response after waking up computer from Sleep mode?

  • 10 replies
  • 12 have this problem
  • 23407 views
  • Last reply by jscher2000

more options

Have never had this problem until a few days ago. Using Windows 7. I like to use sleep mode whenever I leave my desk (whether for a few minutes or several hours). Always has come back just as I left it (tabs, work in progress, etc.) until recently. If I restart, everything's fine, until I use sleep mode again. So vexing.

Chosen solution

Thank you for the tip. I disabled the accelerator as per your link and suggestions and the problem seems to have been solved, at least for now!

Read this answer in context 👍 0

All Replies (10)

more options

Try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
more options

If your laptop has an SD memory card slot, consider getting a flash card equal to or larger than the amount of memory in your laptop, and setting it up for ReadyBoost.

When you insert the card Windows may ask if you'd like to speed up your computer using the card. If not, go into Windows Explorer, right click the flash drive, hit properties, and enable ReadyBoost there. By default it will use the entire space on the card, which is recommended.

This should help with quicker recovery after sleep as the ReadyBoost memory card is faster to respond than the hard drive and Windows will keep the most recently used data there during sleep.

more options

Is the problem that Firefox needs a lot of time to return control to you, or that it simply never returns control to you? If it's the former, does it matter what sites were open when the Windows went to sleep?

Likely related forum threads (unsolved):

Two bugs have been filed recently relating to sleep on Windows 7 (64-bit). Neither seems to have progressed toward a solution as of yet:

(It was also posted on a closed bug: https://bugzilla.mozilla.org/show_bug.cgi?id=765215#c91.)

If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See:

more options

Chosen Solution

Thank you for the tip. I disabled the accelerator as per your link and suggestions and the problem seems to have been solved, at least for now!

more options

I seem to have thanked myself rather than you for the tip. I'm something of a novice. Don't know how that happened. Anyway, assuming I'm not making the same error, thanks much for the disable-accelerator tip, which seems to have fixed my problem. JP

more options

July 19, 2013

I finally fixed the Firefox freeze problem today. Had FF 22, Windows 7. So damn tired of the damn Firefox freeze because if I had tabs open I'd have to X out and lose them. The checkbox for hardware acceleration makes no difference.

The fix was very simple. Uninstall Java. Uninstall FF. Restart computer. Find and download Firefox 20 Beta 4. Go to java dot com and re-install Java and the problem is fixed.

Done. Tired of screwing around with this and having to set my computer never to sleep, because I'm a busy guy and glad I fixed it.

P.S. - When you uninstall Firefox, make sure you don't check the box that erases your personal data. It'll be obvious during the wizard so it's foolproof.

more options

Hi bayouboogie, why do you recommend an early beta version of Firefox 20 instead of the last released version? Why do you think there is the connection with the Java plugin??

Before going back to a vulnerable version of Firefox, it would make sense to try the beta of Firefox 23, which others have confirmed to work for them in another thread.

http://www.mozilla.org/en-US/firefox/all-beta.html

more options

I advocated the FF 20 Beta 4 because it worked perfectly the first time I invented the fix and tried it. I remembered specifically that the problem started with FF21 and so I decided at last to go back to the last version that I KNEW worked. I was 100% on the mark, in my case at least.

I tried everything, and I am quite methodical about what I do. The FF 20 Beta 4 fix works perfectly for me. The hardware acceleration checkbox does nothing for the problem.

I put up with this major pain in the butt for too long and finally solved it for myself. I am a happy camper now with my fix.

That said, are you telling me that FF 23 has fixed the bug? That would be great!

I am very busy right now, but when I get a chance, I will try it and post back my results.

Anyone else trying the beta 23, please report back.

As to your Java question, I'm not sure there is a connection at all. I just decided that if I was going to do a clean FF 20 b4 install, I wanted Java stripped out and reinstalled too. Let me say that I stripped out Java several times in the last couple months to address the freeze, but it didn't help.

IMO, Firefox itself was the problem

FF20b4 - no problem, and I'm happy as a clam now.

more options

Just to update this issue the FF 23 beta does not resolve the issue of hanging on start up for me.

more options

Hi dwinslow, the release version of Firefox 23 is out today, which might work better than your beta, depending on how old a beta you got.

Note that the fix relates to waking from sleep and not other startup issues. If your Firefox hangs in other conditions, you probably should start a new thread showing your OS info, add-ons, etc., for better diagnosis. You can do that here:

https://support.mozilla.org/questions/new/desktop/fix-problems