X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Please can you send me a fix for the error message that starts up when I open Firefox. It says " well this is embarrassing," and asks if I want to close the tab

Posted

Please can someone tell how to fix the problem I have with firefox on a mac OS. When firefox opens it comes up with an error message " well this is embarrassing...." and continues to ask if I want to close or restore the tabs that are open.

Does anyone have a simple fix?

Thank you

Beamer

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

FredMcD
  • Top 25 Contributor
114 solutions 1463 answers

Try this; First run virus scans to make sure you don't and....errr surprises. Then totally uninstall Firefox, but tell the uninstaller to save your preferences. Go to Mozilla.org to download a full copy of Firefox.

Helpful Reply

Thank you for this I will try it.

ideato
  • Top 25 Contributor
616 solutions 4262 answers

Helpful Reply

Hello Beamer, you must update to latest (21.0) version, the bug it is fixed in firefox 21!

https://bugzilla.mozilla.org/show_bug.cgi?id=845681

Update Firefox to the latest version


thank you