Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos plays sound and not the picture in firefox

  • 4 replies
  • 1 has this problem
  • 3883 views
  • Last reply by cfmilam

more options

When I try to watch a video embedded on a blog page, I only get the sound and not the picture. I can watch the same video just fine with Google Chrome

Chosen solution

I have resolved the issue by downloading and installing Real Player. I don't know why but the videos now play in Firefox. Thanks for your support and response.

Read this answer in context 👍 0

All Replies (4)

more options

Have you checked with another browser? Does this happen on one page, several pages, most, all pages? Is it just this site, some sits, all sites? Post a link to one of these sites so we can check it.

more options

This happens on different pages on Firefox only. Work fine on Google Chrome. Thanks for your reply.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin
more options

Chosen Solution

I have resolved the issue by downloading and installing Real Player. I don't know why but the videos now play in Firefox. Thanks for your support and response.