Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to stop babylon search from loading each time i open a new tab in firefox - ANSWER HERE TRY THIS IT WORKS


Close Firefox Open Firefox, it will go to F**$*n babylon Type About:Config in address bar, hit enter In the search bar type browser. Scroll down At > browser.newtab.url you will see listed a long string, this is what loads F**$*n babylon... Right Click on that line and select Modify Delete the string and leave http:// at the start Type in www.google.co.nz (if in New Zealand) or www.google.com or whatever page you want when you open a new tab! Go OK Close Firefox Open Firefox, and hopefully google is your home page anyway, but... when you click a new tab, you will get google, now F**$*n babylon Cheers from Ted in NZ

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • 5.1.20125.0
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • nptrademanager
  • AlternaTIFF v2.0.4
  • iTunes Detector Plug-in
  • D'Fusion Web Plugin (2.00.7057.0)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers


  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

  • Top 10 Contributor
2388 solutions 21097 answers

Hi Ted, some people are also going to need to remove an add-on that comes with Babylon, or even uninstall software from the Windows Control Panel. Hopefully you (or your cleanup software) already rooted those out.

For others reading this thread, here are some other values you can use for the new tab setting.

(i) Page thumbnails (default) or right-click > Reset


(ii) Blank tab


(iii) Built-in Firefox home page


(iv) Any other page

full URL to the page

You should see the change take effect immediately. You can press Ctrl+t to open a new tab and verify your change before closing about:config.

  • Top 10 Contributor
2388 solutions 21097 answers

Hi tayladeakin, spam posts are annoying, too. Please take that to some other site.

Babylon.Ltd 3 solutions 52 answers

I am from the support team at Babylon company. Babylon Search and Toolbar are meant to be a part of an integrated set of tools that help people understand and explore their world. Sometimes though, other manufacturers package our tools with their free programs and people end up unexpectedly receiving our software. We are sorry if this is the case with you and we would be happy to help you remove any part you may not want.

If you followed our removal instructions but when you open a new tab in Firefox, Babylon Search still appears, please try this:

1. Type in the address bar line about:config and press enter.

2. Confirm the popup message.

3. In the search field, type "Babylon". (remove excess text here)

4. Restart your Browser.

Helpful Reply

None of your replies worked sorry to say... but this does, I went to about:config and searching for 'babylon' brings no results, so i did a manual search and killed out babylons web address and I override it with my home page, as you will see in the attached screen shots... Cheers Ted (Flying Kiwi)

boral 0 solutions 15 answers

Helpful Reply

1) First I go to Tools > Options > General and there I reset my homepage.

2) Then I type about:config in address bar

3) Confirm the warning " I'll be careful, I promise " .

4) Searched for browser.newtab.url and right clicked it . Click reset .

Everything is ok then .

nuckyluy 1 solutions 2 answers

All u have to do is to uninstall babylon from your PC control panel and browser extension center, read this detailed babylon removal guide to get rid of babylon searach completely. http://www.virus-delete.com/en/guides/browser-hijacker-removal/20130814-how-to-remove-babylon-search-toolbar-through-isafe-virus-removal-tool.html Just try this simply method, and babylon searach will gone for good

Modified by nuckyluy