X
Tap here to go to the mobile version of the site.

Support Forum

How do I change the default background color for a webpage where none is specified?

Posted

Many versions ago I customized the background color if none was given to a brown to go with the skin I was using then.

Now I find displaying a simple text file is unreadable with unbolded black against the brown, but I cannot find in today's version where to set it back to white (or at least a pale color).

Any help appreciated.

Many versions ago I customized the background color if none was given to a brown to go with the skin I was using then. Now I find displaying a simple text file is unreadable with unbolded black against the brown, but I cannot find in today's version where to set it back to white (or at least a pale color). Any help appreciated.

Chosen solution

I think it must be the "Background" setting in the following dialog:

orange Firefox button (or Tools menu) > Options > Content > "Colors" button

Does that let you choose something lighter for pages that do not set their own color?

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Version 3.18.1.12731
  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Version 3.17.0.12440
  • Shockwave Flash 11.6 r602
  • GEPlugin
  • Google Update
  • 5.1.20125.0
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Updater pluginhttp://pack.google.com/
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

jscher2000
  • Top 10 Contributor
7875 solutions 64239 answers

Chosen Solution

I think it must be the "Background" setting in the following dialog:

orange Firefox button (or Tools menu) > Options > Content > "Colors" button

Does that let you choose something lighter for pages that do not set their own color?

I think it must be the "Background" setting in the following dialog: orange Firefox button (or Tools menu) > Options > Content > "Colors" button Does that let you choose something lighter for pages that do not set their own color?

Question owner

Yes! Thank you! Exactly what I kept missing in my hunt (I assumed that was font colors).

Yes! Thank you! Exactly what I kept missing in my hunt (I assumed that was font colors).
feltra 0 solutions 2 answers

Try using the "No Squint" addon. I just downloaded it and am using it - and so far am having a blast with it. Takes care of colors and some neat tricks like text-alone zooming...

Try using the "No Squint" addon. I just downloaded it and am using it - and so far am having a blast with it. Takes care of colors and some neat tricks like text-alone zooming...

Helpful Reply

My problem had already been solved by prior answers pointing me at Options, Content, Fonts & Colors, Colors. This needed no additional add-on.

My problem had already been solved by prior answers pointing me at Options, Content, Fonts & Colors, Colors. This needed no additional add-on.
RJRam 0 solutions 1 answers

While the options /content / color control is somewhat helpful.. this still does not answer the problem which I stated here a moment ago but I cannot seem find now.. so I'll repeat it..

for some reason every site I visit on my PC desktop using Windows 7 and Firefox as my browser .. appears to have no background color..its plain white every where I visit.. gmail, MSN my own personal sites, huffington post, CNN Fox news.. although the text does appear and the layout of the page also appears ..all is good except for the fact the background color and background images are missing on every site..

I believe this is some form of setting but like everything else in computer land nothing is easy to find.. every freaking setting is a mystery.. you almost have to play like a child to find out what this does and what that does.. I'm 62 so playing like a child really is a lot of fun these days.. the problem is a little of my livelihood relies on this PC gizmo so it pisses me off when I dont know how to fix.. learning how to fix is not the problem, finding the buttons and the settings and logical explanations to do just that is the problem.. any clues anyone ?

While the options /content / color control is somewhat helpful.. this still does not answer the problem which I stated here a moment ago but I cannot seem find now.. so I'll repeat it.. for some reason every site I visit on my PC desktop using Windows 7 and Firefox as my browser .. appears to have no background color..its plain white every where I visit.. gmail, MSN my own personal sites, huffington post, CNN Fox news.. although the text does appear and the layout of the page also appears ..all is good except for the fact the background color and background images are missing on every site.. I believe this is some form of setting but like everything else in computer land nothing is easy to find.. every freaking setting is a mystery.. you almost have to play like a child to find out what this does and what that does.. I'm 62 so playing like a child really is a lot of fun these days.. the problem is a little of my livelihood relies on this PC gizmo so it pisses me off when I dont know how to fix.. learning how to fix is not the problem, finding the buttons and the settings and logical explanations to do just that is the problem.. any clues anyone ?
jscher2000
  • Top 10 Contributor
7875 solutions 64239 answers

Hi RJRamsis, two settings that definitely could remove the page's background color/image are:

  • Overriding the page's choice of colors in the Options dialog here:

    orange Firefox button (or Tools menu) > Options > Content > "Colors" button

    make sure you have a checkmark for Allow pages to choose their own colors
  • Using a "High Contrast" theme in Windows

There are other ways that the page could be modified, but those are less common.

Since the original poster marked this thread as solved, to move forward on your issue, I suggest starting a new question. You can do that here: https://support.mozilla.org/en-US/que.../fix-problems (the form to start your question is below the article suggestions).

Hi RJRamsis, two settings that definitely could remove the page's background color/image are: * Overriding the page's choice of colors in the Options dialog here:<br><br>orange Firefox button (or Tools menu) > Options > Content > "Colors" button<br><br>make sure you have a checkmark for ''Allow pages to choose their own colors'' * Using a "High Contrast" theme in Windows There are other ways that the page could be modified, but those are less common. ''Since the original poster marked this thread as solved, to move forward on your issue, I suggest starting a new question.'' You can do that here: [https://support.mozilla.org/en-US/questions/new/desktop/fix-problems] (the form to start your question is below the article suggestions).
cor-el
  • Top 10 Contributor
  • Moderator
16659 solutions 150573 answers
Make sure that you haven't enabled a High Contrast theme in the Windows Accessibility settings. *http://www.microsoft.com/enable/products/windows7/default.aspx *httpwindows.microsoft.com/en-US/windows7/Getting-the-best-display-on-your-monitor *httpwindows.microsoft.com/en-us/windows7/turn-on-high-contrast See also: *http://kb.mozillazine.org/Website_colors_are_wrong