X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox on Linux wants to use notepad.exe to display a C source

Posted

I'm using Firefox 20.0 on two mostly identical i686 Linux systems (Crux 2.8). On system A, Firefox displays a local C source normally. On system B, it asks which external program it should use, and suggests notepad.exe (!!) as the default. What on earth could make Firefox running on Linux think it is on a Windows system?? Neither re-installing Firefox nor moving my .mozilla directory changed this behaviour.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/Linux/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 2.1 Mesa 9.0.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365757014
  • places.history.expiration.transient_current_max_pages: 77913
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
David Tenser
  • Administrator
  • Moderator
32 solutions 294 answers

Hi there,

This sounds like a configuration error, but it's hard for me to tell where that error might have been made. Vanilla Firefox definitely doesn't suggest "notepad.exe" as the source viewer on Linux builds, so either this is an issue with Crux's build of Firefox, or maybe you copied your prefs.js file at some point from a Windows machine?

Either way, if you're familiar with about:config, you can restore this by searching for the "view_source" settings. Just filter for that and you should find view_source.editor.path. I'm guessing it now says "notepad.exe", but you can change this to anything you prefer, e.g. gedit, or whichever your favorite editor is.

Hope this helps.

Cheers, David

Question owner

David, thanks for the extremely quick answer! I have of course looked into about:config, but "notepad" definitly doesn't appear there. I made a recursive grep in my (freshly generated) .mozilla directory as well as in usr/share/mime - no results. This is weird. The point is, I don't want to edit the file, I just want to see it. From another discussion I just learned that I can prefix the URL with "view-source:". That works indeed. I'm still curious why two otherwise completely equal Firefox installations behave so differently. Regards, Bernd

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

See also this extension:

Helpful Reply

Ah yes, that's a useful extension. Thanks! Bernd