X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I get the erroor message 'couldn't load XPCOM' but only when i try to access my Netflix Desktop App . I have tried unsuccessfully to corect this. My OS is Linux

Posted

After the last Firefox update to Firefox 19.0.2, I got the error message "Couldn't load XPCOM" when i attempted to open my Netflix Desktop App, I did not get that error message when starting Firefox only when trying to open Netflix. I thought it had something to do with Netflix so I removed it then reinstalled but the error message continued. I searched and asked questions to no avail. I did a command line search: "locate /xpcom" It came up with a list of files relating to xpcom, only one refering to Firefox itself and they all ended with xpcom.dll. When i did a search in the File folder I found this: usr/lib/firefox/libxpcom.so .

One of the people trying to help told me this: "The error is caused by the lack of the path "/usr/lib" in the environment variable LD_LIBRARY_PATH Solution Add the /usr/lib path to the environment variable in this way: export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH"

I was informed to do the following:

"Get to a command line prompt (CLP) and use gedit to add that line to your .bashrc file: your.account> gedit .bashrc when you're done, just save and exit. Log out and back in, and from then on whenever you log in, it will be in the LD_LIBRARY_PATH for you. You might also want to copy .bashrc to some sort of saved version; I use bashrc.sav."

No change.

I have done a reinstallation of Firefox and numerous reinstallation of Netflix all with no change.

Is there a chance that a complete removal of Firefox followed by a reinstallation correct the problem? i don't want to do that unless it is the only solution.

Oddsbodkin

Additional System Details

Installed Plug-ins

  • Version: 3.16.0.0
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • This is the DjView-4.9 version of the DjVu plugin.See DjVuLibre.
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The IcedTea-Web Plugin executes Java applets.
  • DivX Web Player version 1.4.0.233
  • The Totem 3.0.1 plugin handles video and audio streams.
  • Version 2.0.5 Twoflower, copyright 1996-2011 VideoLAN and Authorshttp://www.videolan.org/vlc/
  • 4.0.51204.0

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/Linux/en-US/

Extensions

  • AniWeather 0.8.37 ({4176DFF4-4698-11DE-BEEB-45DA55D89593})
  • Global Menu Bar integration 3.7.2 (globalmenu@ubuntu.com)
  • Greasemonkey 1.8 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • ImTranslator 5.2 ({9AA46F4F-4DC7-4c06-97AF-5035170634FE})
  • Novell Moonlight 3.99.0.3 (moonlight@novell.com)
  • Personas 1.6.5 (personas@christopher.beard)
  • Personas Rotator 6.8 ({6e73f6b7-b9ab-44b8-b744-6393e3c2e351})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.6 (ubufox@ubuntu.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 7300 LE/PCIe/SSE2
  • adapterDeviceID: GeForce 7300 LE/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 2.1.2 NVIDIA 304.48
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- GeForce 7300 LE/PCIe/SSE2
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130307122853
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1363630211
  • places.history.expiration.transient_current_max_pages: 52734
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
patrickmc
  • Administrator
  • Moderator
23 solutions 174 answers

Hello Oddsbodkin,

It looks like you are missing the semi-colon at the end of your command to add the library path. Can you try adding the string to your .bashrc file?

export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH;

Let me know if you continue to see this issue.

Cheers, Patrick

Helpful Reply

The missing semi-colon was a typo. When I installed the line in the .bashrc 'LD_LIBRARY_PATH=/usr/lib/lib:$LD_LIBRARY_PATH:' I did not add the prefix 'export' Would that make any difference? Also would it be neccessary to add to the end of the LD_LIBRARY_PATH, the following: '/usr/lib/firefox/ netflix-desktop' ?

Is it possible that my WINE may be a factor?

Oddsbodkin

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

Make sure that you meet the system requirements for the current Firefox version (especially GTK+ and glib).

Question owner

i am still having the stupid issue with 'couldn't load xpcom' Patrick, I placed: export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH; at the end of the .bashrc which i found by opening a terminal and entering; gedit .bashrc. i had deleted netflix prior to this, then reinstalled but I still got the blasted error message. This is going no where and i am sick and tired from trying to get this to work. Consider this post CLOSED, not solved but CLOSED!!!!

patrickmc
  • Administrator
  • Moderator
23 solutions 174 answers

Hello Oddsbodkin,

It looks like the creator of Netflix Desktop has a site for the project here:

https://answers.launchpad.net/netflix-desktop/

I would try posting your question there and see if anyone else has encountered this error and has a solution.

Cheers, Patrick

franklogullo 0 solutions 1 answers

I had this problem & traced it to a failed wine installation. You will want to goto your home directory, do a search for a direction with .wine in it, and delete it. ( No guarantee the name is .wine, or .wineX , so do an ls and grep for .wine ). After deleting the directory (in my case rm -rF .wine ), you can click on the netflix desktop icon, and then wine will get reconfigured for you. After that happens, netflix will work. Key thing to know is , wine must be configured correctly for netflix desktop to work.