X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The Firefox PDF viewer won't render drop-shadows created within Adobe InDesign. It replaces them with a flat gray box.

Posted

The new built-in Firefox PDF viewer won't render gradient drop-shadows created within Adobe InDesign. It replaces them with a flat gray box - no matter what shape it sits behind. Is there a fix for this problem?

Chosen solution

Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

See also:

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • Office Live Update v1.0
  • Pando Web Installer
  • DivX Web Player version 1.4.1.4
  • RealPlayer Plugin
  • npmnqmp 071505000006
  • iPhoto6

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/Darwin/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6760
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6490M OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.boston.com
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.max_script_run_time: 0
  • extensions.lastAppVersion: 19.0.2
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1363702103
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1326809412
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Chosen Solution

Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

See also:

Helpful Reply

Thanks for you quick response! Much appreciated.

I apologize. I guess I should have included that we're posting PDFs on our websites and are concerned that others who are accessing them are viewing the glitchy images. I'm assuming there's no fix for this problem at this time, but perhaps with future versions it will be rectified?

The good news is that when they're downloaded, they're fine.

Thanks again.

fallulafirst 0 solutions 1 answers

I am having the exact same issues. We upload larger pdf's frequently to send to our clients for approval and if they viewing the link through the new firefox pdf viewer they are seeing these issues (boxes where the drop shaddows should be). Most annoying!

I hope this gets fixed soon.

Cheers