X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to edit the default Search engine URL from https://www.google.com to http://www.google.co.in

Posted

Hi,

i upgraded to Firefox 19.0.2 Version. After the upgradation my search engine ( Google ) not working. We have a proxy server. https requests will block by the proxy. So I need to edit the search engine URL from https://www.google.com to http://www.google.co.in. Thanks in Advance

Mithu

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • VLC media player Web Plugin 2.0.2

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Anti-Banner 13.0.1.4250 (anti_banner@kaspersky.com) (Inactive)
  • Content Blocker 13.0.1.4250 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4250 (url_advisor@kaspersky.com) (Inactive)
  • Safe Money 13.0.1.4250 (online_banking@kaspersky.com) (Inactive)
  • Virtual Keyboard 13.0.1.4250 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16384
  • driverDate: 10-9-2012
  • driverDate2:
  • driverVersion: 8.15.10.2858
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.co.in/
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.direct3d.checkDX10: False
  • keyword.enabled: False
  • keyword.URL: http://www.google.co.in
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362633329
  • places.history.expiration.transient_current_max_pages: 102076
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
finitarry 157 solutions 2184 answers

Helpful Reply

Do you mean the search engine you get from searching from the address bar, or do you mean the default search plugin? If the former, use keyword.URL in about:config and use http rather than https in the URL. If the latter, what I do is put the search plugin name into browser.search.selectedEngine in a user.js file so that gets set up every time the browser launches. You would need to get a search plugin with a URL with http instead of https. Those files are .xml files and can be edited with a text editor.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Helpful Reply

Which search method(s) do you want to modify?

  • searching via the location bar (pref: keyword.URL)
  • search bar on the Navigation Toolbar
  • search bar on the about:home page (pref: browser.search.defaultenginename)

For the location bar see:

You can find more search engines on the Mycroft Project site.

Modified by cor-el

Question owner

Thanks Ms. cor-el,

http://mycroft.mozdev.org/search-engines.html works for me. Meanwhile My friend Prajod find out another way. That also works fine. What he did was copied the search plugin from Firefox Version 8 and paste in the C:\Program file\Mozlla Firefox\Search Plugins\ directory. I tried adding the search plugin "google US" from the URL given in your mail. That also works.

Thanks a lot, Mithu ...

Question owner

Dear Ms.Finitarry,

I tried editing the xml file via notepad and changed the https to http. But it was not working. Anyways thanks for the suggestion. I got the solution from Mr. Prajod and Ms. Cor-el.

Thanks... Mithu ...