X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Lately pdf files from the Web do not display properly; what is wrong and how can I fix it so I don't have to use IE?

Posted

I am a professor and frequently need to open pdfs of academic journal articles from electronic databases. Within the last two or three weeks, when I try to do this using Firefox, only the first page of the pdf displays and the rest are blank. In addition, a bar appears across the top with the message "This pdf file may not display properly." So I have had to switch to Internet Explorer to open the files and do my research. What is going on and how can I fix it so I can open pdf files from the Web in Firefox and have them display properly?

Chosen solution

hello, firefox 19 has introduced its own integrated pdf viewer - if you want to switch back to the plugin you've used before to view pdfs just go to firefox options > applications & scroll down and define the default action for the portable document format (pdf).

How to disable the built-in PDF viewer and use another viewer

Read this answer in context 22

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • 5.1.10411.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Application Basics
Name
Firefox
Version
19.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Symantec Intrusion Prevention
11.1.1.5 - 3
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Skype Click to Call
6.6.0.11664
false
{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.virginia.edu/
browser.startup.homepage_override.buildID
20130215130331
browser.startup.homepage_override.mstone
19.0
extensions.lastAppVersion
19.0
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
gfx.blacklist.suggested-driver-version
257.21
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1362066998
places.history.expiration.transient_current_max_pages
53369
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA Quadro NVS 160M
Adapter Drivers
nv4_disp
Adapter RAM
Unknown
Device ID
0x06eb
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
DirectWrite Enabled
false (0.0.0.0)
Driver Date
8-1-2008
Driver Version
6.14.11.7626
GPU #2 Active
false
GPU Accelerated Windows
0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
Vendor ID
0x10de
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8899 answers

Chosen Solution

hello, firefox 19 has introduced its own integrated pdf viewer - if you want to switch back to the plugin you've used before to view pdfs just go to firefox options > applications & scroll down and define the default action for the portable document format (pdf).

How to disable the built-in PDF viewer and use another viewer

Question owner

Thanks. I tried resetting the default to both "Adobe Acrobat" and "Adobe Acrobat (in Firefox)". Either way works to get a properly displayed pdf, although both seem to be a little slow. I left it on "Adobe Acrobat (in Firefox)".

What's wrong with Firefox's built-in pdf viewer? Does it have a bug that needs to be fixed?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

The integrated PDF viewer is still under development and works fine for simple PDF files, but a lot of advanced features aren't supported yet and there are still a lot of bugs open.

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

pgwebgirl 0 solutions 1 answers

I sure hope that this BUG will be fixed soon, it is a big BUG, my professional pdf document was destroyed by the viewer, it does not handle transparencies in the document pdf at all, ....there are no simple pdf files anymore except plain word documents....clients will be contacting me to find out why my beautiful pdf brochure looks so bad on the web - I am happy to have found this explanation though - firefox has been having more and more problems lately - I am wondering why firefox would move away from the Acrobat Reader when that is so common everywhere on the web

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

For now you can try this workaround and make use of Bug 738967.

Using an embed tag seems Firefox making to use the Abode Reader plugin in Firefox and an object tag defaults to the build-in PDF Viewer if enabled.

acehwd 0 solutions 1 answers

I followed both of the work around solutions posted both in preferences and adjusting the disable value to true. Neither solution has corrected the problem. I use Firefox for a cloud based inventory software and I have to download and print PDFs everyday so this issue makes Firefox less attractive then IE.

bobby-b 0 solutions 1 answers

Helpful Reply

My question is simple - why would you put an application in production that has a lot of bugs? To replace a good and steady Adobe product? My customers will believe that I put a pathetic fallible form online. They are not sophisticated on computers so I just tell them to use IE. Ugh

I must agree with pgwebgirl!

rtrimble 0 solutions 2 answers

I started seeing the error bar 1-2 months ago on all PDFs that are fillable (such as IRS forms). The PDFs display but cannot be modified. I have switched Options -> Applications back and forth between "Use Adobe Acrobat (in Firefox)" and "Use Adobe Reader (default)", shutting Firefox down and restarting it each time, of course. There is no change in the symptom either way. Actually, there are three PDF entries in my application table, and I changed all three of them:

- Adobe Acrobat Forms Documents (application/vnd.adobe.xfdf)

- Adobe Acrobat Forms Documents (application/vnd.fdf)

- Adobe Acrobat XML Data Package File

System and product levels:

- Windows 7 Home Premium SP1

- Firefox 19.0.2

- Add-ons Manager says the Adobe PDF Plug-In is Adobe Acrobat 11.0.2.0 for Firefox and Netscape. Last Updated Friday, February 15, 2013

- Adobe Reader XI Version 11.0.2, which works correctly outside Firefox

I do not have Adobe Acrobat installed.

Modified by rtrimble

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can also check the value of the plugin.disable_full_page_plugin_for_types pref and remove the application/pdf part if present.

See also:

rtrimble 0 solutions 2 answers

Setting pdfjs.disabled to true was not what I wanted; it just forced the PDFs to be downloaded. But removing application/pdf from plugin.disable_full_page_plugin_for_types solved my problem.

Note for other novices: DON'T click reset on that pref. The reset value is empty, and there is no "un-reset", as I learned to my dismay. Just modify it as cor-el said.

annette62 0 solutions 1 answers

I have been a preferred user of Firefox for many years and encourage my clients to install it on their systems. However, lately I and many of my clients have been experiencing terrible trouble with downloading pdfs. I know you have answers in regard to disabling etc but when I upload a pdf to a website and it doesn't view properly in FF, you cant explain that to everyone who visits the site. TO me it's unacceptable to launch something that is only half baked. I deal a lot with the tourism industry and many of my clients are uploading nice brochures to entice visitors but the pdfs in FF are looking very uninviting and that is not the case. I hope this issue will be seriously looked at and either removed until it's fully functioning properly or giving a clear option to viewers that they can view it in Adobe Reader as well.

gmkall 0 solutions 1 answers

In FF Verison 22.0 and Nightly Build 25.01, Windows 64bit this or a similar problem is yet not solved with (default) setting "Preview in Firefox" for Type pdf:

The embed Element src attribute is called multiple times (in my case it is a relative link) and the Response Content-Type is set to text/html. An embed Element with type application/pdf has NOT set the HTTP Header Content-Type application/pdf.

The reason seems to be that the base URL is not set properly: Instead of using the base tag element (in our case ending with a slash) the current URL (page address) is used! All the other errors seem to be subsequent errors...

If I change the Setting to "Ask..." the Content-Type is not set either, but the web server handles this correctly responding at least with the correct type.

This is a not resolved bug in my eyes:

"A embed Element with type pdf having a relative src attribute appends to page address URL instead of Base url (mode Preview in Firefox)".

P.S.: If I change the embed src - Element to an absolute URL anything works fine!

Modified by gmkall